Getting sound and video[fixed thank you]

Getting sound and video
I belive there is 3 different sources

  • Web or real player
  • CD’s/DvD’s
  • .[can’t remember this one or] is it utube ?

Ive got dvd and some web vision but no sound
I have tryed before with 2 different head set’s and there all coded I’ve just tryed a web tutorial no sound

Are you saying sound doesn’t work at all ?

Have you clicked the little speaker icon by the clock and selected “Unmute” ?

If that doesnt’ work, send the output from:

sudo lshw -C multimedia

and remind me which distro/version you are running… I can’t remember what everyone is using ?

gordon@gordon-desktop:~$ sudo lshw -C multimedia
[sudo] password for gordon:
*-multimedia
description: Audio device
product: 82801H (ICH8 Family) HD Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 02
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list
configuration: driver=HDA Intel latency=0
resources: irq:47 memory:50420000-50423fff
gordon@gordon-desktop:~$
I’m using ubuntu 10.10 think I’ got all the video now but no sound

I be back late wednesday now ?

Jeez… will you EVER answer all my questions ?

WHAT LINUX DISTRO ARE YOU USING, AND WHAT VERSION ?
and
ARE YOU SAYING SOUND DOESN’T WORK AT ALL ?
and
ARE YOU SURE THE SOUND ISN’T JUST MUTED ?

is this sigfificant
(firefox-bin:2637): Pango-WARNING **: shaping failure, expect ugly output. shape-engine=‘BasicEngineFc’, font=‘文泉驛正黑 Medium 14.6669921875’, text=‘日本語’
it only appears when I launch a help through firefox
absolutely no sound
I’d allready tryed the muted button all apps appear to have only one button it’s on full - unmutting ?
Distro I thought I had ubuntu 10.10 is that not what you mean’t ?

I'd allready tryed the muted button all apps appear to have only one button it's on full - unmutting ?

I don’t mean unmuting in an application… I mean in the OS.

Do like I said… Click the little speaker icon by the clock and selected “Unmute” (if its muted).

Distro I thought I had ubuntu 10.10 is that not what you mean't ?

That’s exactly what I mean… but you can’t expect me to remember what distro/version YOU have if it isn’t mentioned somewhere in the current thread… also, how am I supposed to know whether you have changed disrto or upgraded, remember Ubuntu 11.04 has recently been released.

When you start a new thread… it’s a good idea to mention your distro/version again.

OK back to the problem.

No the b: Pango-WARNING[/b] has nothing to do with the sound issue, that’s firefox bitching about some font(s)… we’ll come back to that later if necessary.

Post the output from:

cat /proc/asound/card0/codec#* | grep Codec

I made sure it is unmuted OS afraid its what I know, but still no sound on any app ?
If I remember right you helped me do something before and said that is all the codec’s you will ever need ?
gordon@gordon-desktop:~$ cat /proc/asound/card0/codec#* | grep Codec
Codec: SigmaTel STAC9227
gordon@gordon-desktop:~$

Different type of codec… that is the hardware codec chip on the soundcard, not the software audio/video codecs.

Open a terminal, and enter:

sudo sh -c 'echo options snd-hda-intel model=ref probe_mask=1 >> /etc/modprobe.d/alsa-base.conf'

Reboot, and see if sound works.

If it doesn’t, tell me a bit more about the soundcard.

Is this a laptop ? … if so what make/model ?

how many jack plug sockets are there on the card ?

Also send the output from

aplay -l

No change, no it’s not a lap top, it has three sockets for the jacks built-in to the motherboard
gordon@gordon-sdesktop:~$ sudo sh -c ‘echo options snd-hda-intel model=ref probe_mask=1 >> /etc/modprobe.d/alsa-base.conf’
[sudo] password for gordon:
gordon@gordon-desktop:~$

gordon@gordon-desktop:~$ aplay -l
aplay: device_list:235: no soundcards found…
gordon@gordon-desktop:~$

OK, run:

sudo gedit /etc/modprobe.d/alsa-base.conf

find the last line that reads:
options snd-hda-intel model=ref probe_mask=1

and change it to:
options snd-hda-intel model=3stack

SAVE the file and exit gedit.

REBOOT… and see if your soundcard works.

If not, send the output from

asound -l

is this a typo ?

gordon@gordon-desktop:~$ asound -l
No command ‘asound’ found, did you mean:
Command ‘csound’ from package ‘csound’ (universe)
asound: command not found
gordon@gordon-desktop:~$ csound -l
The program ‘csound’ is currently not installed. You can install it by typing:
sudo apt-get install csound
gordon@gordon-desktop:~$

yes… my mistake:

aplay -l

and

sudo lshw -C Multimedia

the output is ?

gordon@gordon-desktop:~$ aplay -l

**** List of PLAYBACK Hardware Devices ****

card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]

Subdevices: 0/1

Subdevice #0: subdevice #0

gordon@gordon-desktop:~$

gordon@gordon-desktop:~$ sudo lshw -C Multimedia

[sudo] password for gordon:

*-multimedia

   description: Audio device

   product: 82801H (ICH8 Family) HD Audio Controller

   vendor: Intel Corporation

   physical id: 1b

   bus info: pci@0000:00:1b.0

   version: 02

   width: 64 bits

   clock: 33MHz

   capabilities: pm msi pciexpress bus_master cap_list

   configuration: driver=HDA Intel latency=0

   resources: irq:47 memory:50420000-50423fff

gordon@gordon-desktop:~$

OK, run:

sudo gedit /etc/modprobe.d/alsa-base.conf

find the last line that reads:
options snd-hda-intel model=3stack

and change it to:
options snd-hda-intel model=ref

SAVE the file and exit gedit.

REBOOT… and see if your soundcard works.

If not, send the output from

aplay -l

and

lsmod | grep snd

You might also want to play with the settings in alsamixer, and see if anything is muted.

aslamixer

is it normal to have the device listed twice ?

gordon@gordon-desktop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
gordon@gordon-desktop:~$

gordon@gordon-desktop:~$ lsmod | grep snd

snd_hda_codec_idt 54919 1

snd_hda_intel 22235 0

snd_hda_codec 87552 2 snd_hda_codec_idt,snd_hda_intel

snd_hwdep 5040 1 snd_hda_codec

snd_pcm 71475 2 snd_hda_intel,snd_hda_codec

snd_seq_midi 4588 0

snd_rawmidi 17783 1 snd_seq_midi

snd_seq_midi_event 6047 1 snd_seq_midi

snd_seq 47174 2 snd_seq_midi,snd_seq_midi_event

snd_timer 19067 2 snd_pcm,snd_seq

snd_seq_device 5744 3 snd_seq_midi,snd_rawmidi,snd_seq

snd 49038 9 snd_hda_codec_idt,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device

soundcore 880 1 snd

snd_page_alloc 7120 2 snd_hda_intel,snd_pcm

gordon@gordon-desktop:~$

Yes for HDA devices… one is analogue, and one is digital.

I take it that it’s still not working ?

have you tried adjusting sound levels in alsamixer ?

I have partial sound you tube, web tutorials and I can play a mp4 saved on my computer are OK but If I play a DVD I know some times get sound some times the picture frezae or jumps finishing with the “errors pa_stream_cork() Failed” and “pa_stream_writable_size failed:” both finish with connection terminated

That’s handy info…

OK, this seems to be related to a known bug in either gstreamer, or pulseaudio… see here:

First, make SURE Synatic, Ubuntu Software Centre, and Update manager are ALL CLOSED.

Lets try adding the PPA mentioned and then updating those packages…

First let’s install the ppa-purge package, so we can back out of the changes easily if necessary:

sudo apt-get install ppa-purge

If the above command fails with ANY errors, STOP NOW, and let me know… DO NOT carry on with the following instructions yet.


OK, now let’s add the PPA:

sudo add-apt-repository ppa:diwic/fighting-rewinds

then update the package cache and upgrade the system

sudo apt-get update && sudo apt-get upgrade

Now reboot, and check your audio.

Thank you that does appear to have fixed the audio I’ve got all 3 playing with audio and vision Thank you again for all your help