Google Drive on Linux

Ok, so I just added Google Drive to my Ubuntu 12.04 desktop, seems to work fairly well and on my Infinity connection, it’s very quick!

Details here;

It integrates with the Ubuntu file browser by creating an “Insync” folder under your home folder.
I’ve found “one” bug thus far, there’s no GUI option to create a new folder on Google drive … however dragging/dropping existing folders works fine, so you can create a new / empty local folder and just drop it onto the lsync folder to create a new GD folder.

  • You get 5G by default (for free) so this is actually quite a useful service, and there is a rumour that Google might be upping this to 10G of free space (!) [and it integrates with Google Docs and GMail … so you get all your storage in one place …]

I was going to take a look at this in Peppermint 3 … but it wanted to remove dropbox :o

Not to mention their command to download/install the GPG key was wrong, and should read:

wget -qO - https://d2t3ff60b2tol4.cloudfront.net/services@insynchq.com.gpg.key | sudo apt-key add -

@Mad Penguin, you can use Insync to create a new folder on GDrive simply by creating a new folder inside your ~/Insync/username@gmail.com/ folder using Nautilus, or any other file manager.

@Mark Greaves, I have Dropbox installed along side Insync, and I combine the two with symlinks, it works fine. Insync will not replace or remove dropbox. Did apt-get try to remove dropbox? If so please post the error here, or in the Insync forums.

Hi bretth, and welcome to the forum :slight_smile:

I wasn’t saying it would remove dropbox on most Linux systems … but Peppermint has it’s own dropbox integration for the LXDE desktop which uses the pcmanfm file manager … directly from the Peppermint specific PPA … and in this case, YES Synaptic, Software Centre, and apt-get wants to remove it.

if you want to take a look at the peppermint-dropbox_3.0.0_all.deb, you can find it here:
http://ppa.launchpad.net/kendalltweaver/peppermint/ubuntu/pool/main/p/peppermint-dropbox/

It’s simply that there’s no version for the LXDE desktop with pcmanfm as the file manager … so I tried the “Generic” version.
(it’s quite possible I could change to using Thunar, and use the Xfce version, then install dropbox in the normal fashion … but I like pcmanfm)

IIRC, I used the “Generic Installer” version (which your site says - “use this if you’re not using Cinnamon, GNOME Shell, KDE 4, MATE, or Xfce”) which wanted to install nautilus which conflicts with peppermint-dropbox … but I could be wrong … if you want me to try again, and tell you exactly what the issue was, let me know :slight_smile:


[EDIT]

mark@AA1-Blue ~ $ sudo apt-get install insync-beta-ubuntu Reading package lists... Done Building dependency tree Reading state information... Done The following extra packages will be installed: brasero brasero-cdrkit brasero-common dvd+rw-tools gir1.2-nautilus-3.0 gnome-desktop3-data growisofs hwdata libbrasero-media3-1 libexempi3 libgmime-2.6-0 libgnome-desktop-3-2 libquvi-scripts libquvi7 libtotem-plparser17 [b]nautilus[/b] python-nautilus wodim Suggested packages: vcdimager dvdauthor readom cdrskin cdrdao eog gnome-sushi cdrkit-doc [b]The following packages will be REMOVED peppermint-dropbox[/b] The following NEW packages will be installed brasero brasero-cdrkit brasero-common dvd+rw-tools gir1.2-nautilus-3.0 gnome-desktop3-data growisofs hwdata insync-beta-ubuntu libbrasero-media3-1 libexempi3 libgmime-2.6-0 libgnome-desktop-3-2 libquvi-scripts libquvi7 libtotem-plparser17 [b]nautilus[/b] python-nautilus wodim 0 upgraded, 19 newly installed, 1 to remove and 0 not upgraded. Need to get 10.3 MB of archives. After this operation, 30.7 MB of additional disk space will be used. Do you want to continue [Y/n]?

It seems peppermint-dropbox contains an executable script which it installs at /usr/bin/nautilus that just contains:-

#!/bin/bash
pcmanfm $1 $2 $3 $4 $5 $6

So if Insync wants to install the full nautilus that would be overwritten, destroying calls to nautilus being passed to pcmanfm instead.

so they’ve added:-

Conflicts: mint-dropbox, nautilus

to the peppermint-dropbox DEBIAN control file.

I wasn’t saying it was an insync “issue” as such … just that it’s not for Peppermint/LXDE/pcmanfm :slight_smile:

.

Hi Mark. I’d just like to clarify that the difference between the command in our website and the one you posted here is that this one has no output (it has the quiet flag switched on). When I tested them they both worked the same. Thanks.

Why are you guys so tetchy ? … again, it may be something on my system, but (as you said) it sure as heck isn’t going to hurt for people to use the ‘quiet’ option, where not using it causes the command to hang.
(I’m not slagging insync off … I’m just relating MY experiences with attempting to install the insync beta on Peppermint 3 32bit, which if it helps is Ubuntu/Lubuntu 12.04 based)

Proof -

WITHOUT the quiet option

http://linuxforums.org.uk/MGalleryItem.php?id=1562

WITH the quiet option

http://linuxforums.org.uk/MGalleryItem.php?id=1564

Maybe I phrased it badly, but as you can see yours doesn’t prompt for my password so doesn’t complete … mine does.

.

Hi Mark.

I can understand the problem now. The command without the quiet option does prompt for the password. However it is buried in the sea of output. You can see it at around the 6th line in your first screenshot ([sudo] password for mark: Resolving d2t3ff60b2tol4.cloudfront.net …)

Adding the quiet flag really does seem to be the better choice here. We would update our website to reflect this. Thanks.

Heh … you’re right, it never crossed my mind to attempt to enter my password at the bottom (which would have worked, I’ve just tested it), how unobservant of me :-[ … but yeh, the quiet option probably does make more sense if the password prompt is going to get buried like that, I’d bet I’m not the only one who’d be confused by that …

Thanks for the feedback :slight_smile: