Gramps missing dependencies (SOLVED)

HI guys

I recently installed Lubuntu to give it a whirl, and I installed gramps from synaptic, but when I try to open gramps I get 2 error messages one after the other as per screenshots

If I close each error message in turn Gramps will continue to load presumably minus some functionality

I have Gramps installed in Peppermint 4 and I don’t have this problem, has anyone any idea why this i’m having it now ?

Many thanks


Which version of gramps is in 14.04 ?

Do you use image metadata, and/or OsmGpsMap for Geography ?

Which version of gramps is in 14.04 ?

4.0.3+dfsg ( I have no idea what +dfsg means

Do you use image metadata, and/or OsmGpsMap for Geography ?

If I knew exactly what that meant I could answer that I use images but I dont really care about the metadata I’m not sure what OsmGspMap means but I honestly don’t think it matters to me

So long as not having these things doesn’y screw up what I already have I don’t really care, it’s just that I’ve never seen those error messages before

Many thanks


Seems there’s a LOT of stuff missing for Gramps 4.0.3 in Ubuntu / Lubuntu 14.04 (Trusty Tahr)…

I don’t think any of it is critical, but it does reduce functionality by disabling some included Gramps plugins.

If you see these error dialogs / messages
OsmGpsMap module not loaded
GExiv2 module not loaded
here’s the fix

Fix tested in Lubuntu 14.04 (32bit) … but should apply to all buntu’s
(should also apply to Peppermint 5 when released)

OK, first you’ll need to enable the “Proposed” repo, so go to:-

menu > Preferences > Software & Updates > Updates (tab)

Make sure there’s a tick in “Pre-release updates (trusty proposed)” … and click “Close” … if it ask to let it update, say yes.

When that’s closed, open a terminal and run:

sudo apt-get update


sudo apt-get install gir1.2-gexiv2-0.10 gir1.2-gtkspell3-3.0 python-pil rcs graphviz-doc libosmgpsmap-dev python3-bsddb3 python-pygoocanvas gir1.2-goocanvas-2.0-9 python-pyexiv2 python-osmgpsmap gir1.2-osmgpsmap-1.0 libosmgpsmap-1.0-0

Now try Gramps

Please let me know if this fixes the issue for you too, so I can document it for Peppermint 5 :wink:


Here’s what OsmGpsMap gives you in Gramps … see here:

GExiv2 - gexiv2 is a GObject wrapper around the Exiv2 photo metadata library. It allows for GNOME applications to easily inspect and update EXIF, IPTC, and XMP metadata in photo files of various formats

Yeah that fixed everything perfectly

Many thanks


No problem … it’s handy figuring out things that may apply to Peppermint 5 ahead of time :slight_smile:

Thanks for the solution. At this point on 14.04.3, the packages you list still do the trick, but you do not need to add the proposed repository (at least for me).

Thanks for that update, and welcome to the forum :slight_smile:

Fixed my problem. Just wanted to let you know. Thanks.
Running Xubuntu 14.04

Great stuff, good to know it still works and you found it useful … and welcome to the forum :slight_smile:

This also worked for me just now. Thank you. :slight_smile:

Hi drew2222 and welcome to the forum :slight_smile:

Thanks for the update … good to know it still works.