Grub does not work properly

I have this Olibook s1530 laptop with Ubuntu 18.04 and Windows 10 in dual boot.
Previously I had Ubuntu 16.04 and Windows 10.
My problem is that Grub 2.02 does not work properly: it is blocked and does not let me choose Win 10.
Sometimes it is blocked on Ubuntu 18.04 and goes on on its own but then I am not allowed to enter Ubuntu password. I have to shut down and reboot several times until it works
I had this problem with Ubuntu 16.04 and thought it was due to a bug so I freshly installed 18.04 and for a while everything was fine but after a while the same problem happened.
I tested the HD and is OK. Could it be the keyboard that is faulty? But then the keyboard eventually works. I tried an external keyboard but the same thing happens.
I tried running Boot Repair Disk but that has not solved the problem.
I am upset because this is the best laptop I have and want to take it withg me on a journey but I would hate to have this problem after I leave.
Can anyone help?
Thanks a lot and best regards

Are you able to enter the BIOS every time ?

ie. Is the keyboard always active BEFORE you get to the GRUB menu ?

Thank you.
Yes, I am able to enter the BIOS every time.
I don’t know if the keyboard is active. How do I check?