Grub2 upgrade

Morning everyone!

I’ve upgraded from Grub Legacy to Grub2 and now I’m trying to install a Grub config tool but with no success!

Grub Customizer isn’t in Synaptic and attempting to download via Terminal gives this error -

$ sudo add-apt-repository ppa:danielrichter2007/grub-customizer
[sudo] password for richard:
You are about to add the following PPA to your system:
This PPA contains the latest release of Grub Customizer.

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer
More info: Launchpad PPA for Grub Customizer : Daniel Richter
Press [ENTER] to continue or ctrl-c to cancel adding it

Traceback (most recent call last):
File “/usr/bin/add-apt-repository”, line 160, in
sp = SoftwareProperties(options=options)
File “/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py”, line 96, in init
self.reload_sourceslist()
File “/usr/lib/python2.7/dist-packages/softwareproperties/SoftwareProperties.py”, line 584, in reload_sourceslist
self.distro.get_sources(self.sourceslist)
File “/usr/lib/python2.7/dist-packages/aptsources/distro.py”, line 87, in get_sources
raise NoDistroTemplateException("Error: could not find a "
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template

Now - I’m running Mint 13 KDE, which can be a bit quirky to say the least ::slight_smile: and KDE has it’s own tool - kcm-grub2. For the life of me I can’t get this installed! It’s not in Synaptic and Terminal returns this -

$ sudo apt-get install kcm-grub2
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package kcm-grub2

Have I missed something?

It’s not critical - I’m just learning about the system but I’d like to tidy up the grub menu and add a few colours etc… all part of the process? :wink:

TIA

Rich

Hi Richard

If you want Grub Customizer you need to add the ppa to your sources list, you’ll find the ppa here

Good luck

Graeme

If you want kcm-grub2 run:

sudo apt-get install kde-config-grub2

Word of advice … before messing with tools like this, backup the grub configuration files:

sudo cp -v /boot/grub/grub.cfg /boot/grub/grub.cfg.bak

and

sudo cp -v /etc/default/grub /etc/default/grub.bak

Thanks both!

@ Graeme

That link doesn’t work for me - terminal spits out the same error message as in my original post.

@ Mark

That has worked and is installed and warnings duly noted! :wink:

I don’t do much actual ‘computing’ any more, in terms of files created, information critical etc. More it is the ‘learning of’ the system and how to configure it to one’s own needs. As a keen DIYer, Linux is definitely ‘right up my alley’! ;D

Rich

That link doesn't work for me - terminal spits out the same error message as in my original post.

Yeah I just gave you a link to what you had already tried, I obviously need to read posts more thoroughly before offering suggestions :slight_smile:

Anyway glad you got it sorted

Graeme