HELP - no audio over HDMI on ODROID U3 w/ Debian wheezy/jessie

I have an Odroid U3 (what a fab bit of kit) and its running debian wheezy with xbmc

The image I burned to the Micro SD card it boots from offers a number of ‘boot.scr’ files depending on your hardware & personal preferences.

An example would be boot-dvi-1080p50hz.scr or boot-hdmi-720p60hz.scr - I am sure you get the picture, basically you rename the required file to simply boot.scr and the OS picks this up at boot and applies the required settings. My problem is that although I am using an HDMI connection into an HDMI port on my TV if I use the boot-hdmi file I get overscan and lose significant corners off my screen!! So I am using the DVI boot.scr file and it is fine…

Except I am getting no audio through the hdmi when I use XBMC (or just the XFCE desktop for that matter). OK, I hear you say, of course you wont get audio with DVI so I changed to the hdmi boot file and its still no better.

Anybody got any ideas what I can do to get my audio through the the TV (/AMP) via HDMI?


What’s the contents of “boot-hdmi” file, and the contents of the one you’re currently using ?

They should just be text files.

Don’t know if this is of any help but I am having the same problem.
I am using a HDMI cable to connect my PC (via the soundcard) to my Samsung TV (Sereis4). I have discovered that a few others are having the same problem and I think it was on the Samsung website that they suggested using a separate cable to connect the audio.
I tried this but sill couldn’t get any audio to the TV.

NOTE: I am not asking for help here, just letting Redstorm know of a possible solution.