Help no graphics.

Installed ubuntu 9.10. at 1st it was great. but then it did loads of updates and retarted. But on restart i had a msg saying cant start graphics. all i get is a black dos type screen asking for login and password. i put my login name put it wont let me put the password. it says password _ but the keyboard wont work when i try to enter the password. Also the duel boot screen dont look right. it has loads of boot options. ubuntu generic with some numbers, ubuntu safe mode with the same numbers, then ubuntu generic with a diff set of numbers, then safe mode for that, then vista loader, vista safe mode, windows 7 loader, win 7 safe mode. I dont have vista never have. Even booting win 7 it runs chkdsk before starting. Its never done that before. 9.10 runs fine from disk thats why i installed it so i can try it better and start putting stuff on there. Think its the Nvidia drivers that wont work. As most of my system uses Nvidia drivers including the ethernet modem its a problem. Think there is a problem in the updates that has shut down all the Nvidia drivers. They all worked fine before the updates.

Ok, few points and questions;

When you say updates, did you click on the big button that says “Upgrade to version 10.04 LTS” ???

From time to time the graphics DO screw up on upgrades if you have third party drivers installed (like nVidia) , but generally this is a feature of nVidia rather than Ubuntu. First thing to try, start Ubuntu from the CD and enter ‘rescue’ mode, when it asks tell it to start a terminal session on your root filesystem. Then at the prompt type in the following (I’m assuming here you have an nVidia graphics card);

apt-get install nvidia-glx-180 nvidia-kernel-common nvidia-xconfig exit

Now select the ‘reboot’ option. Hopefully this will have a positive effect on your graphics.

Note; just check again that you can’t log in from the command line, bearing in mind the ‘password’ prompt ‘will not’ echo your keystrokes … if you can log in, log in (or su) as root and run the above commands, then reboot.

As MP says your password IS being entered, it just doesn’t get displayed to the screen (not even as *******)… just type it and hit enter.

Then try the commands that MP gave you, but first change to root with the “sudo su” command… so you want to do:

sudo su
apt-get install nvidia-glx-180 nvidia-kernel-common 
nvidia-xconfig
exit

Hit Enter after each line, and your password when prompted, remembering the password will not be displayed as you type it

Its working again now. I did a few reboots and it cleared itself. But i did see i cant install or run windows games. wine dont work with AMD64 only intel. Tried a few free games as well they run but cant do anything. the preinstalled ones work fine though. Tried that free civ game. All i can do is move the units around but cant build anything or close the game. Had to reboot to close it. I used the wiki to find out how to install windows games but that said wine only works with intel systems. So until wine works with AMD im sticking with windows. I also found that firefox is slower on ubuntu than windows. Maybe thats cause its 3.5. Ive got 3.6.8 on windows. Or it could be that Nvidia drivers r not supported either. So have to use the generic ones which slow things down. Thts what caused the graphics to stop working. I tried to activate the Nvidia drivers. I hit the 1 that said recomened and i lost all graphics. Their is another wine based program that might work but it costs $5.00 a month to use it. It runs more games than wine and is faster or so it says lol. Cant remember what its called but it starts with ge. I did notice kaspersky gave me pop ups now and then when i was online. It is on the windows partition but is still checking the ubuntu partition as well.

Whoever told you WINE only works on Intel CPU’s is full of… I mean AFAIK they are wrong :wink:

What is your graphics card?.. and which version of the nVidia drivers is Ubuntu offering to activate for you?
(eg. 96, 173, 180, or 185)

As far as browsers go… Use Google Chrome if you want speed :slight_smile:

If you are running Ubuntu or Mint, get the 32bit or 64bit (depending on which version of Ubuntu/Mint you are using) .deb file, and just double-click it to install.

Minor grumble / suggestion; on ‘some’ 64-bit systems flash can be less than 100% reliable and on my system in particular it had a nasty habit of ‘eating’ my sound system forcing a reboot to fix (affects all browsers). I’ve now moved onto the 32-bit Chrome beta (in my 64bit system) which has flash built in (the 64 bit does not!) and this seems to fix the problem.

Few things to know;

  • make sure you have ia32-libs installed
  • obtain the .deb package and install with dpkg -i --force-all to override the “invalid architecture” errors
  • remove the external flash plugin if you have it
  • launch with –enable-internal-flash to get the flash feature to work

I got that from the ubuntu wiki. it says wine is intel only. How do u close programs that crash? Im getting crashes all the time. Black screen. The only keys that do anything is ctrl-alt F6 which brings up the command prompt and ctrl-alt F7 which closes it again. I wont use chrome cause i hate it. tried it a few times and its crap and slow. Cant get java or flash plug ins for firefox. Cant use you tube or any site that needs plugins. Ubuntu is continually crashing. The music and vidio players dont work. so far i have only got 1 game to work and thats a windows game that wont work in windows 7 lol. Cant get any of the stuff i downloaded from the ubuntu list to work except wine. That will install games but wont start them. It wont even find my external DVD drive. I downloaded all the diff flash type plug-ins but it cant install them. It says it cant find them even though it says they have been downloaded. The reason why im not getting graphics is cause it keeps crashing and the only way to get it working again is to pull the plug. Ive heard a lot of good things about linux and how stable it is but i cant get anything to work. From the problems im having i dont think many will switch from windows cause its to hard to use. Most of my drivers r Nvidia or AMD. Ive got the 64bit version of 9.10. Ive got an AMD athlon II x4 Quad core. So that should be fast enough. But from all the forums ive looked at AMD and Nvidia systems have a lot of trouble running linux OS. Im going to keep trying though. It looks better than windows but so far nowhere near as stable. Im going to look through all the posts on here to see if anyone else has had the same problems to see if i can find an answer.

I got that from the ubuntu wiki.

Ok, either you’re reading it wrong, or the Wiki is talking complete ‘tosh’.

To close programs there are three easy methods;

  • System → Administration → System Monitor, Processes, Select the process you want, click End process
  • Start a terminal session, ps ax | grep , kill (from listing)
  • And my favourite, from a terminal session type xkill, this will change the cursor to a skull and cross bones, click on the window to kill

If all you have is ctrl-alt-f6, log in and use the second option.

ALL of my systems run 64 bit AMD chips, ALL of my workstations have nVidia Graphics … go figure … ! :wink:

I just read it again about wine. its in the myth bit on wine hq. I used a link on here to get to it. It says wine will only work with intel X86 prosessers. Its myth 10 go look and u will see it in black and white. It also explains why.

A link to the “Myth bit” on WineHQ might help :wink: … but I assure you WINE works perfectly on AMD CPU’s… here’s what the WineHQ FAQ says about CPU’s
http://www.winehq.org/site/docs/wine-faq/index#WHAT-MINIMUM-CPU-MUST-I-HAVE
so you will see WINE will run on ANY x86 compatible CPU (>=80486)… your AMD CPU is FULLY x86 compatible.

Ahh… I’ve found the bit you mean… Myth 10 on this page:
http://wiki.winehq.org/Debunking_Wine_Myths

Your AMD is Intel x86 compatible…the term x86 refers to a family of instruction set architectures based on (but not limited to) the Intel 8086 processors… in other words ANY CPU with an x86 architecture… not non-x86 CPU architectures such as ARM, Motorola 680x0, etc.

Also, what the WineHQ FAQ says about AMD CPU’s:
http://www.winehq.org/site/docs/wine-faq/index#DOES-WINE-WORK-WITH-AMD-PROCESSORS

Also see:
http://www.winehq.org/site/docs/wine-faq/index#IS-WINE-AN-EMULATOR

So considering WINE is NOT a CPU emulator… and Windows versions greater than NT4.0 ONLY run on CPU’s that use the x86 architecture… if Windows itself runs on an AMD CPU then it MUST be an x86 compatible CPU, so if an app runs in Windows, then it will run in WINE regardless of CPU manufacturer… if it runs in WINE at all, that is :wink:


OK, now to the problem solving… one at a time…

  1. Chrome… I really don’t understand your aversion to Chrome, it’s MUCH faster than FireFox, but what the heck… to install flashplayer system wide.

I’m going to talk you through it using synaptic rather than giving it to you as a command, just to help you learn how to use synaptic (if you don’t already know) :slight_smile:

On your top panel, got to System>Administration>Synaptic Package Manager… when Synaptic starts, type flashplugin into Quick Search… in the main Synaptic window, you should now see flashplugin-installer… click the little box to its left, and select Mark for Installation… now click the Apply button on the Synaptic toolbar… the flashplayer plugin will be downloaded and installed for you.

You might also want to install the ubuntu-restricted-extras package in the same manner (which also installs the flashplayer, java, mp3 and other codec, LAME, some M$ fonts, and DVD playback).

also instal the libdvdcss package for reading encrypted DVD’s… open a terminal and enter:

sudo apt-get install libdvdread4
sudo /usr/share/doc/libdvdread4/install-css.sh

hitting enter after each line, and entering your password when asked (remember you won’t “see” the password being entered)


  1. External DVD… if the above hasn’t fixed the DVD, and it’s a USB drive, can you post the output of:
lsusb

must be entered into a terminal with the drive plugged in.

Also, can you confirm whether when you go to Places>Computer, that the DVD drive is/isn’t shown in nautilus.


  1. Graphics… first can you confirm that Ctrl+Alt+F1 (to F6) also takes you to a console (command prompt)… Ctrl+Alt+F7 to return to your desktop GUI.

Have you enabled the nVidia drivers in System>Administration>Hardware Drivers ?

Which nVidia graphics card do you have?


  1. Running Windows apps/games in WINE… don’t expect them all to work, and even if they do, don’t expect them to run as well as in Windows.

Linux is MUCH more stable than Windows, you have just been unlucky and are having a few configuration problems… as far as I’m aware there are no issues with nVidia chipsets and Linux… glad to hear your sticking with it :slight_smile:


@ Mad Penguin
I think he means that he has an nVidia “chipset” (probably one of the nForce chipsets… north/south bridges, Ethernet controller etc.) that may be causing the issues, as well as an nVidia graphics chip… but I can’t find any relevant bug reports so I doubt if it’s chipset related :slight_smile:

yes its got nforce chipset. Ive got the geforce 9200 at the mo but when i can find a decent low profile card and a PSU that will fit into the case ill be upgrading them. My PSU is only 220w so cant put a better card in till i upgrade that. But as my case is a slimline 1 i cant find a PSU small enough to fit lol. So might have to leave the PSU outside the case. I have activated the Nvidia drivers. Thats when i didnt have any graphics. everything went black when i activated it. But after a few reboots it works ok. Ive already got the flash player from ubuntu downloads but it wont install. so ill try the method u just posted. have to do the same with java. Its all the command line stuff i dont like doing. Think that will put a lot of ppl off using linux. They want an OS thats simple to setup. Ill follow the instructions when i log back into ubuntu. Havent transfered my bookmarks yet so have to keep going back to windows to get on here lol. I printed the page so i can look at it while im doing everything on ubuntu. Cant print on ubuntu as my printer wont work and no drivers for it. There r loads od drivers foe cannon printers but mine aint on the list lol. As for the exrternal DVD that wont work on windows 7 either. LG dont provide drivers for it and cause its not made in the USA they wont give any support for it either. As i cant find the receipt i cant take it back to the shop. My built in DVD keeps chewing up disks so only use it when i have too.

IMHO, Linux is much easier to install and configure than Windows… just different… for those that can’t be bothered to learn some slight differences in layout (which they generally have to do every other Windows version anyway), they can always continue to use an inferior OS and pay for the privilege… and that’s just fine by me :wink:

Can I also add that the only reason people tend to feel more at home installing and configuring Windows, is because they’ve done it a few times… usually out if necessity.

Nobody was born knowing how to setup/use Windows either… they had to learn.

Nowadays it is not necessary to understand the command line in Linux, but it helps, there are graphical (GUI) tools for pretty much everything, the same as in Windows, but the command line is MUCH more powerful in Linux, and nearly everything can be achieved through it… commands tend to get used for forum replies for a number of reasons.

Commands are generally given because they are easier to type and are more distro generic, so are likely to work in Ubuntu as well as openSUSE, Fedora etc)…

which of these do you think is easier for me to type?

Click Places>Home folder, when Nautilus opens, click View>Show Hidden Files, double-click on the .mydir folder then right-click on .file_to_be_copied and select Copy, navigate back to your home directory and open the Desktop folder, right-click on a clear space inside the folder and select Paste, right click on the .file_to_be_copied, select Rename, and change its name to file_to_be_copied

or

cp ~/.mydir/.file_to_be_copied ~/Desktop/file_to_be_copied

And if you were using the KDE desktop and Dolphin instead of Nautilus, the command would still work, but the “GUI version” would need slight adjustment (ok not much in this example, but you get my meaning).

Commands also leave less room for interpretation and tend to be followed with more attention to detail/less getting ahead of the response, and are easy to “Copy and Paste”.

This doesn’t mean Nautilus/Dolphin etc. (Linux file managers) don’t exist… commands similar to the above are used regularly on Windows help forums (how many times do you see things like “you need to delete C:\Windows\System32\annoying_toolbar_popup-malware.dll”), but tend to stop at anything more involved (even if it’s possible)… Linux forums tend to think people won’t mind a response in command line format as they want to learn the true power of Linux, but if they say they are uncomfortable with the CLI, they usually get a GUI response.

Even Microsoft realise the need for a more powerful command line shell and scripting language…
Windows PowerShell

The only real difference is that Linux doesn’t try to hide its all powerful CLI, whereas Windows seem to be ashamed of their puny affair (even continuing to call it a DOS box so they can say its lack of functionality is because it’s a “leftover” from an older OS), whilst quietly trying to improve it… well at least they’re trying :wink:

Mmm, solutions to Windows problems generally come as DOS commands, especially for more complex problems. (or the instructions will just say “copy the file to your home folder” and let you get on with it) Even worse, every other problem seems to involve a problem with the registry and as a result directs you to use “regedit” where one wrong move will screw your system.

Linux has an equivalent called “gconf-editor” , but using it is unlikely to screw your system and indeed rarely referenced with regards to solving problems… :slight_smile:

Shouldn’t that say “using it will never screw your system”, as you can always log on as root and easily fix it… even if this means deleting the ~/.gconf directory, which will just get rid of GNOME desktop custom settings and put you back to defaults?

Unlike the Windows registry which can screw your whole system… OK, Windows normally keeps a backup of the registry, but it can still leave your system unbootable and require booting from a DOS floppy etc. to fix… that’s presuming that the registry wasn’t destroyed by malware, which will probably have screwed/deleted the backup(s) too… Argh!!!.. been there MANY MANY times, can you tell? :wink:

(that made me think of “been there, got the T-Shirt”… Hmm, now thinking of making a T-Shirt… any suggestions?)

I guess what I’m saying is that gconf isn’t really a registry equivalent (though I see what you were getting at)… as doesn’t it only contain GNOME desktop settings/customizations and not system (and/or system wide) configurations?

Mmm, being a single user system, Windows mixes local and global information in the registry … being a multi-user system, the Linux equivalent references local information only, so effectively gconf-editor mirrors the “local/user” component of the Windows registry. Also, as the graphical system is not an integral part of the OS, it doesn’t contain what Windows would call “System” settings capable of screwing up your system. It does however contain settings capable of screwing up your “account”.

Just because you can log in and fix it as the root user, doesn’t mean it’s not screwed, it just means it’s easier to fix … :slight_smile:

Incidentally, “gconf” doesn’t “just” contain settings for Gnome, it also covers the extended environment and a range of applications … check out the “apps” key …

Oh yeh, I agree it could screw with your account and I know it contains app settings as well as GNOME settings, but my point was they are all user specific, so worse case scenario… create a new user account, copy anything you need from the old home directory… done.

Several orders of magnitude less than the system wide damage that can be done with the Windows registry, so I’m loathe to call them equivalent. :slight_smile:

If we’re going to say Linux and Windows are equivalent, and that Linux has equivalent applications to Core Windows functions, I don’t think applying the same to gconf and the registry is unreasonable :slight_smile: … After all, just because they’re equivalent doesn’t mean that one isn’t superior to the other … :wink:

I get what you mean… I just don’t like the word equivalent

OK, 2b might apply… at a stretch.

But I’m struggling to find a more appropriate word

ALTERNATIVE doesn’t fit… Implies you don’t have to use it.

I’d be more inclined to leave comparisons alone, and if asked say they have a “vaguely similar function” and explain why the Linux variant is superior.

Now there’s a better word…

How about “Linux has a superior variant” :wink:

[EDIT]
For clarity - I edited definition 1 of variant… it originally just said “obsolete : variable” with the word variable being a link to the word variable('s) definition.

Ohhh, Noooo… variant implies “from the same source” …

Would you not say that a 2.5 litre diesel engine is equivalent to a 2.0 litre petrol engine?

Yes, but I wouldn’t say a 2.5 litre rover engine was equivalent to a 2.0 litre ferrari engine (if there was such a thing)… if we’re talking about function the term (in this case) kind of fits, but if we’re talking about power, quality, or reliability…

There has to be a better word?