Help restoring dule boot system (Resolved)

I disconnected the HDD with win 7 whilst doing a clean install of mint 17 64bit mate on the 2nd HDD.

Now grub dose not list win7 as a bootable operating system. How do I restore win7 in Grub…

sudo update-grub

then reboot

yes tried that but it dose not find the win7 operating system…

Try to run os-prober. Install it if requred.

sudo os-prober

then

sudo grub-install /dev/sda

then

sudo update grub

Reboot

Another option would be to use EasyBCD to add Linux to the Win7 bootloader ?

[EDIT]

I’m beginning to think grub/os-prober is broken in 14.04 … this is NOT the first time I’ve heard someone say Win7 was not detected.

http://forum.peppermintos.com/index.php/topic,562.0/topicseen.html

when I run “sudo os-prober” I get this: No volume groups found

If I boot from a GRUB 2 rescue disk it detects the windows operating system and I can boot into win7

Also ran suod fdisk -l with the following results… sda has mint 17 on it and sdb has win7.

userone@Office2 ~ $ sudo fdisk -l

WARNING: GPT (GUID Partition Table) detected on ‘/dev/sda’! The util fdisk doesn’t support GPT. Use GNU Parted.

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x00000000

Device Boot Start End Blocks Id System
/dev/sda1 1 976773167 488386583+ ee GPT
Partition 1 does not start on physical sector boundary.

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xa970a970

Device Boot Start End Blocks Id System
/dev/sdb1 * 63 312576704 156288321 7 HPFS/NTFS/exFAT
userone@Office2 ~ $

Seems like the minute GPT is thrown into the mix, os-prober goes nuts.

Any particular reason you used GPT on sda ?

I did not know I had used GPT (what is it)…

I just formatted the HDD and then installed mint 17 from the live usb win7 was disconnected at that time.

Options…

Have you run a full system updeate in Mint … I seeem to remember a GRUB update coming through nt that long ago


Does the GRUB2 rescue disk see BOTH OS’s ? … if so it’ll probably be possible to install GRUB from there


Are you game for reinstalling Mint ? (after changing the partition table to msdos)

it would probably (unless you’ve already heavily modified it) be easier than manually adding boot stanzas.


Does Win7 still boot if it’s the only HDD attached ? … if it does it would be pretty simple to add mint to the Windows bootloader.

OK lets go for a reinitialisation of mint I take it I will need to boot to a live usb stick and use G-parted but how do I change the partition table to MSDOS?

Boot to a LiveCD then from gparted delete all partitions on the Mint target HDD so it is all free space, then go Device->Create Partition Table->MSDOS and stop there.
Then use the Mint installer to create the partitions during install.

This fixed the problem.

Thanks for your help.