Help to make my HP mini work on wireless

I guess I have the same problem with my HP mini.
I have windows but I want to try Ubuntu.
So I have downloaded the latest version 10.04 inside windows.
I can’t connect to my network.
If I need to install b43 please tell me how to do it without cable.
thanks

It can be done … see here:

but it will be much easier if you can connect your Dell Mini to a router via an ethernet cable :slight_smile:

thanks Mark,
But I am afraid not to be good enough to understand all that. Not at all have any knowledge of what they are talking about.
But it seems that I have exactly the same problem.
Ubuntu does not find any wireless network around.
Windows find a lot and my own wireless network.

I can not used ubuntu without internet.
And the step explained are too difficult for me.

Is there another way or I have to go bakc to windows??? ):

… If you’re not prepared to even try very simple instructions, reverting back to Windows is not going to be easy.

Here’s the step by step;

  1. Plug your computer directly into your router via a cable, it should automatically see and make the connection
  2. Goto System → Admin → Synaptic package manager
  3. Click “Reload”
  4. When that’s finished, click “Search”
  5. Enter “bcmw” and hit return
  6. Click on the empty box next to “bcmwl-kernel-source” and select “Mark for installation” from the drop-down menu
  7. Click “Apply”
  8. Close down all your applications and reboot the machine
  9. It should now see all your Wireless networks as you would expect under Windows (via the wireless icon in the tool tray in the top right of the screen)

These are the instructions detailed on Mark’s link.

At what stage are you getting stuck ??

thanks for your prompt answer,
but i do not have two ethernet cables so I try to download it from the net and copy on a usb key.
but after I can not install it from the synaptic package manager.

Also I have connected the HPmini to the internet virgin box using the only ethernet cable I have but wired network does not connect with ubuntu.
Through the HPmini system it works perfectly, but not through ubuntu.

I hate being stuck with this kind of things get me mad like a penguin. :slight_smile:

Also I have another thing with the HP touch pad, I can not scroll icons. The touch pad gets mad.

I will retry tomorrow
Thanks for your help.

you dont need 2 ethernet cables, just one from the Dell to the router.

If you aren’t getting assigned an IP automatically, check the router has DHCP enabled.

When you plug in the cable does anything get displayed, like “Auto eth0 active” or “Wired network disconnected” etc.?

with the ethernet cable plugged into both the router and Dell, open a terminal and enter:

ifconfig

hit enter and post the results

Touch pads are ‘rubbish’, do what everyone else does, plug in an external mouse !

Sorry Mark but I do not get you.

My system is: Virgin box (TV & broadband) connected to a netgear router via the ethernet cable.

Virgin Cable arrives to my virgin box with TV & broadband. Ethernet cable goes from virgin box to router and send internet to all my computers.
If I use the ethernet cable to connect router to my HPmini (not a dell, but should be the same), router not connected anymore with Virgin box so no internet access.

So, I have connected directly the HPmini to virgin box, internet works perfectly with Windows and the HPmini system ( firefox & mail access). But if I launch ubuntu, he does not recognized the virgin box ( wired network).

Must be something simple as usual.
: :o :o :o

Unfortunately the HP-Mini has a few Quirk’s.

Apparently you need to have the network cabled plugged into the Mini BEFORE you power on the mini …

For more details, try this article.

http://wheatfield.wordpress.com/2010/06/01/ubuntu-10-04-netbook-remix-on-an-hp-mini-1000/

Ahh an HPmini… what model?

This may seem a bit of a weird request, but can you try connecting the HPmini to your Virgin box with the ethernet cable again… here’s the weird bit… make sure your HPmini is not running off the battery, but has the power supply plugged in and is running from the mains, reboot the HPmini and see if it connects.

The reason I want you to try this:

I am going to try Mark idea

But the other idea, I need to change a line in etc/default/grub

First he does not allow me to change the line, do not have the right.

Secondly, how do I update grub (sudo update grub)?

Another question, I tried to install ubuntu on an other computer ( you see I really want to get it). A DELL desktop.
Just after the question allowing network acces for pyrun during installation process, he stop with message can not download metalink, etc…

you can edit the etc/default/grub file ONLY if you have root permission, so from a terminal:

sudo gedit etc/default/grub

to update grub:

sudo update-grub

But try it first running from the mains before adding the acpi_os_name=Linux boot parameter to grub.

thanks guys,
it is working perfectly now.
The connection to the virgin box works well. It download all the necessary files and then I install the bcwm file. GREAT.

OUT through the window.

I sure will comeback some others questions

speak to you soon and again thank you

You’re welcome :slight_smile: