Help with installing canon printer onto linux mint system

Hi, I am a total newbie to linux mint… I have a new canon pixma mg3350 all in one printer and would like to install this on the computer but am totally clueless as to how I do this, I would be grateful if someone would talk me through. Thanks :-\

well, Ctl>Alt>T

open a terminal, from there you must enter these codes…
do you remember your admin password?
it will ask you the original time you start an install

follow these directions

but Canon usually install right away with nothing extra…kinda funny

also are you sure it is MG 3350, not 3550?

There are .deb packages available on the Canon site, but before I post instructions, can you open a terminal and post the output from running this command:

uname -a

[EDIT]

Yeah … are you sure it’s not a 3550 ?

Hi Thanks for all the messages and sorry for and delay in getting back to you… Oh typo probs MG3550 is correct.

Here is the result from the terminal for you Mark:

Linux oxlade-TravelMate-4280 3.5.0-17-generic #28-Ubuntu SMP Tue Oct 9 19:31:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Normally I’d provide links to the drivers directly from the manufacturer and instructions to install them but Canon don’t make it particularly easy … so I’ve uploaded the necessary 64bit drivers to my dropbox.

To install them, open a terminal and run these commands in sequence

mkdir ~/canon-printer

then

cd ~/canon-printer

then

wget https://dl.dropboxusercontent.com/u/11876059/mg3500series.tar.gz

then

tar xvf mg3500series.tar.gz

then

cd ~/canon-printer/mg3500series

then

sudo dpkg -i *.deb

then let us know if you need help setting the printer up.

Hi Mark, Thanks… all good so far. It’s now asking me for my password and when I type it nothing is actually working the cursor just blinks? hit the return and it goes back to [sudo] password…

Any ideas?

Thanks
???

When you enter your password in the Linux terminal nothing is echoed to screen … not even ****** … but it IS going in, so just type it and hit enter.

:wink: Sorry to be so clueless. That’s all ok and it’s done it’s unpacking and setting up in the terminal and ended with…

Setting up cnijfilter-common (4.00-1) …
Setting up cnijfilter-mg3500series (4.00-1) …
Setting up scangearmp-common (2.20-1) …
Setting up scangearmp-mg3500series (2.20-1) …
Processing triggers for libc-bin …
ldconfig deferred processing now taking place
oxlade@oxlade-TravelMate-4280 ~/canon-printer/mg3500series $

I have just found the canon printer file in a folder but am not sure how to make it work, I’ve no desktop icon for it and nothing in the printer file…

Not sure what to do next?

How is the printer attached USB or wireless ?

Sorry Mark, I didn’t realize it was so late… It’s wireless.

OK, let’s start again…

first lets remove what we just installed, and delete the temporary installation files.
run these commands in sequence:

sudo apt-get remove --purge cnijfilter-mg3500series cnijfilter-common scangearmp-mg3500series scangearmp-common_

then

rm -vrf ~/canon-printer

OK, now we’re going to download some new files, unpack them, and run an installation script
run:

mkdir ~/canon-printer

then

cd ~/canon-printer

then

wget https://dl.dropboxusercontent.com/u/11876059/cnijfilter-mg3500series-4.00-1-deb.tar.gz

then

wget https://dl.dropboxusercontent.com/u/11876059/scangearmp-mg3500series-2.20-1-deb.tar.gz

then

tar xvf cnijfilter-mg3500series-4.00-1-deb.tar.gz

then

tar xvf scangearmp-mg3500series-2.20-1-deb.tar.gz

then

cd ~/canon-printer/cnijfilter-mg3500series-4.00-1-deb

Now make sure your printer is switched ON … then run:

./install.sh

You will be prompted to hit enter to continue

then enter “2” for “Network” and press enter

It should search and find your printer.

Then follow the on screen instructions.

Once you’re done, let me know and we’ll install the scanner drivers.

Yey… Thanks so much Mark that all worked and now I have a computer and working printer after months :slight_smile: :slight_smile:

OK, now the scanner…

Open a terminal and run:

cd ~/canon-printer/scangearmp-mg3500series-2.20-1-deb

then

./install.sh

then when finished, see if

menu > Graphics > Simple Scan

finds your scanner ?

Sorry I have been unable to get on line for sometime, a page error kept appearing when I tried to access your page. I have run the scanner commands in the terminal and it says that it is installed, I can open up simple scan but the scanner can’t be found. I have connected it with cable and printer is on.

the other problem that I have is that the first time I tried the printer it worked wirelessly but now the only way that I can print is to connect it in with a wire… any ideas why?

Many thanks

If you’re going to use the printer wirelessly … give it a static IP address.