help with linux anti vurs

Quote
Error Description: “Have Problem occurred at the hacking function block (108)”

Cause: Problem with some antivirus software. Somehow do not like HackShield.

Solution: You can try to uninstall and install another antivirus, temporarily disable the antivirus before playing. Reinstall the game completely (see bottom of page), because some file may have become corrupted.

this is the error 4story gives thru wine… now i have some on windows but this one is to do with anti virus as ya can see :S how do i make an exeptin for the hackshield(there hack protections)

You will be lucky to get 4story to run in WINE… nobody else seems to have.

WineHQ App Database rating = Garbage

but surely the only thing that is holding me back is this, now not alot of people know, but Alot of winxp and other win ver runners getting errors all over from hackshield. and are normaly fixed easy on win,

i have seen one guy in forums saying how to fix 108 over and over then last post was ‘‘nvm i fixed it’’ and he not bin on forums again in months,
so people are fixing it :S

this is only that the antivirus on linux does not like what hackshield has with it

when i used avast i had to add in the acception list to let it run without errors,
so surely linus can run an exeption for 4story?

the tests how they all error on the installer (which is where hackshield loads and errors)

on my windows pc it does it but if i turn antivirus down add exeption turn it off, or keep clicking eventualy it wil load there are fixes for various errors they got

this fix on this is in anti virus

You can install AV in Linux (as you say you have), but 4story can’t find it as it isn’t installed in WINE…

What I mean is 4story (running in WINE) is looking for an AV program in ~/.wine/drive_c/ (what it thinks is the Windows C:\ drive)

4story has been installed to somewhere in there, so it’s looking for an AV in the same place.

Before you ask… I have no idea if there is an Windows AV that will work in WINE.

Why have you got an AV app running in Linux in the first place?

Just because Windows users get the same error message, it doesn’t mean the cause is the same… it could be a firewall issue, or a Linux file permission issue, or it just not finding something it expects to find… it sounds to me like it is trying to modify something and can’t… usually caused (in Windows) by AV stopping it, hence the error message… so because it can’t find what it’s trying to modify, or Linux won’t let it… it’s showing the same error.

From everything I can find online, there is no way to get games that require HackShield, GameGuard, etc. to run in WINE.

aah i see :slight_smile: well i havent av on linux its on my windows swap drive :slight_smile:
but i just posted about why my wine is happening, i didnt think to post here sry linux to swap boot xp ofc,

and im set as cat5e cable though the main pc,
in connections i can stil see the main pc there,
nic#2 fo rmy internet says is unplugged… worked fine for weeks all i do is 4story ,

now on linux my nic#2 is connected stil :S i tryed every setting rollback the lot :S what shal i do (this is why i trying to wine 4story)

anti virus is only on xp:P

Is it Windows that can’t connect to the internet?.. but Linux does?.. If this is the case, I bet you know what I’m going to say next :wink:

yeah linux with nic#2 is fine
windows for some odd reason 2days ago dropped and after 5 restarts it came back bin fine, and now… its gone again, says its unpluged :S:S

no i dont lol only ever seems to be windows that gets this stupid net error!! lol all they past 5 years always i get this damn thing (always fixed accidently)

you say ‘‘scrap windows and stop playing cool games?’’ lol

I wouldn’t say that :slight_smile: … by all means keep Windows for your games.

But I would like to draw your attention to the Banner/Logo at the top of the page…
This is a problem with your Windows installation and is unrelated to Linux in any way… So at least for this problem, you’re in the wrong place I’m afraid.