HMRC PAYE tools in Ubntu [solved]

Hi

I have seen that HMRC now offer there PAYE basic tools for Linux. Link Download HMRC's Basic PAYE Tools - GOV.UK
How should it be installed properly to work in Ubuntu?
I have tried downloading it, extracting it and then double click it. It seems to install but once finished and rebooted, It will not open and run the program.
Thanks
Mark

[EDIT]

Updated with the latest version (as of 30 April 2015)

[END EDIT]

Just download the archiive from that page or from this direct link
https://www.gov.uk/government/uploads/uploaded/hmrc/payetools-rti-15.0.15048.300-linux.zip

then right-click on the file you just downloaded, and select “Extract here”

You’ll then see an extracted binary installer called payetools-rti-15.0.15048.300-linux … double-click that to run it.

Walk through the installation, accepting the defaults (it’s safe, it’s installed in user space and doesn’t require elevated privileges)

Once finished, you should find an icon on the desktop.

Hi

That is what I did. But when i try and open it from the desktop icon I get a blue box in the middle of the screen with PAYE tools on it as I should, it then disappears and nothing else happens.

What distro & version are you running?

and architecture ?

Working fine for me on Peppermint 5 32bit, and Peppermint 6 Beta 32bit

If you’re not sure, please post the output from:

uname -a

Is it the installation that fails, or running the program after installation ?

Can you tell me which version of Ubuntu P6 is based on yet? :stuck_out_tongue:
Thinking of the support period!

Hi

Ubuntu 14.04 resonant update. I think it has Gome as well.
Output is

mark@mark-Aspire-5755G:~$ uname -a
Linux mark-Aspire-5755G 3.13.0-49-generic #83-Ubuntu SMP Fri Apr 10 20:11:33 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
mark@mark-Aspire-5755G:~$

It is the running of the program after install that fails.

I think you will have to try harder than that!

Mark ;D

Try this…

First uninstall it completely with:

$HOME/HMRC/payetools2012/uninstall

and when prompted accept to unninstall EVERYTHING (including the user data)

Now download the file and reinstall, but this time when asked, remove the tick from “automatically check for updates”.

Does it work now ?

If not, is there any output if you run:

cd ~/HMRC/payetools2012

then

./bpt.linux

Hi
Done that I had to modify the line from payetools2012 to payetools-rti because that is what its called now.
It starts to run then I get a pop up box with

An error has occurred in accessing the database during startup.
You may need to check whether you have permissions to access the following location on this computer:
/home/mark/HMRC/payetools-rti/userdata
For assistance, please contact your IT support person, or your computer manufacturer.

The output from the next bit is

mark@mark-Aspire-5755G:~$ cd ~/HMRC/payetools2012
bash: cd: /home/mark/HMRC/payetools2012: No such file or directory
mark@mark-Aspire-5755G:~$ cd ~/HMRC/payetools-rti
mark@mark-Aspire-5755G:~/HMRC/payetools-rti$ ./bpt.linux
bash: ./bpt.linux: No such file or directory
mark@mark-Aspire-5755G:~/HMRC/payetools-rti$

Why was the directory name different … did you manually change the directory name during installation ?

Did you at any point attempt to install the application as root ?

What’s the output from:

ls -l /home/mark/HMRC

and

ls -l /home/mark/HMRC/payetools-rti/userdata

output is

mark@mark-Aspire-5755G:~$ ls -l /home/mark/HMRC
total 4
drwxrwxr-x 14 mark mark 4096 Apr 29 17:38 payetools-rti
mark@mark-Aspire-5755G:~$ ls -l /home/mark/HMRC/payetools-rti/userdata
total 300
-rw-rw-rw- 1 mark mark 300032 Apr 29 23:14 sqlite3.db
mark@mark-Aspire-5755G:~$

The directory name it what it named itself. I have not changed it at all.
How do you install it as Root?

Just realized I have used the download file from hmrc website not the one from the link you gave. I will uninstall and try again.

I have just downloaded the file again from your link, extracted it but it will not open and install, dose nothing.

I have reinstalled the rti version from hmrc website again with the check for updates unchecked, and it is working. Also have updated it from within the program and now have up to date version.
The difference in what I have done, I don’t know, but it works now. All I have to do now is restore the back up from last years one in windows and I am all sorted.

Thanks for all the help

Mark

Sorry, I’d obviously scrolled too far down their page … I’d missed the rti version :-[

Link changed above.

Just for info
The output from above is

mark@mark-Aspire-5755G:~$ ls -l /home/mark/HMRC
total 4
drwxrwxr-x 14 mark mark 4096 Apr 30 10:55 payetools-rti
mark@mark-Aspire-5755G:~$ ls -l /home/mark/HMRC/payetools-rti/userdata
total 976
drwxrwxr-x 2 mark mark 4096 Apr 30 11:43 backups
-rw-rw-r-- 1 mark mark 992256 Apr 30 11:43 sqlite3.db
mark@mark-Aspire-5755G:~$