how can i set up and connect thru my main

i been using temp cat5-e to get net, how do i set this up on mint9

my main net pc is xp atm and no spare on the modem

set what up…

  1. an ethernet connection? (to a router)… should just work, as long as your router has DHCP switched on.

  2. a wireless connection? (to a router)… click menu>administration>hardware drivers… is there anything in there that needs activating?.. or does it say wireless connections are available, but you don’t know where to put the settings.

  3. a USB modem connection?

Can you be clearer about the problem.

i have 2 computers set up, the main 1 is xp and my personal 1 is linux mint9…xp is set up to a cable modem via ethernet. the linux pc needs to connect to the xp computer via cat5-e cable how do i set this up i’m a little confused lol

so your main PC has 2 network cards?

if so, is the cat5 ethernet cable that’s going between the 2 PC’s a “crossover” cable? (and not a standard ethernet cable)

if so, have you set up internet connection sharing in Windows (main PC)?

if so, what are the ICS settings, ie. the gateway IP (second network cards IP address)… you will also need the DNS server IP’s for your internet service provider.

see here:

so your main PC has 2 network cards? err it must do, cause i had both pcs connected before linux was installed,
is the cat5 ethernet cable a “crossover” cable?yeah its not for filesharing it was the one for the internet advised me which to get

if so, have you set up internet connection sharing in Windows (main PC)? i ran windows file share on the pc before linux havent done anything since waiting to know what to do off you lol

ICS settings,
IP address,
gateway IP…
you will also need the DNS server IP’s for your internet service provider.

how can i see these for you

You never told me that you’ve had them connected using internet connection sharing… and I’m not a mind reader !!!

you can get the gateway IP from running

ipconfig /all

in a Windows command prompt window
you will need to get the DNS servers from your router, or an internet search, or from your ISP

after that you will find instructions on the link I provided.

sorry readin my post looks liek im being cocky lol im not i didnt mean to sound it, was thinkin aloud lol
sayin err i thik it must cause it was insalled before, sry for that just my typing , and i put in red at endof yours so i could answer all easyer

and i totaly missed that link lol thanx

i got them all now, but how do i open shell promt i tryed in command line but nothing happens :S

aah got it , but it says
SIOCSOFADDR: Permission denied
SIOCSIFFLAGS: permission denied

when i type ifconfig

OK… as long as Internet Connection Sharing is set up on the Windows box, and the second cards IP is (should have been automatically set to this by ICS)

Ignore the stuff on that link and do it this way instead:-

Right-click the Network Manager icon (by clock) and select Edit Connections, on the “Wired” tab, click Add, on the “IPv4 Settings” tab, select Method: Manual, click Add and enter:

DNS servers: enter your primary DNS servers IP address

make sure “connect automatically” and “available to all users” boxes are ticked, and click Apply

If at any time it asks you to enter a keyring password, leave it blank and click continue, even if it complains, and says it’s unsafe.

If on the other hand it asks for the root or administrator password, enter “your” password.

ok ive done this and now it says
eth0 Now

but i got no net ? lol there an additional step? or something i need to do differently?

If you open a terminal (menu>terminal) and enter:


then hit enter, do you get a response? … ie. a few lines scrolling up with time=3.56 ms (or similar)

BTW you can stop this by either closing the terminal or hitting Ctrl+C

Also try this… open your browser (Firefox) and in the address bar enter (nothing else) and hit enter… does the Google page display?

Remember, the Windows PC has to be switched on for ICS to work.

YAY!! its on thankyou so much for all your help, no doubt i will need you again at some stage as i’m changing the whole family’s computers to linux! i will also b donating at the end of the month :slight_smile:

if it only works when you enter an IP address such as (but not if you enter a domain name, such as, then the DNS server is set incorrectly.

And you’re welcome :slight_smile:

it works wen i type :slight_smile: thnx again