How do I get rid of Pep 8 from my dual boot (Solved)

Hi Mark,
Is there an easy way to get rid of Peppermint 8 from my dualboot Pep 7 and Pep 8 system ??

Don W

Boot into Peppermint 7, and post the output from:

sudo fdisk -l

and

sudo blkid

and

mount

if it’s Peppermint 8 you want to get rid of, make sure you post the output from those commands whilst booted into Peppermint 7

Hi Mark,
Hows this ?

don@ldwatson ~ $ sudo fdisk -l
[sudo] password for don:
Disk /dev/sda: 465.8 GiB, 500107862016 bytes, 976773168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: DE608926-D903-482F-BE6E-3EA72F89AD5B

Device Start End Sectors Size Type
/dev/sda1 2048 1050623 1048576 512M EFI System
/dev/sda2 1050624 623449576 622398953 296.8G Linux filesystem
/dev/sda3 968998912 976771071 7772160 3.7G Linux swap
/dev/sda4 623450112 968998911 345548800 164.8G Linux filesystem

Partition table entries are not in disk order.

don@ldwatson ~ $ sudo blkid
/dev/sda1: UUID=“D39E-DA25” TYPE=“vfat” PARTLABEL=“EFI System Partition” PARTUUID=“49d5d369-b448-4103-a2f8-c7cc1c874dc3”
/dev/sda2: UUID=“15ac0596-d7f7-471d-803e-f7897fc7d3a7” TYPE=“ext4” PARTUUID=“a6682da6-640c-44ce-a943-d2d9dab8b3fd”
/dev/sda3: UUID=“f404b181-4780-438e-8339-d9c680635f94” TYPE=“swap” PTUUID=“87d04b65” PTTYPE=“dos” PARTUUID=“22a2c3f7-49e7-4a5b-bc76-d16f7e61eb7e”
/dev/sda4: UUID=“a6ae7f58-1daa-4b8c-baee-cda572e74a1f” TYPE=“ext4” PARTUUID=“f8f7a69a-7985-4dc6-ace1-963797b9423f”
don@ldwatson ~ $ mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=1849992k,nr_inodes=462498,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=374380k,mode=755)
/dev/sda2 on / type ext4 (rw,relatime,errors=remount-ro,stripe=32748,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
efivarfs on /sys/firmware/efi/efivars type efivarfs (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=25,pgrp=1,timeout=0,minproto=5,maxproto=5,direct)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
/dev/sda1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=374380k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
don@ldwatson ~ $

Okay, basically you need to boot to a LiveUSB … then use Gparted to

a) delete /dev/sda4 (which is the Peppermint 8 partition)

b) move /dev/sda3 to the end of the drive (sda3 is the swap partition, moving it to the end of the drive will leave room to expand sda2 into, sda2 being the Peppermint 7 partition)

c) expand (NOT move) /dev/sda2 into the free space (so the now free space is available to Peppermint 7)


If I were you, I’d create a LiveUSB, boot to it. fire up GParted and take a look at the partition layout, and make sure you understand what I just suggested BEFORE actually doing it.

Hi Mark,
I carried out those suggestions and it looked as if everything was well.
I logged out and logged back in and got this message

GNU GRUB version 2.02~beta2-36ubuntu3.17
Minimal BASH-like line editing is supported.
For the first word, TAB lists possible command completions.
Anywhere else TAB lists possible device or file completions
Any ideas ?

Are you able to select “ubuntu” from the EFI boot selection screen ?

if you don’t know how to get to the EFI boot selection screen, what make/model is your laptop ?

Boot to a Peppermint 7/8 64bit LiveUSB and run these commands in sequence:

sudo mount /dev/sda2 /mnt

then

sudo mount /dev/sda1 /mnt/boot/efi

then

for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done

then

sudo chroot /mnt

then

grub-install /dev/sda

then

update-grub

then hit Ctrl+D to exit the chroot environment

and reboot to test.

Thanks Mark,
That did the trick :smiley: :smiley:
It was a bit cheek clenching entering those commands manually but all is well again.
Thanks again, great karma.

Don W

Glad I could help … can you please remember to mark the topic (SOLVED) Don :wink: