how do I install latest update (Solved)

How do I install the latest update of Master PDF Editor ? Please.

Can you find it in Synaptic?

No, the version in the repos is old.

To install the latest version for 64bit Peppermint 5 download this file:
http://code-industry.net/public/master-pdf-editor_2.2.15_amd64.deb
double click it … and when gdebi opens, click the “Install Package” button.

It’s finished installing when you see a:-
Status: Same version is already installed
message … you can then close gdebi

32bit Peppermint 5 users should use this file instead:
http://code-industry.net/public/master-pdf-editor_2.2.15_i386.deb

Instructions should be the same(ish) for recent versions of Ubuntu/Mint/Debian/etc.

Thanks Mark,
Tried the above suggestions and all went well. :wink:

no problem :slight_smile:

This kinda thing really annoys me with Linux - how difficult is the final step of actually moving that deb into the Ubuntu repos? Isn’t that the maintainer’s job?

That’s a point. It would have helped me. Maybe Mark can tell ?

After looking again, it’s not in the default Ubuntu repos at all … the authors don’t release the source code so there’s no way to get it into the Ubuntu repos or a PPA

You can’t just add a pre-built .deb to a PPA … you MUST package the source code properly, then upload the source code to launchpad where it’s automatically compiled into a .deb package against the version of Ubuntu you packaged it for.
This stops people from uploading packages that can’t be compiled on the target Ubuntu version … it also stops people using launchpad PPA’s for disseminating pirated closed source software

Thanks Mark,
I knew you would have a simple explanation :wink:

:slight_smile:

That makes sense, but it can’t be true all the time? I mean, there are some open-source softwares that aren’t in the repos, so you have to obtain them “Windows style”. I didn’t realise launchpad did the compiling, that’s kinda neat. I wasn’t really talking about PPAs, but it also applies to outdated software in the main Ubuntu repos (although I’m aware of some of the reasons for this, in terms of stability on a single version). Where, if you go to upstream, there is source code for an application, and sometimes even a pre-compiled .deb, but it’s absent from the Ubuntu repos. More so where it’s an out-of-date version (like, for example, Chromium), where the version that’s installed from the repos isn’t the current version. Chromium is a bad example because it’s actively packaged, but some more obscure software can remain at the same version in the repos for ages, even when the upstream project has been updated many times. I’m assuming it’s just the maintainer being slack, but I guess if it doesn’t compile against the appropriate Ubuntu version, they just leave it rather than trying to patch minor upstream software.

Oh sure … there’s always gonna be the odd lazy dev and/or package maintainer :wink: