how to get gps navigation with bluetooth gps-adapter to work on eeepc 701 ??

Hello,

I’m verry happy with peppermint on my little eeepc 701 …I use the eeepc in my mobilhome to play my music and to show me the way…
Since the disksize is so small peppermint is perfect for it and much easier to install with unetboot than a slimmed down XP (nlite)

The only thing that is bugging me is how to get the gps navigation to work…
Have been trying and reading instructions on it but so far no succes…

Some help is very much appreciated…

Grtz, marc


hardware : ADAPT AD-300 Bluetooth GPS
bluetooth dongle : mogo bluetooth adapter Engadget is part of the Yahoo family of brands)
software : I used drive sygic xp perfect… but not for linux so viking or gpsdrive should be fine…

Hi nomadic, and welcome to the forum :slight_smile:

What exactly is the problem … the bluetooth GPS device not being recognised by Peppermint, or not being seen by the navigation software ?

Have you tried getting sygic to run in WINE ? (be aware installing WINE in Peppermint brings in a LOT of other libraries, just thinkg of your disk capacity limitations)


These are inks to running sygic in WINE … just for future reference if you decide to try the sygic in WINE route:
(not necessarily of any use, just don’t want to forget them)

http://www.mp3car.com/linux/134682-three-questions-regarding-sygic-wine.html
and

with # hcitool scan it shows my BT GPS …
so maybe it the program that doesn’t see my gps adapter…
I’m trying Viking gps software right now…

for example if I open XGPS it’s say’s GPSD not running…

The main problem is me not understanding completely what I’m doing…

Is gpsd installed ?

gpsd is installed
when I try to run the program from the terminal I get this message :
gpsd: can’t run with neither control socket nor devices ??

See this thread:

you need to work out which “device” your bluetooth adapter is … possibly /dev/rfcomm0

Uplugging it, waiting 10 secs or so, then replugging it, and running:

dmesg | tail -n 30

should give you a clue.

Then you need to start gpsd with the correct options … such as:

gpsd -bn /dev/rfcomm0

thanks mark…
seems to be a pretty good explanation on the other forum…
I’ve got GPSD running in the right modus…xgps doesn’t show any data

when I do cat/dev/rfcomm0 : Device or resource busy ??

It’s a nice puzzle…

Grtz,Marc.

I’m sorry, but I don’t know if I can offer much more help with this as I don’t have any GPS hardware, and have never used any … I’ll keep looking, but there’s no way for me to test anything I find.

If I come across anything that seems relevant, I’ll post it here, but you may be better off asking on the xGPS forum:
http://xgpsdev.xwaves.net/forum/

Thanks for the effort…I just keep on trying to fix it

Keep checking back … I might find something … I haven’t given up :slight_smile:

But if you do find a solution, I’d like to hear about it, if you have time :slight_smile:

Never give up!!!
Tomorrow morning I start again fresh…
Will post an update on the progress…