HP LaserJet Pro MFP M130fn NOT working wth Xsane

Hello,

I’ve been trying to make my laptop to “speak” with the scanner for the past half a day, with no success. I installed hplip and used the interactive interface to setup the printer which works fine. When opening Xsane, I got the error:

`hpaio:/net/HP_LaserJet_MFP_M129-M134?ip=10.10.10.1’
Error during device I/O.

I followed all the steps in the trouleshooting guide provided in the Scanning Troubleshooting section of the HP Linux Imaging and Printing page.

The hpaio appears in /etc/sane.d/dll.conf and is not commented out and I run both commands (after commenting out all the SANE backends which I’m not using):

$ export SANE_DEBUG_DLL=128
$ scanimage -L

As advised, I checked out the output for errors but I cannot see where the issue might be so I am pasting it here for your review and feedback:

valentin@thinkpad:~$ xsane hpaio:/net/HP_LaserJet_MFP_M129-M134?ip=10.10.10.1
[sanei_debug] Setting debug level of dll to 128.
[dll] sane_init: SANE dll backend version 1.0.13 from sane-backends 1.0.25
[dll] sane_init/read_dlld: attempting to open directory ./dll.d' [dll] sane_init/read_dlld: attempting to open directory /etc/sane.d/dll.d’
[dll] sane_init/read_dlld: using config directory /etc/sane.d/dll.d' [dll] sane_init/read_dlld: considering /etc/sane.d/dll.d/libsane-extras [dll] sane_init/read_config: reading dll.d/libsane-extras [dll] add_backend: adding backend ls5000’
[dll] sane_init/read_dlld: considering /etc/sane.d/dll.d/hplip
[dll] sane_init/read_config: reading dll.d/hplip
[dll] add_backend: adding backend hpaio' [dll] sane_init/read_dlld: done. [dll] sane_init/read_config: reading dll.conf [dll] add_backend: adding backend net’
[dll] add_backend: adding backend hpaio' [dll] add_backend: hpaio’ is already there
[dll] sane_get_devices
[dll] load: searching backend hpaio' in /usr/lib/x86_64-linux-gnu/sane:/usr/lib/sane’
[dll] load: trying to load /usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1' [dll] load: dlopen()ing /usr/lib/x86_64-linux-gnu/sane/libsane-hpaio.so.1’
[dll] init: initializing backend hpaio' [dll] init: backend hpaio’ is version 1.0.0
[dll] load: searching backend net' in /usr/lib/x86_64-linux-gnu/sane:/usr/lib/sane’
[dll] load: trying to load /usr/lib/x86_64-linux-gnu/sane/libsane-net.so.1' [dll] load: dlopen()ing /usr/lib/x86_64-linux-gnu/sane/libsane-net.so.1’
[dll] init: initializing backend net' [dll] init: backend net’ is version 1.0.25
[dll] load: searching backend ls5000' in /usr/lib/x86_64-linux-gnu/sane:/usr/lib/sane’
[dll] load: trying to load /usr/lib/x86_64-linux-gnu/sane/libsane-ls5000.so.1' [dll] load: dlopen()ing /usr/lib/x86_64-linux-gnu/sane/libsane-ls5000.so.1’
[dll] init: initializing backend ls5000' [dll] init: backend ls5000’ is version 1.0.0
[dll] sane_get_devices: found 1 devices
[dll] sane_open: trying to open hpaio:/net/HP_LaserJet_MFP_M129-M134?ip=10.10.10.1' [dll] sane_exit: exiting [dll] sane_exit: calling backend hpaio’s exit function
[dll] sane_exit: calling backend net's exit function [dll] sane_exit: calling backend ls5000’s exit function
[dll] sane_exit: finished

Could be the fact that the only backend in use is the “ls5000” whereas my printer is “HP LaserJet Pro MFP M130fn”?

The distro is Debian 9.3

Thank you for your help,

Valentin

Which version of hplip does Debian come with ?

According to this:
https://sourceforge.net/p/hplip/news/2017/10/hplip-31710-release-notes/
support for the LaserJet Pro MFP M130fn wasn’t added until hplip 3.17.4

Hi Mark,

Thank you for your reply. I didn’t add the print server package when I first installed Debian 9.3 on my laptop. I added cups afterwards. Then I installed the latest version of hplip: 3.17.11.

Regards,

Valentin

Have you tried this with a direct USB connection ?

I’ve tried the USB connection and, as with the network connection, no success in scanning.

I had a thorough look at the trouble shooting guide on the website and I attached to this post the output of the commands (the hpaio.txt file). I have also attached the logs for:

hp-check
hp-check -t

Maybe this helps.

Cheers,

Valentin

I’ve forgotten to mention that I did my tests on two different machines: the Debian 9.3 laptop and a Raspberry Pi with the latest Raspbian Stretch, then the same Raspberry Pi with an older distro: Raspbian Jessie (a release from November 2016).

Have you tried installing hplip-gui, then configuring your printer/scanner via the HPLIP Toolbox ?

I did try to install the printer / scanner via the GUI with no success.

Anyway, eventually I managed to make it work: I issued tail -f /var/log/syslog and noticed an error regarding a plug-in which was missing (I didn’t pay attention to this as in the supported printers page the “Plug-In Required” column was showing “NO”). All I did was to run hp-plugin in user mode. Now I am able to scan over the network.

I put this issue to the fact that hplip supports Debian up to 9.1, and I am using 9.3.

Thanks for your help,

Valentin

Great stuff, glad you got it working, and thanks for taking the time to post the solution :slight_smile: