HPLIP Toolbox

Hi All - for some reason my HP Toolbox has disappeared!

I can invoke it from the start menu but it doesn’t load and reports a system crash. I tried removal/ reinstall but no different. Any clues please?

Running Mint 13 KDE

TIA

Rich

Any clues if you try to start it from the terminal with:

sh -c 'STARTED_FROM_MENU=yes /usr/bin/hp-toolbox'

?

Hi Mark - thanks, that got it working again and the icon has reappeared in the taskbar although it still flagged up a crash warning… ???

The command produced this output - don’t know if there any any clues there?

$ sh -c ‘STARTED_FROM_MENU=yes /usr/bin/hp-toolbox’

HP Linux Imaging and Printing System (ver. 3.12.2)
HP Device Manager ver. 15.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /home/richard/.config/ibus/bus

Rich

I take it your username is richard ?

if so, run:

mkdir -p /home/richard/.config/ibus/bus

and see if you still get errors

code returns as per -

richard@richard-Ei-306 ~ $ mkdir -p /home/richard/.config/ibus/bus
richard@richard-Ei-306 ~ $ sh -c ‘STARTED_FROM_MENU=yes /usr/bin/hp-toolbox’

HP Linux Imaging and Printing System (ver. 3.12.2)
HP Device Manager ver. 15.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

richard@richard-Ei-306 ~ $

That seems to have done the trick! Thanks Mark! :wink:

No problem :slight_smile: