i cant rcover my pc after sleep !!

Hello:
I’m used to close laptop lid to make it sleep, but in Linux after 2 times closed , the pc just show me the blank desktop , with blank menu!!
any suggestion please

Hold Ctrl+SysRq and type r e i s u b (waiting a couple of seconds between key strokes)

Your system should reboot … is it displaying properly after a reboot ?

Hello
yes it works ok after reboot, but close the lid 2 times make all thing disappear , so i must reboot again and loose my work,

Okay there are a few things that might cause this

  1. Peppermint set to hibernate on lid close, and the swap partition not being large enough

  2. Your system not being happy with the MATE power manager

  3. This problem
    http://forum.peppermintos.com/index.php/topic,1046.0.html

For now, post the output from:

free -m

total used free shared buffers cached
Mem: 7904 6946 957 168 127 4254
-/+ buffers/cache: 2564 5340
Swap: 8107 0 8107

Okay, you seem to have enough swap space … JUST!!!

Next, let’s try changing the power manager

sudo apt-get remove --purge mate-power-manager mate-power-manager-common

then

sudo apt-get install xfce4-power-manager

now go to

menu > Preferences > Default applications for LXSession > Core applications (tab)

and change

Power Manager mate-power-manager

to

Power Manager xfce4-power-manager

Now log off/on or reboot.

Now right-cick the power manager icon by the system clock, and select “About” … it should now say it’s the “xfce4-power-manager”

If it does, check what happens if you close the lid now ??

if it works, great.

If it doesn’t, run

gksudo gedit /var/lib/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

and when a blank file opens make it read

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

SAVE the file, and exit gedit.

then test again.

I replace the power manager, then i choose Suspend when i close the lid" but same thing, just blank windows, and i must force power down to get control over the system

does

sudo pm-suspend

do the same thing … ie. leave you at a blank screen that you cannot resume from ?

if so, use the REISUB trick to reboot then post the output from

inxi -F

Hello:
i found this in Ask Ubuntu , and its work good ,just the menu is still blank but if you put the cursor on it , its return

[size=12pt]I had a similar problem on Ubuntu Gnome 15.10. This is what worked for me:
sudo gedit /etc/default/grub
Edit the line: GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash’”
Replace it with: GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash acpi_backlight=vendor
acpi_osi=‘!Windows 2013’ acpi_osi=‘!Windows 2012’”
sudo update­grub
Then you have to reboot twice. I know. You have to do it twice, though.
That fixed the issue for me, hopefully, this helps someone else.
[/size]

and this is the output from your command

System: Host: hayder-Lenovo-G50-80 Kernel: 3.16.0-67-generic x86_64 (64 bit) Desktop: N/A Distro: Peppermint Six
Machine: System: LENOVO product: 80E5 version: Lenovo G50-80
Mobo: LENOVO model: Lenovo G50-80 version: NO DPK Bios: LENOVO version: B0CN97WW date: 01/08/2016
CPU: Dual core Intel Core i7-5500U CPU (-HT-MCP-) cache: 4096 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx)
Clock Speeds: 1: 2958.375 MHz 2: 1966.125 MHz 3: 2997.656 MHz 4: 2974.968 MHz
Graphics: Card: Intel Broadwell-U Integrated Graphics
X.Org: 1.16.0 drivers: ati,radeon,intel (unloaded: fbdev,vesa) Resolution: [email protected]
GLX Renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) GLX Version: 3.0 Mesa 10.3.2
Audio: Card-1: Intel Wildcat Point-LP High Definition Audio Controller driver: snd_hda_intel
Card-2: Intel Broadwell-U Audio Controller driver: snd_hda_intel
Sound: Advanced Linux Sound Architecture ver: k3.16.0-67-generic
Network: Card-1: Realtek RTL8723BE PCIe Wireless Network Adapter driver: rtl8723be
IF: wlan0 state: up mac: 18:4f:32:02:c1:39
Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller driver: r8169
IF: eth0 state: down mac: 50:7b:9d:2c:4b:89
Drives: HDD Total Size: 1000.2GB (19.0% used) 1: id: /dev/sda model: ST1000LM024_HN size: 1000.2GB
Partition: ID: / size: 909G used: 177G (21%) fs: ext4 ID: /boot size: 236M used: 71M (32%) fs: ext2
ID: swap-1 size: 8.50GB used: 0.05GB (1%) fs: swap
RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors: System Temperatures: cpu: 38.0C mobo: N/A gpu: N/A
Fan Speeds (in rpm): cpu: N/A
Info: Processes: 213 Uptime: 16:46 Memory: 2479.0/7904.4MB Client: Shell (bash) inxi: 1.9.17

Hello
After I update to version 7, and close the lid , I cant recover my PC !!

Have you tried your GRUB edits again ?

yes i did, but the last command ( sudo update grub) not works !!

The command is

sudo update-grub

I did it now , but still same problem…