I have corrupted my OS and need help? Please!

::slight_smile: Hello all, I am in need of some help and advice. I am brand NEW!! to LINUX, and have just received a New PC with an OS Called @N’NIE, the OS is LINUX based… I was updating to V19, when I realised the USB Flash Stick was plugged into the USB port. The system was just begining to boot up when like a real pleb, I pulled the stick out, thinking that I had enough time, alas NOT!!

I have now managed to kill the system, the message I am getting is as follows… kernel panic - not syncing: Attempted to kill init!

Can anyone tell me what I can do to revive my OS? I am hoping that I can install a piece of rescue software to allow the udating to v19. to finish? Dare I hope it could be that simple? Thank you for your assistance… regards,

Can you tell us more about the PC as I can find no reference to as distro called @N’NIE

Is there any more to the message that ends with… “kernel panic - not syncing: Attempted to kill init!”

kernel panic - not syncing: Attempted to kill init!

Typically issued by a running kernel that’s lost access to it’s root filesystem (maybe because someone pulled it out of the USB port?).

Have you tried re-inserting the Stick and rebooting?

I hope this information is useful to you.

I have attempted to reboot the system using the V19 OS Upgrade flash drive. Initially it appears to be accepting the upgrade but ends up hanging on a blank screen all bar… “starting Up X11 session manager” _ flashing cursor… at this point I cannot input any further commands.
I suspect it is because I do not have access to a USB wired keyboard. The only keyboard I have connected to @N’NIE at this time is a wireless keyboard. But I do have a wired mouse connected to the @N’NIE PC.

I hope this has been helpful in assisting you with any solutions you may be aware of that can help me out of this situation.

Would the Ubuntu 10.x OS fit on to a 8gb flash drive? If so do you think this may help me out of this situation?

I will look forward to your response.

No further info after the message “kernel panic - not syncing: Attempted to kill init!” but going above
line by line backwards…

Code: Bad EIP Value.
EIP: [<00000000>]
CRZ: 0000000000000000
— [endtrace ea4ebe21 fecc7f36]—

“kernel panic - not syncing: Attempted to kill init!”

most of the information above <Code: Bad EIP Value.> passes to fast to read

Mmm, I’d be inclined to send it back, get a standard PC and put a known version of Linux on it.

Have you tried loading a previous kernel?

Hit the “Esc” (or shift) key at the beginning of the boot process and see if you are offered a list of different kernels and/or recovery mode to boot from.

EIP = Enhanced Instruction Pointer, if I’m understanding this correctly, it looks like something is being placed in a non-existent memory register.

I would still like to know more about the Linux distro and where you got the v19 upgrade.

It could be caused by any number of things from bad memory to a corrupt file system to a kernel module being loaded incorrectly, but from what I gather EIP issues are normally hardware related, but as you suspect this could just be a keyboard and/or driver issue.

It could also be an ACPI and/or APIC issue, but I can’t offer info on passing kernel boot parameters without knowing if the GRUB or LILO bootloader is being used.

In answer to your question… Yes, Ubuntu has been loaded onto many netbooks with 8gb solid state drives, and/or LiveUSB keys… If you can boot an Ubuntu LiveUSB key you might be able to get some more info from the logs… or you could just load Ubuntu and ditch your current OS.

But I would first attempt to use a wired keyboard and boot from an earlier kernel or recovery mode.