Ice will not open (Solved)

Hi, have been using Peppermint 4 for a week or so now after sorting out the dual boot with XP, (incidentally, I have not logged on to XP once since this,) but find that for some reason when I click on Ice nothing happens, any suggestions, please.

Thanks,
Degsy

First thing to try … open a terminal (Ctrl+Alt+T) and run:

sudo apt-get remove ice

then:

sudo apt-get install ice

then try Ice.

If it still doesn’t work … can you try running ice from the command line:

ice

and post anything returned in the terminal.

Still didn’t work.
derek@derek-MM061 ~ $ ice
Traceback (most recent call last):
File “/usr/bin/ice”, line 376, in
Ice()
File “/usr/bin/ice”, line 292, in init
self.fill_store()
File “/usr/bin/ice”, line 362, in fill_store
icon = gtk.gdk.pixbuf_new_from_file_at_size(iconline, 16, 16)
glib.GError: Unrecognised image file format

Can you run:

tar -cvf ~/ice-issue.tar.gz ~/.local/share/applications ~/.local/share/ice

You’ll then find a file called “ice-issue.tar.gz” in your home folder … attach that to your next posting.

Atached as requested

OK, this is going to remove all your custom ice shortcuts … but if this solves the problem, you can recreate them.

run:

mv -v ~/.local/share/applications ~/.local/share/applications-old

then

mv -v ~/.local/share/ice ~/.local/share/ice-old

then

cp -rv /etc/skel/.local/share/applications ~/.local/share/ice

then

cp -rv /etc/skel/.local/share/ice ~/.local/share/ice

then

cp -vf ~/.local/share/applications-old/mimeapps.list ~/.local/share/applications/mimeapps.list

Does ice start now ?

Only went this far:-
derek@derek-MM061 ~ $ mv -v ~/.local/share/applications-old
mv: missing destination file operand after ‘/home/derek/.local/share/applications-old’

Degsy

Copy and paste the above commands one at a time into the terminal (and run them).

The command you entered is not one of the ones I gave you :wink:

Yes, opens now, once again many thanks for your help.
Will mark the thread SOLved

Degsy

If it breaks again, can you let me know what the last shortcut you created was … TIA