I'm a Broken man!

Hi
Ok first things first, I have linux 18.3 running on my laptop along with windows vista trying to use linux more and more although I still find it not as friendly as windows when adding or changing anything which brings me my present problem. I have a desktop with windows 7 on and decided to install 18.3 on it I admit its an old desktop and board but it does have a intel processor @2.66 gz so I figured it would be ok as windows works fine I have 1.5gb memory also. The problem is it takes FOREVER to start and when it finaly gets going its unusable ie
SO slow i click on an icon and wait, and wait etc its just a total pain i feel like giving up and staying with w7. BUT I have now spent 3 days trying to sort it out and came across another thread which says graphix driver could be a problem The native board graphics driver didnt display correctly as I could only get 640x320 or something similar so I got another agp graphics card from fleabay a ati radeon 9600 but that too will not dispaly correctly. I have since found out that ati are BAD for support. I have download a driver file but not sure how or where to unpack it! I am not that good at the terminal lol. incidentaly my laptap is also old but it has a radeon card in and no problems. I have now come to a stop as I am just going round in circles I am typiing this on my laptop as I cant even use the desktop for typing as it takes ages for the letters to appear when I am typing. like I mentioned before I want to use linux but windows is giving me no problems at all ( apart from spying, logging, keystrokes etc lol) if anyone can help it would be appreciated. incidentally the drive with linux on is around 50gb so it shouldn’t be that Any help would be appreciated to stop this silver surfer from reaching for a happy pill!
Cheers Paul

Run

systemd-analyze blame > ~/Desktop/blame.txt

and

systemd-analyze critical-chain > ~/Desktop/critical-chain.txt

and

dmesg >  ~/Desktop/dmesg.txt

now host the three files that just appeared on the desktop somewhere like
http://www.tinyupload.com/

and provide us with links to them

Also post the output from

df -h

Mark ,would he be better off installing Peppermint as he has an older machine?

Good Morning Mark
Thank you for reply and sorry for not getting back to you earlier but had a few problems carrying out the said instructions purely down to myself! anyway I think
i have finally succeeded :slight_smile: so here goes. The 3 files you wanted are in the attachment broken1 and the final one is shown below
pauly@pauly-desktop ~ $ df -h
Filesystem Size Used Avail Use% Mounted on
udev 728M 0 728M 0% /dev
tmpfs 151M 5.0M 146M 4% /run
/dev/sda1 228G 6.9G 210G 4% /
tmpfs 753M 752K 752M 1% /dev/shm
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 753M 0 753M 0% /sys/fs/cgroup
cgmfs 100K 0 100K 0% /run/cgmanager/fs
tmpfs 151M 40K 151M 1% /run/user/1000
/dev/sdb1 3.8G 3.1G 699M 82% /media/pauly/0C94C6BE94C6A9
I HOPE I have done everything correctly it took me a while to get my head around the commands! One thing I had a problem with is the dmesg one it just stayed
In the terminal window however scrolling through it to try again I noticed that it said I have a "winfast card/ xp " but I haven’t not sure whether that is anything to do with
my problems or its just a standard output not knowing what I was looking at ! I do have a soundblaster card installed and the graphics card is ati radeon RV350(9600 series
128mb , I know its old hat but I dont play games and it plays dvd files ok in windows .The motherboard is a Foxconn 661FX7mj. Like I say I know its not cutting edge hardware
but it will suffice my needs. AS I mentioned before my laptop runs 18.3 fine and it has a radeon card in that and the processor is only 2.0ghz where the copmuter is a 2.6ghz
and 1.5gb memory. Anyway I will leave it in your capable hands
Cheers for now
Paul

http://s000.tinyupload.com/?file_id=37294747414861632461
http://s000.tinyupload.com/?file_id=24584286596927527678
http://s000.tinyupload.com/?file_id=02806791139085824519

Do you have a floppy disk inserted, because the system appears to be having trouble reading it during bootup … which appears to be causing a 13 second delay in bootup

[    7.719178] Btrfs loaded, crc32c=crc32c-generic
[   20.644335] print_req_error: I/O error, dev fd0, sector 0
[   20.644347] floppy: error 10 while reading block 0

Absolutely, but suggesting that as a “fix” might be a bit disingenuous at this point … makes sense too check if there are any other underlying issues first :wink:

Hi Mark
Floppy disk ? no have not even got a skeleton of one lol. Very strange. I do have a confession to make though, I said I haven’t a winfast card alas i have ! just forgot about it . I wholeheartedly agree about the startup being slow as well approx up to 3 minutes to get up and running.

Okay what’s the output from

cat /etc/initramfs-tools/conf.d/resume

and

cat /etc/fstab

and

sudo blkid

BTW, if this is a desktop PC you may want to experiment with disconnecting that floppy drive and see if it makes a difference.

ok , the first code gives the following readout:
RESUME=UUID=3a5c151f-9562-4555-9f40-5a2e7ca6c0d8
the second code gives:
cat /etc/fstab

/etc/fstab: static file system information.

Use ‘blkid’ to print the universally unique identifier for a

device; this may be used with UUID= as a more robust way to name devices

that works even if disks are added and removed. See fstab(5).

/ was on /dev/sda1 during installation

UUID=e055fb36-989f-4b8e-b332-94fd733d1422 / ext4 errors=remount-ro 0 1

swap was on /dev/sda5 during installation

UUID=3a5c151f-9562-4555-9f40-5a2e7ca6c0d8 none swap sw 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
And the third one gives:
sudo blkid
[sudo] password for pauly:
/dev/sda1: UUID=“e055fb36-989f-4b8e-b332-94fd733d1422” TYPE=“ext4” PARTUUID=“f9493a72-01”
/dev/sda5: UUID=“3a5c151f-9562-4555-9f40-5a2e7ca6c0d8” TYPE=“swap” PARTUUID=“f9493a72-05”
/dev/sdb1: UUID=“0C94C6BE94C6A992” TYPE=“ntfs”
Yes it is a desktop pc but I have NO floppy disk /cable attached to the mother board the floppy socket is bare but I do see what you mean if I am correct the last line
of the previous readout dev/fdo mentions floppy but thats all I can say
Cheers

Try commenting out this line in /etc/fstab :

sudo nano /etc/fstab
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
make it thus:
#/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

then reboot and see if that reduces the boot time

I’d suggest

sudo xed /etc/fstab

in place of SeZo’s first command … unless you know your way around nano :wink:

Hi
WELL, that was a near miss lol. I saw a reply and proceeded to follow the instructions and got myself in a right old mess not realising that it was a different person answering ! I was
just about to reply with I cant do that and saw Mark’s post to try a different first line which worked fine as no I dont know nano at all and got myself in all sorts of bother lol. Anyway the upshot
is it hasnt helped much the boot time to getting the desktop icons to appear is 1 minute 36 seconds which is a little better but i have a black screen for quite a while before anything happens. then every time I open a window I cant see anything else as its too big and I have to try resize it thats after I have waited for it to go into action , The whole thing is a nightmare
the display wont let me change anything it comes up with unknown display and I am stuck at 1024x768(4.3) the only other option is 800x600(4.3) and anything I do is SO slow and laboured which is why I am replying using my laptop lol.I think I will have to admit defeat and just use the windows as that has no issues at all using the same graphics card and just use linux in the laptop which is getting on for 8 years or more old.
Cheers

I would not give up just yet. I am running a windows 7 and mint 18.2 64bit desk top with very few problems.

Mark would it be a good plan to find out the specs of the system and try a number of live USBs to see which version of Linux is the best.

For me I always find windows takes longer to start then mint.

I’m running a 6 year old machine with W8 pro and Mint 19 with no problems.

Can you post the output from:

inxi -Fz

and

dpkg -l | grep -i sis

Hi Mark
The BAD news is I cant send you an output because I no longer have an operating system! I was trying all manner of things and then suddenly it stopped i. it wont boot any more so I
have loaded the cd rom again to reinstall it however its just as bad running from that so its no point going any further at this moment in time. Not only was the display rubbish but like i
said 5-12 seconds after clicking on an icon for anything to happen it is useless. I even think it could be the hard drive, the motherboard etc but then again windows 7 runs fine so I will
leave alone now . Thank you for all your efforts and although I am like a dog with a bone usually and wont stop trying this has gone too far lol. I accept defeat gracefully. If I ever get it sorted
I will let you know in the meantime take a big breath or a sigh of relief knowing that unlike Arnie…I wont be back!
many thanks
Paul

Good morning Mark
I am back ! After my demise the other day I decided that I would not be beaten by a machine so I went back to basics and breadboarded the whole system. (in fact it still is running outside
the case) booted up mint from dvd and I could see straight away that the the display was ok so I went to install it . I got half way through then it came up with an error about the
the disc being dirty or the hard drive couldn’t be written to . I knew the disc was ok so tried again, same result time to change to a newer hard drive, the one I was using was a ide, now gone to a sata drive VOILÀ mint installed in around 20 minutes and the screen resolution was bang on . I ran the dmesg command you asked me to do the other day and it showed that I had a radeon card etc so everything was fine. HOWEVER I did have a small problem in as much when I try to update I get the message of dpkg was interrupted and you must run it manually but when I tried it said I need to be a super user to do this! Anyway found out about superuser and logged in as that and a WHOLE lot of information passed my eyes lol. Updating this, installing that etc now its downloading the packages for updates and I have just got the message to say my system is up to date. Finally I can now say mint is installed and running nicely on my old board and I am a super user (only kidding)
Ok thanks again for your help the other day at least now I know I am in good hands if I have any problems in the future
Cheers
Paul

Glad you didnt give up and managed to sort it. :slight_smile:

thanks, it really does feel satisfying in the end lol. So… you have mint 19 on your system now there’s a thought …perhaps another time lol

Nicely done :slight_smile: