install problem with Peppermint 3 on a Dell "Inspiron Mini" Netbook

Hello, I have recently installed Peppermint 3 on my Dell Netbook.

On start up the Dell logo is flashed and then the screen goes blank.

If I insert the boot USB stick and press F12 and then select the boot USB I can get to the Peppermint desktop.

what have I done wrong to get this to start without the boot USB stick?

Many thanks,

Hi emilly, and welcome to the forum :slight_smile:

Can you give us the model of Dell netbook … should be on a sticker on the bottom of the netbook.

mini 9
mini 10
mini 10V

That kind of thing.

Hello Mark,
It is an Inspiron Mini 10 - it is a basic one. the only part I upgraded was the battery. Bought in 2009.
I have copied the list of the other components below in case that helps.

Base: Intel Atom Processor N270
OS; Genuine Windows XP
Memory: 1024MB 533Mhz Dual Channel DDR2 SDRAM
VIDEO CARD: Integrated Intel Graphic Media Accelorator 950
Hard Drive: 160GB SATA
Wireless: Dell wireless 1397 Minicard

Have seen Peppermint on my dad’s Acer and would love to get it working on my netbook too. :slight_smile:

OK, can you answer a few questions for me.

What happens if you turn ON your netbook, then as soon as you see the Dell logo, hit and hold the Shift key … are you presented with the GRUB boot menu ?

Have you tried leaving it for a minute or 2 at the black screen and seeing if it eventually boots … normally Peppermint will display the Peppermint logo with some dots underneath, but on some systems that doesn’t get displayed, you just get a blank screen till it gets to the login screen.

If after 2 minutes it’s still displaying a black screen … what happens if you hit Ctrl+Alt+F2 (at the same time) … does it drop to a text console (white writing on a lack background) ? … if so, what happens if you now hit Ctrl+Alt+F7 ?
(you may also have to hold the Fn key on a Dell mini 10 if the Fn key is required to access the F1 - F12 keys)

Can you boot to the Peppermint LiveUSB, then open a terminal (Ctrl+Alt+T) and run:

sudo lshw -C display

and post back here what’s returned in the terminal.

Remember, Linux commands ARE case sensitive, so that’s a capital C … and for clarity, that’s a lower case L in lshw, which stands for “list hardware”.

If it boots from the USB stick then it might be one of two things:
a) Boots to the live image (located on the USB)
b) If it boots to the HDD installed Peppermint (via the USB) then it might be because the grub (stage 1)
was installed onto the USB stick.
Done this myself except it was a floppy disc then. :-[

If it is the latter then instructions are available for re-installing grub to the MBR of the HDD

great - thanks to you both.
I will try those tests and let you know what happens.
probably tomorrow but will try to do it sooner.

Hello Mark,
There was no response at all to any of the actions except the command in the terminal. I took a screen shot is there a way to get it to you as I can’t seem to insert it into this reply?

Hi again - cut and paste the terminal response below

emily@DellNetbook ~ $ sudo lshw -C display
[sudo] password for emily:
description: VGA compatible controller
product: Mobile 945GSE Express Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 03
width: 32 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:16 memory:f0000000-f007ffff ioport:1800(size=8) memory:d0000000-dfffffff memory:f0200000-f023ffff
*-display:1 UNCLAIMED
description: Display controller
product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2.1
bus info: pci@0000:00:02.1
version: 03
width: 32 bits
clock: 33MHz
capabilities: pm bus_master cap_list
configuration: latency=0
resources: memory:f0080000-f00fffff
emily@DellNetbook ~ $

Whilst still booted from the LiveUSB, can you open a terminal and run:

sudo fdisk -l

(for clarity … that’s a lower case L at the end of that command)

I’m guessing it didn’t get installed … or at least the GRUB bootloader didn’t, as holding the Shift key just after turning on the PC should have brought up the GRUB boot menu.

Whilst booted to the Peppermint LiveUSB, can yo go to menu>File Manager … when the File Manager opens, can you see if your internal hard drive is listed n the left hand column … if so, does it contain directories with names like


and some others ?


Is this to be a dual boot system where you choose Windows or Peppermint at boot time … or a purely Peppermint netbook ?

A little good news for you … you definitely have a mini 10, not a mini 10v … the 10v can be a pain in Linux (because of its Poulsbo graphics card), but your mini 10 should run Peppermint just fine, so it’s just a matter of finding what went wrong :slight_smile:

Hello, Am really pleased to hear that Peppermint should run okay on this as fed up with Windows! I am not looking for a dual boot system either - would like to keep it as simple as possible!

In the File Manager the left hand column lists the folders
emily (is this the hard drive"?)

within “emily” there are folders but none of the ones you list! I have a screen shot of this if helpful?

This is what came back when in the terminal …

emily@DellNetbook ~ $ sudo fdisk -l
[sudo] password for emily:

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders, total 312581808 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00083ad8

Device Boot Start End Blocks Id System
/dev/sda1 2048 310503423 155250688 83 Linux
/dev/sda2 310505470 312580095 1037313 5 Extended
/dev/sda5 310505472 312580095 1037312 82 Linux swap / Solaris

Disk /dev/sdb: 8097 MB, 8097103872 bytes
256 heads, 18 sectors/track, 3432 cylinders, total 15814656 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

Device Boot Start End Blocks Id System
/dev/sdb1 * 6072 15814655 7904292 c W95 FAT32 (LBA)
emily@DellNetbook ~ $

OK, for screenshots you should be able to add then to your posting as an “attachment” … otherwise you’d need to host them elsewhere (such as flickr) and provide a link.

Anywho … if you open a terminal and run these commands in sequence:

sudo mkdir /media/hdd


sudo mount /dev/sda1 /media/hdd


ls -a /media/hdd

What is the output from the last command

It is

emily@DellNetbook ~ $ sudo mkdir /media/hdd
[sudo] password for emily:
emily@DellNetbook ~ $ sudo mount /dev/sda1 /media/hdd
emily@DellNetbook ~ $ ls -a /media/hdd
. boot etc lib mnt root selinux tmp vmlinuz
… cdrom home lost+found opt run srv usr
bin dev initrd.img media proc sbin sys var
emily@DellNetbook ~ $

“tmp” is highlighted in green background
“vmlinuz” & “initrd.img” show up as a lighter blue font colour
everything else in the list is in blue

have tried attaching the 3 screen shots so far

OK, it looks like there is a Linux install on the hard drive … I’m assuming that’s Peppermint, if you’ve had a previous version of Linux installed STOP NOW and let me know … otherwise carry on -

We’re going to reinstall the GRUB bootloader, and point it at the Linux install on the hard drive.

Open a terminal and run:

sudo mount /dev/sda1 /mnt


sudo grub-install --boot-directory=/mnt/boot /dev/sda

now shut down your PC

Once shut down … unplug the LiveUSB, and turn on your PC (so it boots from the hard drive) … hopefully it will boot to Peppermint, if it does, open a terminal and run:

sudo update-grub

If it doesn’t … boot back to the LiveUSB and let me know … we’ll then try it from a “chroot” environment.

It is Peppermint the only other system in use was the XP it came with. Will follow your instructions now and postback asap

Hi, it didn’t work. The screen that was blank (following the Dell screen) now shows the following information:

error: file not found.
grub rescue>

Can you open your file manager (menu>file Manager) and tell me if the left hand column still has a directory called “emily” and NOT one called “peppermint”

as it was before.
There is a drive called “emily” but not one called “peppermint”

OK, I think I know what’s happened … you ARE actually running Peppermint from the hard drive (NOT the LiveUSB) … somehow you managed to install stage 1 of the GRUB bootloader to the LiveUSB stick, which then point to the hard drive installation … so you ARE running from the hard drive, but it can’t boot without the LiveUSB plugged in.

Open a terminal and run:

sudo grub-install /dev/sda

and reboot to the hard drive.

done - terminal replied “Installation finished. No error reported”

did you need me to shut down ad restart again?