Installed P6 not recognizing my Android phone = ??

As the thread title, but the really weird part, is that when I booted from a USB stick, to see if it would work with the phone, it did !!, and now having installed it, it does not.

What actually happens is that the directory structure appears in file manager, but if one tries to copy, then the process either hangs, or eventually generates an error message with “unable to get object handles”

The actual error message is:- “Sorry, could not display all the contents of “Card”: libmtp error: could not get object handles.”

I suspect that I have done something silly, but would be grateful of some help !!

Output from uname -a ; and dmseg |tail -n 40 - which I think might help folk understand…

sim@sim-flaptop ~ $ uname -a
Linux sim-flaptop 3.16.0-50-generic #66~14.04.1-Ubuntu SMP Thu Sep 10 17:05:00 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
sim@sim-flaptop ~ $ dmesg | tail -n 40
[ 9373.066063] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 9373.066067] cfg80211: (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 9373.066070] cfg80211: (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 9373.066073] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 9373.066075] cfg80211: (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 9401.649987] wlan0: authenticate with 58:7f:66:b1:52:80
[ 9401.653549] wlan0: send auth to 58:7f:66:b1:52:80 (try 1/3)
[ 9401.683468] wlan0: send auth to 58:7f:66:b1:52:80 (try 2/3)
[ 9401.690662] wlan0: authenticated
[ 9401.691001] wlan0: waiting for beacon from 58:7f:66:b1:52:80
[ 9405.433975] wlan0: authenticate with 58:7f:66:b1:52:84
[ 9405.438254] wlan0: direct probe to 58:7f:66:b1:52:84 (try 1/3)
[ 9405.639460] wlan0: direct probe to 58:7f:66:b1:52:84 (try 2/3)
[ 9405.843632] wlan0: direct probe to 58:7f:66:b1:52:84 (try 3/3)
[ 9406.047806] wlan0: authentication with 58:7f:66:b1:52:84 timed out
[ 9409.751889] wlan0: authenticate with 58:7f:66:b1:52:80
[ 9409.755968] wlan0: send auth to 58:7f:66:b1:52:80 (try 1/3)
[ 9409.758316] wlan0: authenticated
[ 9409.758980] wlan0: associate with 58:7f:66:b1:52:80 (try 1/3)
[ 9409.764665] wlan0: RX AssocResp from 58:7f:66:b1:52:80 (capab=0x411 status=0 aid=1)
[ 9409.777918] wlan0: associated
[ 9409.778006] cfg80211: Calling CRDA for country: GB
[ 9409.782101] cfg80211: Regulatory domain changed to country: GB
[ 9409.782107] cfg80211: DFS Master region: unset
[ 9409.782109] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 9409.782114] cfg80211: (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 9409.782117] cfg80211: (5170000 KHz - 5250000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[ 9409.782120] cfg80211: (5250000 KHz - 5330000 KHz @ 40000 KHz), (N/A, 2000 mBm), (0 s)
[ 9409.782123] cfg80211: (5490000 KHz - 5710000 KHz @ 40000 KHz), (N/A, 2700 mBm), (0 s)
[ 9409.782126] cfg80211: (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[10830.539509] usb 3-2: new high-speed USB device number 3 using xhci_hcd
[10830.668290] usb 3-2: New USB device found, idVendor=04e8, idProduct=6860
[10830.668294] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[10830.668296] usb 3-2: Product: SAMSUNG_Android
[10830.668298] usb 3-2: Manufacturer: SAMSUNG
[10830.668300] usb 3-2: SerialNumber: 07fe8be3
[10830.675987] cdc_acm 3-2:1.1: This device cannot do calls on its own. It is not a modem.
[10830.676026] cdc_acm 3-2:1.1: ttyACM0: USB ACM device
[10830.676219] usbcore: registered new interface driver cdc_acm
[10830.676220] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

Phone is a samsung S4 Mini Duos GT-I9192, running android 4.2.2

TIA
Sim

Official bug is here - Bug #1263355 “Unable to directly access files of any smartphone ...” : Bugs : libmtp package : Ubuntu
Unfixed at present :frowning:

Thanks for the reply… have edited the original post for greater accuracy.

I am going to try running P6 from USB on another machine… and report back.

Yeah, if it works, can you check which kernel the LiveUSB has

uname -a

Well, I tried this again, and initially got the same error as installed P6 :-[ :cry: - so I unplugged the phone, and plugged it in again… and it worked :slight_smile: - I took a screen shot to prove it too!!! ( which I have attached - sorry. Mark, feel free to do whatever you want with this file - I don’t think there is anything contentious on display !?!)

as you can see… P6 recognised all the files on the 32Gb card in the phone, and was also able to copy them to a partition in the PC. :slight_smile:

I also ran the command requested, and inxi too, in an attempt to put this in some sort of context…

peppermint@peppermint ~ $ uname -a
Linux peppermint 3.16.0-46-generic #62~14.04.1-Ubuntu SMP Tue Aug 11 16:27:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
peppermint@peppermint ~ $ inxi
CPU~Quad core Intel Core i7-4790 CPU (-HT-MCP-) clocked at Min:800.015Mhz Max:4101.750Mhz Kernel~3.16.0-46-generic x86_64 Up~17 min Mem~403.7/11904.1MB HDD~2123.4GB(1.2% used) Procs~197 Client~Shell inxi~1.9.17
peppermint@peppermint ~ $

Hope all that helps - I will leave the machine up for a while if you want anything other info ( although its hardly a chore to boot it from USB !) :slight_smile:

(click image to enlarge)

https://i.imgur.com/nkGZhsT.jpg

Reading some stuff online seems to suggest Samsung phones sometimes work, replugging them sometimes makes it connect sometimes it doesn’t … so I guess replugging it was what did it.

Have you tried that on the installed version ?


In future can you please host images on somewhere like:
http://imgur.com
and link to them rather than adding them as attachment … thanks in advance :slight_smile:

I’ve done the one above for you, so you can select “Modify” and see the format for posting an image hosted on imgur.com :slight_smile:

Oh yeah, I have… repeatedly ::slight_smile: - it ignores me, every time :o seem a big strange that replugging it worked - even tried different leads, but that didn’t work either - on the other machine, any lead works - I tried them all (four).

In the meantime, I’m going to borrow a card reader off a mate and see if that works - our current one can’t cope with large micro SD… if his works, i will just buy one!

I’ll have a look at imgur - i just thought it might help getting the image up… thanks for moving it though :slight_smile:

Have you tried booting the 3.16.0-46-generic kernel in the installed version ?