Installed ubuntu-restricted-extras, but still cannot play anything (mp3s, etc)

Running Ubuntu Netbook Remix 9.04 “Jauty”. (Impossible to upgrade, please do not mention)

This device has never let me play or listen to any format, mp4, mp3, WAVs, OGGs, YouTube, etc

Recently tried installing ubuntu-restricted-extras to resolve this, but it has not worked. Uninstalled and reinstalled the OS plenty of times before and it has never fixed it.

Clueless as to what could be the issue. Would just like to listen to some tunes. Have asked this on several forums and nobody has helped ): Thanks

When you say “impossible to upgrade”, do you mean the OS or the computer? Please clarify.

The OS. This is a custom version of Linux that has been made for this specific device and no other Linux works correctly.

That version of Ubuntu was based, I believe, on Debian Lenny. The repository for that is still available and may contain the codecs you need in versions that will work qith your program versions:

You need ffmpeg and the gstreamer good, bad and ugly plugins.

Hi there, your answered seemed very promising but sadly the Debian archive side says it has been disabled

Well I find that rather puzzling … Please post Make, Model and system specs - using the code below - of your computer so we have a clear idea of what you have. :wink:

sudo lshw

sudo ls hw will produce an awful lot of text! Best options are:

sudo lshw > lshw.txt

and attach the file lshw.txt to your post, or

inxi -Fx

although you will have to install inxi by

sudo apt install inxi

…which produces very much less output that you can copy/paste and is still very informative.



Hope it helps!

That’s a very modest computer, but there’s nothing weird about it: Intel 32-bit Atom processor and support chips with American Megatrends BIOS. The challenge is the 512MB memory, but that’s not a complete show-stopper: AntiX Linux will run on half of that. It’s worth getting that and trying it.

You sadly happen to be gravely wrong.

I have tried tens of Linux distributions. Most do not boot at all. The ones which do boot, the touchscreen (Only method of controlling the device aside from the keyboard) works incorrectly, and usually the WiFi does not work. Sometimes even the sound does not work. See: (Same issue here, but changed to a discussion about touchscreen)

Only about Puppy since it is the only distribution I have tried where everything has worked EXCEPT the touchscreen.

But at his point I have figured it is not worth trying to get other distributions to work considering the currently installed Linux is working great with zero issues aside from the inability to play anything.

Ah, the touch screen is the one thing I never knew about — I should have searched the make and model on the web. Looking at the responses to your posts on other sites, I think this is a lost cause. More memory would make a modern distro possible, but where would you find it? A mouse might make it possible to use a distro with no touch-screen support, if it worked, but that would rather cancel the convenience of the physical format of the tablet. Old hardware eventually reaches the end of its life — my laptop is facing the same fate, unfortunately.

There are no issues with the performance of the device with the currently installed OS, Ubuntu Netbook Remix 9.04. Web browsing is quick enough with Seamonkey 2.26 - even the YouTube site loads with completely tolerable time. Could sit and use it all day happily, if not for the problem no formats play. (Also an adblocker would be nice)

I refuse to give into this silly issue. It is fixable.