Installing Gimp 2.8 on Linux MInt 13 Maya

Trying to install The Gimp 2.8 on Linux Mint 13 Maya. Can’t find it in Software centre and have looked at previous posts on the new release, can’t seem to be able to get it running. Any ideas?

If Mint 13 is based on Ubuntu 12.04 … there should be no problem using this PPA:

(read the warning there first)
It seems that PPA causes problems on earlier Mint/Ubuntu releases though, so I’ll put these links to the Mint forum here for reference … just in case:

http://linuxforums.org.uk/MGalleryItem.php?id=1540

and this one … but you’ll have to chase it :wink:

http://linuxforums.org.uk/MGalleryItem.php?id=1540
← CHASE ME

If you’ve already tried to install it, and it’s broken, let us know HOW you tried to install it … and if possible what went wrong (ie. any error messages).


Install whatever version of the GIMP is available in your package manager (to resolve any dependencies).

THEN run:

sudo apt-get install ppa-purge

(ppa-purge may already be installed, but I’ve included it anyway just in case)
then

sudo add-apt-repository ppa:otto-kesselgulasch/gimp

then

sudo apt-get update

then

sudo apt-get upgrade

Thanks Mark

I will give it try when I get back home. :slight_smile:

Used the code you posted Mark but Gimp still comes up as version 2.6.

When I get the chance … I’ll try it in a VM … meanwhile, if you find a solution, can you post it please.

OK

This works on my Mint 13 install.

YOU MUST REMOVE ANY GIMP INSTALLATIONS FIRST!

    sudo add-apt-repository ppa:otto-kesselgulasch/gimp
    sudo apt-get update
    sudo apt-get install gimp
    sudo apt-get install gimp-plugin-registry

Then

    sudo apt-get install gimp-resynthesizer

There are no gaurantees this will work on your system, it works on mine. :slight_smile:

Thanks for that Toonman … and sorry for not getting back to you, I had meant to mark this topic “Unread” so I’d keep coming back to it … but forgot … sorry :-[

No problem. Sometimes it does me good to do some scratching around, I become a bit lazy. Not true, I’m rushed off my feet! So, this site helps me a lot. :slight_smile:

It says on the program website that only source code is available for version 2.8 is there a reason to rush to get 2.8 when 2.6 is a stable release backed by the O>S> provider.

Is it that much better?

There’s a list of the new features here:

Most people just want to try the new much vaunted (but IMHO fairly pointless) “single window mode” … personally I don’t like it … but it’s optional in 2.8, you can have the old separate tool boxes if you want.

In answer to your question … unless you NEED/want any of the new features, stick with what’s in your software repositories.

A big thank you for your clear instructions. Gimp 2.8 is up and running. :slight_smile:

Enjoy. :slight_smile:
Remember that if you want yo save jpgs you will have to go to…

Export
export as jpg.

For anyone interested . Peppermint 3 has GIMP 2.8 in the default repositories :slight_smile:

So if you install the GIMP … 2.8 is what you get.

Not “totally” on topic, nor “totally” off topic … It’s about GIMP 2.8, and Peppermint has the word “mint” in it :wink:

And who knows … maybe Mayans liked peppermints.