Installing Teamviewer [SOLVED]

I have built a 64-bit Athlon PC (2GB) for a friend and installed Ubuntu 14.04.
Most things are working fine, but as my friend lives far away, I need to install Teamviewer 9. Although the updates are current, Team viewer is not listed in Synaptic and when I attempted to download from the Teamviewer site I had an error: Dependency is not satisfied: lib32asound2

I searched for it in Synaptic without success. Any ideas anyone?

OK, you attempted to install the 64bit version which doesn’t work with 14.04, you need to use the “32bit / 64bit multiarch” version.

First just to be sure you didn’t half install Teamviewer 64bit, please run:

sudo apt-get remove --purge teamviewer*

if prompted hit the “Y” key, then the “Enter” key to continue.

now carry on with the install instructions below.


The following instructions are for 64bit Ubuntu 14.04/Mint 17/Peppermint 5

Open a terminal and run these commands in sequence:

sudo dpkg --add-architecture i386

then

sudo apt-get update

then

mkdir ~/teamviewer-installer

then

cd ~/teamviewer-installer

then

wget http://download.teamviewer.com/download/teamviewer_linux.deb

then

sudo dpkg -i teamviewer_linux.deb

You will get errors from that command, ignore them and run:

sudo apt-get install -f

which should correct the missing dependencies.

Teamviewer 9 should now be installed and available in the menu at:-

menu > Internet > Teamviewer 9

I hit an error at the penultimate step:

[i]jenny@dt2:~/teamviewer-installer$ sudo dpkg -i teamviewer_linux.deb
Selecting previously unselected package teamviewer9.
(Reading database … 231255 files and directories currently installed.)
Preparing to unpack teamviewer_linux.deb …
Unpacking teamviewer9 (9.0.32150) …
dpkg: dependency problems prevent configuration of teamviewer9:
teamviewer9 depends on libc6 (>= 2.4).
teamviewer9 depends on libgcc1.
teamviewer9 depends on libasound2.
teamviewer9 depends on libfreetype6.
teamviewer9 depends on zlib1g.
teamviewer9 depends on libsm6.
teamviewer9 depends on libxdamage1.
teamviewer9 depends on libxext6.
teamviewer9 depends on libxfixes3.
teamviewer9 depends on libxrandr2.
teamviewer9 depends on libxrender1.
teamviewer9 depends on libxtst6.

dpkg: error processing package teamviewer9 (–install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
teamviewer9
jenny@dt2:~/teamviewer-installer$
[/i]

Keep reading above … it explains you will get errors, and what to do next

Sorry not to have read further than the failed command - my mother used to complain bitterly about things like that!
Anyway, it worked perfectly - many thanks, as usual.

Can you explain what “multiarch version” means and why it’s necessary?

multiarch = multiple architecture.

https://wiki.debian.org/Multiarch


In this case it’s necessary because Teamviewer haven’t packaged the 64bit version with Ubuntu dependencies in mind :wink:

I followed several paths via your link. Whilst I can’t say that I fully (or even a little bit) understand it I think I get the gist of it as being a long-term project to get parts 32-bit and 64-bit architectures (like libraries) to work together. Binaries are a future problem, apparently.

If anyone has yet to get the message about how hard people are working on Linux, they need only follow the links via the URL in your post.

[EDIT] just got your edit which is helpful.

Are there any native 64 bit equivalents that don’t require multiarch? Something like a GUI version of SSH (VNC?)

Why ?
(not that are as easy to setup/use as Teamviewer and also support Android/iOS/Windows/OS X … there’s ZERO setting up of teamviewer, just install, run, tell the other person the ID and generated key)

Multiarch is already part of Peppermint 5 64bit ?

I could probably solve the native 64bit version of Teamviewers dependencies … but why bother ?

Just out of interest really - multiarch always seems like a “make do” solution. It shouldn’t be up to the end-user, the developer upstream should sort it out.

Didn’t realise that TeamViewer was a de facto standard, only remote viewing software I’ve used is OpenVNC (a few years ago) and GoToAssist (shudder)