Instant messaging and video [Solved?]

I’ve been asked by one of my elderly Linux friends (94!) to look into Skype (or equivalent) for him. As I understand it, Skype no longer supports Linux since being taken over by Microsoft, but there are several alternatives.

Not knowing anything about direct communication between computer users, I’ve struggled to make sense of the wealth of information on the internet but I think it works as follows and would be grateful for correction.

There are two essential bits of software:

  1. The first resides on a server and acts as a gateway or hub for communication between two (or more) parties. One registers with this provider and is allocated a universal username/address. XMPP appears to be the favoured protocol and Jabber a well respected, free service based upon it. (https://www.jabber.org/)
  2. The second resides on the user’s computer, provides a graphical interface (usually) and deals with all the transmission protocol business. My Ubuntu 16 machine has Empathy installed by default.

Now we come to the difficult bit. I attempted to register with Jabber but Firefox declined to visit the site, claiming that the connection was not secure:
register.jabber.org uses an invalid security certificate
Error code: SEC_ERROR_EXPIRED_CERTIFICATE
expired: 17/12/13”

I was invited to “Add an exception” but thought it wise to ask advice first. Of course I don’t have to use Jabber, but many people recommend it.

I would welcome the forum’s advice.


I am using a Lenovo Thinkpad T500

As long as it’s a 64bit Ubuntu based distro you could try the new “Skype for Linux” alpha
https://www.skype.com/en/download-skype/skype-for-linux/downloading-web/?type=weblinux-deb

Looks interesting, Mark, although there is a warning on the download page that some components may not be free.
I shall install and play with it before reporting back.

Keith

I guess it depends what you mean by “free”

as in “freedom” to modify … most definitely NOT.

or as in “no money” … yep (AFAIK) it’s free.

Yeah give it a shot … it’s easy to uninstall.

More info
https://community.skype.com/t5/Linux/Skype-for-Linux-Alpha-and-calling-on-Chrome-amp-Chromebooks/td-p/4434299

.

I downloaded Skype but baulked at the request for my 'phone number during the installation process and prefer to continue with Empathy unless I get nowhere with it. (Am I paranoid?)

Although I haven’t ruled out Skype, some more web-based perseverance yielded the information that jabber has a new home page - as of today! The registration page is jabber.at - Registration deactivated. And it works.

I registered without difficulty and entered my details in Empathy but hit a snag when a warning notice demanded my keyring password (which I haven’t set). Tried entering nothing (failed) and the enter key (failed), then my computer password (failed again). Clicking on ?done? didn’t satisfy Empathy. I tried deleting my account on the computer (and it told me my on-line jabber account would be safe) and reinstated it, but now when I start Empathy, the Contact List pane just shows a rotating “waiting” circle, forever (because no contacts are listed?). The “Add Contacts” is greyed out, as are many other options.

Although I have (somewhat impolitely) not used your Skype suggestion I would be grateful if you can advise me on this Empathy problem.

I don’t remember skypeforlinux asking for my phone number … just my Skype account login details (?)

Have you set some kind of 2 stage authentication on your skype account … so it’s asking for this for security ?


For empathy, (with empathy closed) try:

mv -v ~/.local/share/keyrings ~/.local/share/keyrings-old

then REBOOT

Once rebooted open empathy … when prompted for a NEW keyring password, leave it EMPTY and continue.

Skype
I haven’t installed Skype yet as I was put off by it asking for my 'phone #.
I understand now why you recommended installing Skype: it doesn’t use XMP protocol so Empathy/Jabber can’t communicate directly with Skype users. However, a web search reveals that one can use Empathy if Skype is running in the background and one installs the appropriate code. (API?)
I can see the usefulness of this but it’s a bit advanced for me at present so I shall install Skype via your link as a first step, then come back to the Forum later to get advice on running it behind Empathy.

Empathy
I sorted out my problems last night (mostly my own incompetence, so no change there, then) and found Seahorse as a way of getting into the keyring where I deleted all my attempts at trying passwords. It worked fine then, especially when not mistyping my PC’s password! Your trick is better as I always use auto-login, so I shall do that.

All I need now is to find someone who uses Skype or XMPP-based chat/video so I can get the hang of the technology before helping the chap who first asked me about it.
Thank you for your help, Mark. No doubt I shall be back later!

When did skype ask for your phone number ?

Before giving you the .deb ? … if so I can point you at the .deb if you wish ?

But it’s NOT asking for my phone number :-\

As far as I remember it asked at the start of the download process, but I can’t be sure exactly.
I shall try again later this evening and if it does it again I’ll go the direct .deb route.
.
.
back soon

If it helps, I’ve uploaded the .deb to my dropbox
https://dl.dropboxusercontent.com/u/31525164/skypeforlinux-64-alpha.deb
just download it, and double-click it to install

This might be worth a shout.

Although I have no idea if it`s any use.

This is the homepage

https://ring.cx/

Re your Reply #9
Thanks, Mark.
I had already downloaded it. The phone number request can be replaced with an email address which I hadn’t noticed before, so I completed the installation.
After entering a password, Mr. Microsoft asked:
“Now just a little more information: what’s your name?” (hackles rose)
Not realising this would be used as my on-line name, I lied as I usually do and I was signed up. It is very easy to do and might satisfy my friend’s needs, although it’s not obvious whether one can use video with this free Skype and I guess not, which might not appeal to my elderly friend.

As for myself; I really don’t feel comfortable with the overtly commercial feel of it and shall continue with Empathy (if I hadn’t screwed up jabber - again).
Just out of interest I looked for a way of unsubscribing from Skype and it appears that it’s not possible. Even the Microsoft help site tells me that my information is there for ever - although the article refers specifically to the paid-for version. Another nail in its coffin.

When I visit my mate I shall install it and see if we can communicate.

Many thanks for all your help, as usual. No doubt I shall be asking for assistance with other, similar services.
Keith

Your reply #10
I shall check that now

Very many thanks for the Ring link! It appears to be ideal for my needs:

  • Free
  • secure
  • private
  • voice, video, text,files
  • Linux, Windows, Mac, Android
  • very flexible
  • etc

The demo video is rather poor, unfortunately, but worth watching. See also: Take control of your communication with Ring! — GNU MediaGoblin

When I have installed it on two machines and tested it I shall report back.
Perhaps another of our readers would like to try it out, too.

Thanks again, Mark.

The Ring install appeared to go well - until the end when the following informative message displayed:

[i]Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
ring-gnome : Depends: ring but it is not going to be installed
E: Unable to correct problems, you have held broken packages.[/i]

I guess I shall just have to wait for greater stability.

The correct installation instructions can be found at: https://ring.cx/en/download/gnu-linux

The installation was very quick and successful. Perhaps someone else would like to try it with me.
My RingID is: af2511719a012579cc81888fe72efe554ba64679