Internet connection problems

Hello again

After using IE on my windross partition earlier, I can now no longer connect to the wireless router on Ubuntu.

A WEP key is requested (it’s normally automatic), I have copied the WEP key from the Netgear info page but it won’t recognise it.

Any ideas?

Related: How do I find the mac address of my laptop?

Cheers

For the MAC address of your wireless adapter, open a terminal and enter

ifconfig

and hit enter

now look for the wlan0 section (or similar)… your MAC address will be listed as:

HWaddr 00:18:e7:d0:c2:51

or similar.

as for the WEP key

a) I can’t see how using Windows would change that… have you tried turning the router off and on again, and rebooting the PC ?

b) is the WEP key on a sticker on your router somewhere ?

If not, you’re going to have to connect to the router with a cable, then enter the routers IP in a web browser to access its interface, and manually check what the WEP key is set to.

Thanks

I already did ifconfig, but didn’t know which numbers I was looking for. Your answer answered that one.

a) Me neither… I just blame anything that goes wrong on windows :smiley: Does seem a strange coincidence though.

b) Netgear gives an http address for info on settings. I accessed the WEP key from there.

I’ll check the router has my mac address now.

Are you sure Ubuntu is asking for the WEP key, and not the keyring password ?

Fairly. The keyring is the password for login and download authentication etc, right?

The dialogue box asks for a 40/128 WEP key… the ‘connect’ option is only available on specific character string lengths. My password isn’t of the right length.

I’ve just added the mac address to the router list and still no joy.

The HWaddr numbers listed were for etho0 and etho… rather than wlan. Is that okay?

Are you sure you’re using WEP and not WPA/WPA2 ?

Errr… no, not sure. I’ll check.

btw. My wife has come home and connected to the router with no problems and the kids have just finished watching DR Who on the iplayer… the problem is twix my machine and the router.

If you’re sure you’re using WEP… try firing up NetworkManager, and deleting your wireless profile… and manually setting it up again.

If you don’t know how to start NetworkManager, open a terminal, and enter:

nm-connection-editor

[EDIT]

Can you post the output from

ifcomfig

and

iwlist wlan0 scanning

I take it it can see the network, it just won’t accept the WEP key ?

I’m pretty sure it’s WEP… that’s what it says, and I can see mention of the others.

Yep, had the NetworkManager open already. I’ll try deleting and setting up again.

If that doesn’t work… see the EDIT above.

BTW, when setting up the connection again… if it asks for a keyring password, leave it blank… it will complain, but leave it blank any way and accept it.

How many characters are in your WEP key ?

Okay…
I’ve just disabled the security at the router, but still this same dialogue appears:

ifconfig produces this:

Sorry not very clear.

and iwlist wlan0 scanning produces:

wlan0 Interface doesn’t support scanning

OK, I guess you wireless adapter is eth1

try -

iwlist eth1 scanning

or

iwlist eth0 scanning

anything returned ?

Yes:

neil@ubuntu:~$ iwlist eth1 scanning
eth1 Scan completed :
Cell 01 - Address: C0:3F:0E:FD:91:DC
ESSID:“virginmedia2247842”
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=33/100 Signal level=-80 dBm
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : CCMP
Pairwise Ciphers (1) : CCMP
Authentication Suites (1) : PSK
Extra: Last beacon: 716ms ago
Cell 02 - Address: 00:0F:B5:BD:23:82
ESSID:“home”
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.417 GHz (Channel 2)
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 22 Mb/s; 24 Mb/s
36 Mb/s; 48 Mb/s; 54 Mb/s
Quality=96/100 Signal level=-27 dBm
Extra: Last beacon: 180ms ago
Cell 03 - Address: 1C:BD:B9:2E:3E:FA
ESSID:“SKY38102”
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 11 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=23/100 Signal level=-85 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Extra: Last beacon: 2380ms ago
Cell 04 - Address: 12:FE:F4:32:4E:98
ESSID:“BTFON”
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=27/100 Signal level=-83 dBm
Extra: Last beacon: 4900ms ago
Cell 05 - Address: 00:FE:F4:32:4E:98
ESSID:“BTHub3-28HJ”
Protocol:IEEE 802.11bg
Mode:Master
Frequency:2.412 GHz (Channel 1)
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Quality=25/100 Signal level=-84 dBm
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Extra: Last beacon: 2392ms ago

And:

neil@ubuntu:~$ iwlist eth0 scanning
eth0 Interface doesn’t support scanning.

OK the adapter/driver is obviously working… can you tell me how may characters are in your WEP key, and how many the dialog will accept.

[EDIT]

and are all the characters of your WEP key 0-9 and A-F

and is the WEP key secuyrity setting in NetworkManager set to WEP (HEX) or WEP (Passphrase)

Well bugger me!

I just tried to connect via wireless, to prompt the dialogue box, and it connected as normal. ???

There’s clearly something not right, but it’s getting late. I’ll reboot tomorrow and enable the security to see what happens and let you know.

Mark, you are a star. 8)

If you have any problems tomorrow… gimme a shout and we’ll see what we can do :slight_smile:

Will do.

My wife can’t connect now… but that’s not my problem ;D

Conflicting static IP’s maybe ?

or not enough IP addresses available in the routers DHCP pool ?

A sort of update:

Everything seems to be working fine now… but I have no idea what the problem was or how it was cured.

Thanks for the help.

As long as it’s working… that’s what really matters :slight_smile: