Intternet connection problems

Hi I am very new to Linux and I would class myself as a user and not someone who likes messing around with code etc.
My problem is that my other laptop a Dell Inspiron 2200 running Win.Xp that my wife uses to do her shopping but complains
that the boot up time is to long, and when I read an article about how good Linux mint was I got a CD from the Linux shop and
got started. After a few attempts to get it loaded it looked great but no internet connection and to my horror it would not turn off!
I cleaned that off and tried Ubuntu,the installation was easy but yet again it does not see my Netgear wireless router and no internet.
Is there any of the linux packages that work from the box or will they all have the same problems, I never have any problems with
windows can someone help

If I’m right the Dell Inspirom 2200 uses the Broadcom 4318 wireless chipset…

Connect your Inspiron to the router with an ethernet cable, so you have an active internet connection.

Open a terminal Applications>Accessories>Terminal

In the terminal enter:

sudo apt-get install b43-fwcutter

and hit enter, then your password when asked.

When it’s finished (installing the firmware) and you’re back at an $ prompt… go to System>Administration>Additional Drivers, and activate the b43 driver.

Info - Depending on the Ubuntu version, “Additional Drivers” may be called “Hardware Drivers”.

You can check your wireless card IS a Broadcom BCM4318 by entering this command in a terminal:

sudo lshw -C network

and hitting enter and your password.
(remember - Linux commands ARE case sensitive)

If you have to post back, can you tell us which version of Ubuntu you are using… you can find this out be running:

cat /etc/*-release

in a terminal

output should be similar to this:


Thank you for your help, I connected my laptop via a cable to my router and bingo! up came the internet I visited a few sites and bookmarked them
then I was informed that loads of updates were waiting so I let it update, then I put in the codes to get and install the drivers which went fine then I had
a senior moment when with the cable disconnected it looked as if the wireless system was working having forgotten that firefox remember last visited web pages
but a quick click on the wireless icon showed the network and after entering my security code it was all systems go. I did try and enter the other codes for software
version etc but they were rejected, command not known, but its not a problem now.
I do have some irritations with the setup, every time I click on Firefox its gone off line and I have to click on the wireless icon to reactivate it can change this, and every time
I go online or some other action the screen brightness is turned down and I have to turn it back, and last but not least when running Ubuntu the mouse movements are very

Mouse is easy… go to: System>Preferences>Mouse and change the “Sensitivity” and “Acceleration” settings till it behaves the way you want.

Wireless… right-click the “wireless icon” by the clock, and select Edit Connections, then click the Wireless tab… highlight your connection, and select Edit, now make sure there is a tick in “Available for all users” and “Connect Automatically”… click Apply.

As for screen brightness, that sounds like odd behaviour, but I’m guessing it has something to do with either the screensaver, or power management.
You can change the setting for both by going to: System>Preferences>Screensaver, where you will also find a button for the power management.

Thanks again for your help, internet connection sorted, mouse speed now OK, the screen brightness better and a few more adjustments and we should be ok