Is kernel upgrade possible ? (Solved again)

Hi Mark,
I am having problems ( again ) with my internet connection.
Would it be possible to upgrade to the 3.16 kernel series ?
I am running Peppermint 5

take care
Don W

Yes, open a terminal and run:

sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic

when that’s finished, REBOOT.

Then post the output from:

uname -a

Hi Mark,
Is this ok,
don@ldwatson ~ $ uname -a
Linux ldwatson 3.16.0-34-generic #47~14.04.1-Ubuntu SMP Fri Apr 10 17:49:16 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

take care
Don W

Yup, let’s hope that helps with your wireless problem :slight_smile:

Won’t he have to recompile the drivers against the new kernel headers? Or have I misunderstood how that fits together (again)?

Did donwatson compile any drivers in the first place ? … I thought he was just using the ones provided by the kernel, in which case they’ll now be provided by the 3.16 kernel

This is the third time I have posted this, hope it works this time.
Everything is looking ok at the moment but I will leave it until Monday before marking solved.
One point I have to ask is, at the moment I switch the computer on and off about 6 times a day, would I be better to switch on in the morning and off at night ?
Or indeed can I leave the computer permanently on ?
Your thoughts please.

take care
Don W

@Mark - I can’t remember, there’s so many posts about wireless adaptors, most seem to end up compiliing drivers! Considering the issues Don has had, I guessed it might have been suggested at some point. Anyway, seems like he didn’t from his follow up post :slight_smile:

@Don - There’s nothing wrong with leaving it on apart from the waste of power. You can always set it to suspend instead of turning it out - it’ll still be on, but in a very-low power “sleep” state. If suspend doesn’t work (can be flaky), I’d do the morning-night suggestion

Thanks chemicalfan

This is a tough one to answer, different people have different opinions, it also depends on your priorities … certainly continued power cycling of electronics can cause them to fail sooner (keep heating/cooling something is akin to bending a piece of metal backwards and forwards) … but components with moving parts such as hard drives MAY last longer the less wear they get.

Personally I go with the always on option for desktops (except where noise may be a consideration such as in the living room) and my NAS … laptops on in the morning/off at night.

As I said other people will likely have differing opinions about the “always on”, but I think most people would say if you switch your PC on /off 6 times a day, you’d probably be better off just powering on in the morning, and off at night (unless of course power usage is the main consideration, say on a laptop that’s on battery)

Thanks for the advice chaps :slight_smile:
I removed the battery at the beginning of the week as I only use the laptop at home.
If I sit in the garden I can use the power from the shed, it just means switching off before going outside, or refitting the battery.
@chemicalfan, I will go with the on in the morning and off at night option.
@ Mark, I remember reading somewhere about the chips becoming loose due to to heating/cooling, it was a long time ago.
I think that was what prompted the lock on the socket ? I dunno :smiley:
I will wait until Monday before marking this solved, when I will have another problem to set you ???

take care
Don W

Hi Mark,
The internet connection has dropped out again. :cry:
I checked emails etc this morning and all was ok.
I left the computer running while I did some work, after tea I woke the computer up and signed in, and, lo and behold no internet connection.
What’s next Mark ?

take care
Don W

So this is purely a resume from suspend issue ?

it’s no longer dropping out prior to suspending ?

next time it suspends and doesn’t reconnect after resume … whilst it’s NOT connecting, please run:

nmcli nm status

copy the output to a text file.

Reboot so you can connect

post the output back here

Thanks Mark,
When I finished my tea I came back to the computer, moved the mouse and signed in.
I saw that it hadn’t connected and the icon whizzed around a few times but it is still disconnected.
I will go back to the Linux machine and carry out the above request.

take care
Don W
I have ran the command, saved it and shutdown the computer.
I re started computer and I am connected to internet.
This is what I got from the command

don@ldwatson ~ $ nmcli nm status
running disconnected enabled enabled enabled enabled
don@ldwatson ~ $
Hope this helps

If your connection is called “VM185937-2G”, and the wireless device is “wlan0” does it reconnect it you run:

nmcli -p con up id "VM185937-2G" iface wlan0


Hi Mark,
My connection is “VM185937-2G”.
I don’t know the device, can I check it somewhere ?
I will need to wait until the problem strikes again to try that command.
The computer started ok this morning, I logged in and there was an Internet connection.
I have a bit of work to do today so I will let the computer go to sleep until I get back.



you’ll see output similar to

mark@AA1-Blue ~ $ ifconfig eth0 Link encap:Ethernet HWaddr 00:1e:68:d5:92:04 UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:5025 errors:0 dropped:0 overruns:0 frame:0
TX packets:5025 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:522153 (522.1 KB) TX bytes:522153 (522.1 KB)

wlan0 Link encap:Ethernet HWaddr 00:23:4d:3d:36:01
inet addr: Bcast: Mask:
inet6 addr: fe80::223:4dff:fe3d:3601/64 Scope:Link
inet6 addr: fdb8:fa2f:97c0:0:223:4dff:fe3d:3601/64 Scope:Global
inet6 addr: fdb8:fa2f:97c0:0:71ae:97f8:4302:a914/64 Scope:Global
RX packets:170844 errors:0 dropped:0 overruns:0 frame:0
TX packets:120926 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:173407397 (173.4 MB) TX bytes:23624556 (23.6 MB)

Or you could run:

nmcli dev status

which will list the devices and their current status

nmcli dev status DEVICE TYPE STATE [b]wlan0[/b] 802-11-wireless connected eth0 802-3-ethernet unavailable

I have switched on and there is no connection.
I ran the nmcli -p con up id “VM185937-2G” iface wlan0 command and it says
connecting (configuring) and then it says
disconnected then it says
Error: Timeout 90 sec. expired and puts me back to the prompt.

I ran ifconfig and it says wlan0
I also ran nmcli dev status and it returns
eth0 802-3-ethernet unavailable
wlan0 802-11-wireless disconnected

Last night I was on t’internet playing Backgammon and twice the programme hung and said I had lost the server.
Over the past couple of weeks I have had this problem a few times and wonder if it is connected.
The little signal level thingy was sitting was showing it still had a signal so I never bothered.

I have shutdown the computer before having a shower and now I’m back and logged in and everything is working fine.
When the internet connection came on it showed 100%, this has now dropped to 52% ?

We’re quickly approaching the point where I say “get a USB wireless adapter”.

Have we tried disabling IPv6 and giving your wireless connection a static IP ?

Have you got a USB wireless adapter you could test it with … just to be sure it is actually the wireless card ?