Is there anything better than VirtualBox?

I’d love to know if there is anything else, native for Linux virtualization wise? I’ve tried to install XP twice through virtualbox and twice my laptop suddenly blanked out, and I had to switch it off at the mains, which I hate doing. I’m not going to try a third time, because being generically scottish, I’ll lose the head. Pretty ironic that XP won’t install lol.

P.S. Second time, installed but it then blanked whilst downloading the pack for using the USB ports etc, and then corrupted the install. Bleh.

KVM if your CPU supports hardware virtualization.

VMware Player if it doesn’t.

Is KVM in the repos?

Jeez… it would have taken less effort to open synaptic and type “kvm” into quicksearch, than to come here and type that question :stuck_out_tongue:

But don’t expect KVM to have it’s own GUI front end… you’ve got some reading to do again.

Right after I posted that, I went to synaptic. Lol. Then I realised… It has no GUI. :frowning: So reading it is… this will be interesting… :3

EDIT: My mind just exploded. Mind helping me with this please? >.<

Right, just to make sure I’m on track here, this is what I’ve done so far. I’ve ran the command:

sudo apt-get install gcc libsdl1.2-dev zlib1g-dev libasound2-dev linux-kernel-headers pkg-config libgnutls-dev libpci-dev

and

tar xzf qemu-kvm-release.tar.gz
cd qemu-kvm-release
./configure --prefix=/usr/local/kvm
make
sudo make install
sudo /sbin/modprobe kvm-intel
# or: sudo /sbin/modprobe kvm-amd

However, when I ran the second command I got a bunch of errors from terminal.

bally@bally-laptop:~$ tar xzf qemu-kvm-release.tar.gz tar (child): qemu-kvm-release.tar.gz: Cannot open: No such file or directory tar (child): Error is not recoverable: exiting now tar: Child returned status 2 tar: Error is not recoverable: exiting now bally@bally-laptop:~$ cd qemu-kvm-release bash: cd: qemu-kvm-release: No such file or directory bally@bally-laptop:~$ ./configure --prefix=/usr/local/kvm bash: ./configure: No such file or directory bally@bally-laptop:~$ make make: *** No targets specified and no makefile found. Stop. bally@bally-laptop:~$ sudo make install make: *** No rule to make target `install'. Stop. bally@bally-laptop:~$ sudo /sbin/modprobe kvm-intel FATAL: Error inserting kvm_intel (/lib/modules/2.6.38.8/kernel/arch/x86/kvm/kvm-intel.ko): Operation not supported bally@bally-laptop:~$ # or: sudo /sbin/modprobe kvm-amd bally@bally-laptop:~$ tar xzf qwmu-kvm-.tar.gz tar (child): qwmu-kvm-.tar.gz: Cannot open: No such file or directory tar (child): Error is not recoverable: exiting now tar: Child returned status 2 tar: Error is not recoverable: exiting now

… still have no idea what I’m ment to do. Just using instructions from the KVM - How to page.

http://www.linux-kvm.org/page/HOWTO1

I’ve always found it best to check if there is any “Ubuntu” specific documentation on any subject before compiling from source… read this for KVM installation instructions for Ubuntu:
https://help.ubuntu.com/community/KVM/Installation

Be sure to check your CPU can handle hardware virtualizatio.n

and install virt-manager (in the repos) to help build/manage guest VM’s

More info on virt-manager here (but install it from the repos):
http://virt-manager.org/index.html
including screenshots:
http://virt-manager.org/screenshots.html

I guess there’s no point trying to install this then. Just did the grep command and it returned “0” also ran the “kvm-ok” command.

bally@bally-laptop:~$ egrep -c '(vmx|svm)' /proc/cpuinfo 0

bally@bally-laptop:~$ kvm-ok
INFO: Your CPU does not support KVM extensions
INFO: /dev/kvm does not exist
HINT: sudo modprobe kvm_
INFO: For more detailed results, you should run this as root
HINT: sudo /usr/sbin/kvm-ok

Thanks anyway. Kinda weird how I had Win7 running in VirtualBox before I upgraded to 64-bit :confused:

Nope.

But I’ve had Win7 running in Virtaulbox on Ubuntu 64bit… so it’s not a 64bit issue.

I’m gonna guess it was the way you installed the “guest additions” … it took me a while to work that out :o

Also, how did you install Virtualbox and which edition ? (I don’t mean which version, I mean the OS edition or what).

Well like most stuff I install, I got it from the repos.

It was OS version: OSE 4.0.4

I also installed the guest additions through Virtualbox. I have read that I should download Virtualbox from the Oracle site because it comes with the guest additions installed, but I wasn’t willing risk it just incase.

Uninstall the OSE edition from the repos… it doesn’t support USB pass through.

Now download the .deb from here:
https://www.virtualbox.org/wiki/Linux_Downloads
or direct downloiad link to Virtualbox 4.1.4 for Ubuntu 11.04 64bit:
http://download.virtualbox.org/virtualbox/4.1.4/virtualbox-4.1_4.1.4-74291~Ubuntu~natty_amd64.deb

Double-click to install…

Once installed, add yourself to the vboxusers group.

Now build your Win7 and/or XP VM('s)

When you’ve done that… come back here, and ask how to install the “Guest Additions”.

How does one add oneself to the vboxusers? I read the help guide about adding some kind of USB number from “/etc/groups” or something similar.

I don’t know what you’ve been reading, but stop reading it NOW :wink:

You MUST install Virtualbox first, or the vboxusers group won’t exist.

Once virtualbox is installed…

Applications lens > Users and Groups

Click Manage Groups

Scroll down to vboxusers

Highlight vboxusers, and select Properties

In the Group Members box, make sure your username is ticked.

Click OK

Now log off and on again.

Congratulations, you are now a member of the vboxusers group :wink:

FYI, you can check which groups you belong to with:-
groups
As in:

groups bally

If you want to add yourself to the vboxusers group from the command line (and your username is bally):

sudo usermod -aG vboxusers bally

then log off/on
then check you are in vboxusers with

groups bally

Right, all done. How do I add the guest additions?

OK, Guest additions for Windows (from what I remember) is dead easy…

install dkms

sudo apt-get install dkms

(not necessary but a good idea, specially if you’re ever going to install the extensions pack)

Start up your Windows guest VM… once it’s open, go to Devices > Install Guest Additions

See the top pic here:
http://www.howtogeek.com/howto/2845/install-guest-additions-to-windows-and-linux-vms-in-virtualbox/


Just in case you’re interested, you can get the Virtualbox 4.1.4 User Manual from here:

Ah sweet! Installed the guest additions and also installed the 4.1 extension pack to be able to use USB 2.0. Works a treat! I do have one problem however. Even though I run LFS through WINE, I wanted to do a comparison through Windows, but I just get the error: Could detect any suitable screen modes."

I’ve enabled 2D & 3D hardware acceleration, so do I have to install Direct 9 or something in Windows, or is this a problem with Virtualbox?

Haven’t got the foggiest… sorry ??? … Though I thinks it’s a Virtualbox issue with the way it passes the graphics through.

Which would also explain the lack of the Aero Interface.

I guess I’ll go install Direct 9.x and see if that fixes it. If not, I’ll boot up in safe boot and install the 3D addition from the guest additions. :smiley: I’ll report back if I figure out how to do it.

Some further research shows that the error is actually tied to Direct X and the graphics card not reporting the available screen modes. Now If my memory serves me correct, Virtualbox uses a virtual graphics card doesn’t it? Is there a way I could get it to report that it’s using my nVidia card?

Instead of editing my old post, I’ll just make a new one with updated info. I HAVE managed to found the solution to this problem, although with LFS you only get about half the frames you would if you where to run it in WINE. That said, you can get round this problem by booting up in safe mode in your Windows VM, by pressing F8 after the Virtualbox BIOS screen. select safe boot with networking and then continue until you reach your desktop. Once you’ve reached the desktop in the Virtualbox menu, goto Devices > Install Guest Additions once the installation wizard starts, tick 3D Experimental support. Reboot, and enjoy.