Issues with Pulse Audio and Skype (Resolved)

I’m beginning to think maybe the issue is Skype itself or the networking, and not the system Audio… does audio ever drop out when in any other application ?

How do you wish to proceed ?

ie. do you want me to look for a fix for audio in ALSA, or do you want to go back to Pulse and seee if we can fix the problem there ?

No, I doubt the desktop will make any difference… though it might be worth getting a USB stick and trying out some other distro’s as LiveUSB’s.

Hi, sometimes web radio drops out maybe once in an hour.

I just received a Skype call and audio was cutting in and out so maybe I should return to Pulse Audio and start again.

I could try the on-board sound card and take the pci card out of the computer to see if it is a sound card issue.

I will put the system back to where we started with Pulse Audio this will give me back sound in the game and see where we go from there.

It would certainly be worth checking if it is a sound card issue if only to rule it out, but as they are BOTH internet based applications, I think it more likely that it is networking based.

Can you try connecting your PC to the router with a cable, and see if audio still plays up ?

Are you running any kind of firewall or AV ?

I can not find any firewalls running on the system

I use Bit Defender virus scanner but it is only run when I ask it to scan something.

There could be an issue with connecting via a cable as I do not have enough IRQ resources to switch the network card on.

I have to work out what I can disable to switch the network card on.

That doesn’t sound right ??? … is the BIOS set to assign interrupts “Manually” or by a “Plug & Play OS” ? … Linux is Plug & Play BTW.

It may be an ACPI issue… try temporarily disabling ACPI in the BIOS, and see if that helps.

Also, look through the dmesg and kernel logs to see if anything jumps out as using a load of interrupts.

This will list interrupt assignments:

cat /proc/interrupts

What is the output ?

This may actually be the root cause of ALL your issues.

Here is the read out.

userone@office2:~$ cat /proc/interrupts
CPU0 CPU1
0: 2397 2308685 IO-APIC-edge timer
1: 0 2 IO-APIC-edge i8042
6: 0 3 IO-APIC-edge floppy
7: 1 0 IO-APIC-edge
8: 0 0 IO-APIC-edge rtc0
9: 0 0 IO-APIC-fasteoi acpi
12: 193148 405 IO-APIC-edge i8042
14: 2638 68229 IO-APIC-edge pata_amd
15: 16348 8960 IO-APIC-edge pata_amd
16: 1169671 650 IO-APIC-fasteoi nvidia
17: 0 0 IO-APIC-fasteoi ohci_hcd:usb6
18: 0 0 IO-APIC-fasteoi ohci_hcd:usb5
19: 714707 5107 IO-APIC-fasteoi ehci_hcd:usb2, CMI8738-MC6
20: 0 0 IO-APIC-fasteoi ohci_hcd:usb4
21: 1 1176 IO-APIC-fasteoi ohci_hcd:usb3
22: 0 2 IO-APIC-fasteoi ehci_hcd:usb1
NMI: 0 0 Non-maskable interrupts
LOC: 1135425 122432 Local timer interrupts
SPU: 0 0 Spurious interrupts
PMI: 0 0 Performance monitoring interrupts
IWI: 0 0 IRQ work interrupts
RES: 280338 475953 Rescheduling interrupts
CAL: 524 611 Function call interrupts
TLB: 1611 1930 TLB shootdowns
TRM: 0 0 Thermal event interrupts
THR: 0 0 Threshold APIC interrupts
MCE: 0 0 Machine check exceptions
MCP: 60 60 Machine check polls
ERR: 1
MIS: 0
userone@office2:~$

As far as I can remember BIOS is set to Plug & Play OS
All ACPI settings are disabled except for the resume from power loss (set to off)
Printer and RS ports are disabled.

Ok, Ubuntu desktop rule number 1;

  • don’t f**k with the sound system that comes with Ubuntu, it will make you cry!

Re; Interrupts, I could be totally wrong here, but unless you have either a very old or very odd computer, interrupts “shouldn’t” cause you a problem.
Back in the good 'ol days, Operating Systems liked to have one interrupt per device and sharing interrupts caused much grief.
Then much rain was forecast and Noah build a boat … :wink:

Ubuntu 11.04 + Skype 2.2.x works “out of the box” and the built-in sound system is flawless.

BUT (in capitals) unless I missed something , if you look at the “about” box you will find that version 2.2 is a BETA - so expect “issues” (!)

In this case, I’d be looking at the sound driver for your audio device as the first possibility.

  • are you using a Camera? a number of camera drivers are to say the lease “less than optimal” !!
    [strangely I’ve found that the M$ HD Widescreen Camera’s are the best , ~£25 for the cheaper one, £65 for the more expensive, excellent camera + MIC]

Things I’ve seen using SKYPE (daily);

a. It can “lose” the tool-try icon completely
b. It can get into a state where it accepts incoming calls, then effectively drops out and vanishes, while still leaving a ghost running
c. It can run a hung session, then let you start more sessions on top that can’t access video/sound because the session is hung
d. When talking to SKYPE users on other platforms, if they lean far enough away from their MIC, it can cut the sound off, i.e. there’s a “minimum”
e. There is a volume control for the MIC which can cause problems if set too low, see [d]
f. It can drop out for no apparent reason (even tho’ pings are still looking fine) then reappear after 10s or so …

You might want to consider the audio+visual option in “Google Chat”, this is actually much more reliable than SKYPE on Linux … [!]

  • but it might also be a good test to see if that option displays the same issues …

Hi, thanks for the input yes Skype worked after I adjusted the mic input.

I rebuilt the computer on a new motherboard with an AMD duel core CPU new RAM and Video. The OS was windows XP, my wife bought me a webcam for Christmas but it caused the USB wi-fi connection to drop out as it over loaded the USB system. I installed a new PCI usb card and at that time XP told me there were no resources for the new card.

I thus removed system components that were no longer required to free resources.

Yes Skype is BETA in Linux and as far as I know there is no Linux version that has not been BETA (I tried installing a windows version with WINE but that did not work).

Using another program is not possible SKYPE is established and used by many companies. It would be good if there was a program that allowed you to talk to people no matter what system they used.

My wife has just been using Skype on her windows lap top and she had no problems.

I will see if a wired connection makes a difference. I have been considering replacing the router for sometime it has been running 7/7 365 for 9 years now but seems to need resetting weekly in recent months.

I’d also try ditching the add-in CMI8738 sound card, and go with the onboard sound card, unless there’s a specific reason not to.

On a new modern mobo, I’d expect the onboard is probably better anyway, and you may find it “plays nicer” with the APIC interrupt handling than the add-in card too.

There’s something wrong there then :o … but as the CMI8738 is ALSO using the same interrupt as one of your USB 2.0 hubs, maybe all 3 were using the same resources, which may have been the cause of the wireless adapters drop outs.

BTW, re-arranging the cards (different PCI slots) may move them to different interrupts… just something else to try.

This surprises me a little (though probably nothing to worry about) -

7: 1 0 IO-APIC-edge

If you’ve disabled the onboard parallel port, I’d have expected this line to have disappeared… you could try selecting “Reset configuration data” (or similar) in the BIOS and see if it is then freed.

“Reset Configuration Data” (sometimes listed as “Force ESCD Update”) just tells the BIOS to ditch the “stored” settings and rebuild them… it will switch itself off automatically after the settings are rebuilt and stored.

BTW, have you tried downloading the “Static” version of Skype:
http://www.skype.com/intl/en-us/get-skype/on-your-computer/linux/downloading.static
Unpacking it, and running it directly from the unpacked directory, by just clicking on the skype executable ?

Hi, I have maybe nailed this down to the wi-fi side of the router, I ran a temp wired link from the router and made ten calls to the Skype testing service with no problems.

If it keeps needing a reset, I agree, it could probably do with replacing then :wink:

Though it’s still possible it’s a wireless driver issue, I doubt it if it’s only Skype that keeps failing… odd that it works in Windows though.

Have you got a spare wireless adapter you could try ? … preferably a different model/chip.

Here’s a thought… are you close to any other wireless networks such as neighbours ? … try setting a different channel in the wireless section of your router… most routers default to channel 6 or 11, try selecting channel 1 or 2 and see if that helps.

You could also try setting the router to “wireless g only” or similar, and see if that helps.

Though on a desktop you should really be using a cabled connection anyway :wink:

I’d test it thoroughly with a wired connection, and if all’s well -

If necessary get some of these (or similar):

or

But if you MUST use wireless:

or

Do you use the powerline adaptor? I have seen mixed reviews of using the power cables for networking.

Will try changing the frequency. I using wi-fi as do not wont cables running all around the house.

Wireless is far from ideal… it may even be another wireless PC on the network using the wireless bandwidth (have you tried it as the ONLY PC that’s connecting wirelessly ?)… wired is ALWAYS preferable.

In answer to your question… Personally NO, I’ve CAT5E wired my house… but I’ve fitted powerline adapters for many other people in the past, and have never had any issues… they beat the living s**t out of wireless.

Can’t say I’ve used this particular product, but read the 69 reviews:

5 Stars :wink:

Some people say the monitoring software isn’t up to much, but as it’s probably windows-only software so you aren’t going to be using it anyway… but all seem to agree that they work perfectly… and why would you want to monitor the connection anyway :wink:

One other thing I’ll say is if you’re not happy with them, I’ve never (so far) had any problem with ebuyer swapping anything for another product, or refunding… no questions asked… but that is just my experience, I’ve used them a LOT in the past, so maybe they are just keeping me happy.

I have considered these adaptors in the past and have also used ebuyer perhaps it’s the way to go.

Once you’ve thoroughly tested it with a wired connection and are happy it works… that’s the way I’d go :wink:

It’s also going to free up a USB 2.0 port, and maybe allow you to ditch the add-in USB card.

Hi, I have removed the PCI sound card and gone back to the on-board sound and it seems to have improved the mic in-put by leaps and bounds.

Also using wired connection and had no problems with SKYPE calls even when checking my emails at the same time so it looks like it was the wi-fi and sound card all-along.

I will be buying some of the networking powerline adaptors as you suggested.

Thanks for your help on this.