kodak printer drivers on acer aspire one impus lite

Has anyone discovered a way of printing from linux? I have a kodak 5250 aio. I have tried open source and it finds the driver but of course it don’t work. mainly because this is linux not windows and nothing is simple!!
If anyone has a step by step guide on how to use such a site it would be greatly appreciated.
Thanks, john

As far as I can tell there is no easy way to install this printer in Linpus Lite as the drivers (c2esp) are only available for Ubuntu/Mint/Debian (.deb file) or as source code, but Linpus Lite doesn’t have the kernel source, headers, gcc, or any of the other build tools required to build from source.

Bit of friendly advice, comments like -

mainly because this is linux not windows and nothing is simple!!
say more about Linpus Lite than Linux as a whole, they also show your only Linux experience is with the outdated Linux distribution that Acer decided to install on the AA1 .. this type of comment is also unlikely to win you many friends on a Linux forum ;)

It would also be nice if Kodak supported Linux, rather than leaving the drivers to others … if you want FULL Linux support, first get rid of Linpus Lite and install an up-to-date Linux distribution, then get an HP printer.

If you want to try using the pre-compiled i386 binaries for Ubuntu and the .ppd … let me know and I’ll upload them to my dropbox and write up some installation instructions, but I have no idea if they will work … and at best they will only give you the ability to print, not scan or fax.

hi
firstly an apology for any comments about linux distribution . I just get so frustrated over the complicated way the novice like myself is expected to download programmes. it is lightning fast for searching the web and from start up compared to windows but simple tasks like printing is almost impossible. Yes i know the acer aspire one is a net book, but the ability to print would be nice also :slight_smile:
i would be most greatful if u could download instructions for me, i don’t need to scan etc just print.
kind regards, and thanks,
john

Linux isn’t a distribution, only a kernel. If I were you, I’d complain to Acer the OEM, to install an updated version of a Linux distro. Something like Lubuntu or Kubuntu would be more suited rather than the full Ubuntu desktop OS. Since Lubuntu, & Kubuntu use the Ubuntu repositories and all other things from Ubuntu, you’d have lots of support, lots of up to date software and things like the drivers for Kodak printers would be easier to install. I’ve only been using Ubuntu for 17 months and it’s been easy as pie to install anything. You just have to get round the new learning curve, and get rid of the old stupid windows habits and your experience will be golden everytime. Granted Ubuntu, or Linux itself isn’t perfect, but neither is Windows/Mac OS X. :slight_smile:

If I were you, I’d get rid of Linpus Lite and update to a distro like Lubuntu or Kubuntu. That way you’ll be able to enjoy up to date software.

I’ve only been using Ubuntu for about

As I said, this may or may not work … but here goes …

OK, open a terminal … you can do this by hitting Alt+F2 then in the resulting box enter terminal anf hit enter.

a terminal window will open … enter:

wget http://dl.dropbox.com/u/11876059/c2esp.tar.gz

and hit enter.

then still in the terminal enter:

sudo tar -xvf c2esp.tar.gz --directory /

and hit enter.

When that command finishes … REBOOT

When the system has restarted … Plug your printer into a USB socket, and turn it ON

The printer may be autodetected, and you offered a configuration button … if it isn’t …

Open Firefox and in the URL/Address bar, enter:
localhost:631

You will be presented with the CUPS (Common UNIX Printing System) interface …

Click the Administration tab

Click Find New Printers … if it is listed, follow the instructions … if not …

Click the Administration tab

Click Add Printer

Name = kodak5250aio
Location =
Description =

Click Continue … and follow the instructions.

hey mark
thanks for that, it found my printer which is great. when i tried to print there was no movement from the printer. i have a small printer icon bottom right which says 2 documents held in queue. Think its on the verge and most likely its something i have not done. Any ideas would be great, many thanks,
john

All I can suggest is deleting the printer in the CUPS interface, and trying again … experiment a little.

Meanwhile I’ll go through the debian post install routine to see if there’s anything I missed.

BUT … as I said before, there’s a good chance this WILL NOT WORK … there is NO version of the driver that’s specifically designed for Linpus Lite, or any other .rpm based Linux distro … the only sure fire method of installation on anything other than a .deb based distro is compiling and installing from source code, but Linpus Lite is incapable of doing this.

My real advice would be to switch to a more recent (and Debian based) disto, such as PeppermintOS, Lubuntu, Xubuntu, etc. … then the drivers will be a double-click to install thing.

or get an older HP printer :wink:


Think of it like this … Linpus Lite is (in Windows terms) Windows 95, yet the drivers were probably built for (the Linux equivalent of) Window Vista/Win7

I very much doubt if you’ll get Windows 95 drivers for your printer either :wink:

But in the Windows world, when no Win95 drivers available, you’re stuck … In the Linux world, the source code for the drivers is usually available, so you can compile them yourself … the problem is that because Linpus Lite is a VERY trimmed down and customised version of Fedora core 8, it doesn’t contain the tools to compile from source and there’s no easy way to install those either.

In the near future, I’m going to be attempting to install Fedora core 8 in a virtual machine … to see if more recent software and drivers can be compiled in that, then packaged for Linpus Lite … but in all honesty, I wouldn’t hold your breath.

As previously mentioned … best bet would be to install PeppermintOS (or similar) then effectively you’re running the Linux equivalent of Vista/Win7 and the drivers will install easily.

PeppermintOS, Lubuntu, Xubuntu, they’re all free, and you can test drive them first by running them from a USB stick if you wish … if you want further info on creating a LiveUSB stick, just ask.

hi mark
i would like to try what you said, i have usb sticks laying about, i take it one i have used in windows os also works with linux? Test driving them first is a great idea.
the printer icon is still showing documents held in queue. Sounds silly but i’m pleased its even got as far as that!
I look forward to any instructions you are able to give me.
cheers,
john

Which would you like to try first ? … PeppermintOS is damn fast and so far my favorite on the AA1, but will require you to manually install an office suite, etc. if you regularly use one on your AA1 … by default it uses the online Google Docs (which is fine if you have an active internet connection, but a pain if not) … it’s easy to install LibreOffice (that’s an updated OpenOffice), just thought I’d let you know first.

The reason I like PeppermintOS for the AA1 is that it DOESN’T come with a load of stuff that you will never use preinstalled … but obviously this means you may have to install some stuff you DO need (all very easy to add the package manager) :wink:

Might be a good idea if you let me know what applications you use on the AA1 … ie. things you NEED … and I’ll try to advise on the best one to test drive first … and how to put it on a LiveUSB.

Have you got access to a Windows PC ?

And a >= 2GB USB stick ? … 4GB would be better.

happy to try which ever one you think might get my kodak printer on the move some. I really only use the aa1 for emails ane net browsing. Whenever i use it its always connected to the net. i do have access to a windows laptop and a 4gig usb stick. an office set up would be handy though, because you never know. But the ability to print would be my first choice.
as always, much appreciated,
thanks, john

OK, on your Windows PC, download the PeppermintOS (two) ISO image from here:
http://peppermintos.info/dl2/Peppermint-Two-i386-06052011.iso
or see here:
http://peppermintos.com/download/

Once you’ve got the ISO image … download Universal USB Installer from here:

or see here:

Start Universal USB Installer, and at …

Step 1 … In the drop down list, select PeppermintOS (Two)
Step 2 … point it at the ISO image you downloaded
Step 3 … Choose your (already plugged in >= 4GB) USB stick … probably best to let it format it too, so backup its contents first.
Step 4 … Set the slider to at least a 2GB persistence file … so you can save changes, like adding the printer driver, LibreOffice, Firefox, etc. to test.
(the persistence option says optional, but you NEED one)

Heres a pic of the Universal USB Creator interface

http://linuxforums.org.uk/MGalleryItem.php?id=1510

Click Create … and wait till it’s done … it will take a while, and may appear to have stopped … but just wait till it says it’s “Done” … as in the following pic

Pic of Universal USB Installer … Installing to USB Stick

http://linuxforums.org.uk/MGalleryItem.php?id=1509

Once the LiveUSB has been created, click Close, plug it into your AA1, then turn ON your AA1 … as soon as you see the first screen (Acer Empowering People), hit the F12 key to access the boot device selection screen … and select the USB stick as the drive to boot from and hit Enter to boot.

When asked, select “Try PeppermintNOTInstall Peppermint

Be aware … running from a USB stick will be quite a bit slower that running it from the internal SSD after installation, so don’t draw any conclusions about speed at this point :wink:

I can tell you that once installed, it takes about 15 - 20 seconds longer to boot than Linpus Lite … but once booted it loads/runs applications just as quickly … and has access to all the latest software.

Once you’ve got that going … let me know … and I’ll tell you how to install your printer drivers, and some other stuff such as LibreOffice, Firefox (rather than Chrome), Thunderbird (if you need it) … and how to achieve things like auto login, and get the wireless to auto start every boot, etc.

Thanks Mark,
i’m back to work for 5 straight days now but will give it a go as soon as i’m off again. i need to dedicate a little time to it as does not sound like a 20 minute job ;).
thanks very much and i will let you know as soon as i have loaded it on my usb.
cheers,
john

other than for the download (which you can start overnight) it’s not that much work to get it on the USB and will probably take about 20mins including installing the printer drivers … BUT the time consuming part will be getting it set up the way you want.

There were a few things I had to do to get it “right” … but at least I know how, so can advise … the thing that took the most time was learning how … not something you need to do, as I’ll tell you.

Here’s the list of things I added/sorted … and the aprox time it will take

  1. enter the wireless key and connect … 1min
  2. enable wireless autoconnect … by default you had to turn wireless on every boot … 1min
  3. enable the extra repos … 2min
  4. enable auto login (if you want) … 2min
  5. run an update … 7min
  6. install apt-xapian-index
  7. install firefox
    8.) install vlc
  8. install libreoffice-writer
  9. install libreoffice-calc
  10. install thunderbird
  11. install pidgin (or amsn) IM client
  12. install lubuntu-restricted-extras

all the software can be installed with a single command, and will take about 5 mins to install

Done :slight_smile:

So add it all together, and giving yourself time to read the instructions and digest them … a couple of hours (as long as you already have the ISO image and application I mentioned in the last post).

But whenever you’re ready :slight_smile:

hi mark
have tried several attempts now at following the above, when i go to boot the aspire up nothing happens, last time it simply said boot error. I’m obviously doing something wrong but can not think what.
any suggestions greatly received,
kind regards and thanks, humble apologies for me taking so long to get round to trying this new os, been manic here of late
john

I’m a little lost … What are you attempting to do ?

Install Peppermint ?

If so, how far do you get with the installation ? … does the system boot to a working desktop from the LiveUSB stick (if you select “Try Peppermint”) ?

hi mark
when i boot the acer aspire by pressing f12 this is what comes up;
SYSLINUX 4.05 EDD 2011-12-09 copywright (c) 1994 2011 H. peter Anvin et al

any ideas whats happened, just went through all the stages once more and same thing comes up after pressing f12 button
cheers, john

Tried to put into my windows machine and open the pen drive, it does not auto run so not sure how to check the files on there mark

OK, so you never got as far as installing Peppermint ?

This is a message from the LiveUSB saying it cannot boot … you can try a different application to create the LiveUSB … or use a different USB stick.

If you search the forum (for “SYSLINUX”) you’ll see Peppermint doesn’t like certain USB sticks … though sometimes people have been able to create a working LiveUSB using a different LiveUSB creator.

I’m sure that was in the Peppermint tutorial ?

Would I be right in assuming when you hit F12, the USB stick is listed as a USB FDD (floppy disk drive) and not a USB HDD (hard disk drive) ?

hi mark
i never looked at the tutorial, ok, i will order another usb from ebay to see if it makes a difference. in the mean time my acer has upgraded itself to firefox 8!!, any chance you can direct me to a link on how to revert back to 7? i have tried the search but only seems to display the link for upgrading from 2,3,4,5,6,. i need to downgrade from 8. i found it before but its escaped me now.
many thanks, john

yea just popped it back in mark, its second in menue, says fdd