Laptop screen goes black after installing 12.4 (Solved)

Hi,
Since 11.10, Ubuntu has been difficult to run, I have to use the 32bit versions on my tower unit, a dual core 64bit with 4gig ram.
And my laptop will only run with Suse 12 64bit in safe mode, having been a Ubuntu user, I should like to stick with what I know.
The laptop works OK if I connect a monitor, the laptop still has a black screen, but the monitor is fine. Suse will work the monitor during installation, then you need to go to the safe mode or that goes black as well.

Before I go mad and back to Windows 7, could anyone help? Laptop is emachine, E525, Intel Celeron cpu 900 @ 2.2 GHz
Currently running Linux 3.1.10.9 desktop x86_64
openSuse 12.1 (x86_64)
KDE 4.7.2 release 5.
With 4gig ram, fitted, Suse is showing that we have 3.8gig.

Thanks.

Do you know which graphics card your Laptop has?

If not, could you open a terminal and run:

sudo lshw -C *-multimedia

If this is a intel graphics then it is more than likely a backlight issue.
You can check this by shining a torch (in the dark) on the screen.

A quick google suggests the eMachines E525 has an Intel® Graphics Media Accelerator 4500M with a 15.6" LCD (1366x768).

So SeZo is probably correct (as usual) … is the picture actually being displayed on the laptops screen, but the backlight not working ?
(check with a torch)

Most suggest kernel mode setting causes the backlight to distinguish and stay off (so adding nomodeset as a kernel boot parameter should work)… others suggest it’s caused by the backlight just being very dim.

So if the picture IS displayed, we can try the nomodeset kernel boot parameter first … as it’s the easiest option.

If you need help adding nomodeset to the kernel boot line (as a single boot test) … just ask :slight_smile:


Links for future reference:

and

and
http://linux-on-acer-aspire-5732z.blogspot.co.uk/2011/06/backlight-workaround-for-linux-mint-11.html

Thanks for that answer, and yes you can see a very dark image as if the back light is switched off, your help would be very kind of you, thanks.

OK, try this …

Turn ON your laptop, and as soon as your BIOS POST screen disappears, press the SHIFT key and hold it, until you are presented with the GRUB menu … SIMILAR to this:
(you won’t have long to hit the shift key, and the timing can be a little awkward, so it may even be easier to hit AND HOLD the Shift key DURING the BIOS POST … ie. immediately after turning on your PC)

http://linuxforums.org.uk/MGalleryItem.php?id=1361

Select the ‘default’ Ubuntu kernel (usually the top one), and rather than pressing enter, press E to edit.

You will be presented with a screen SIMILAR to this:

http://linuxforums.org.uk/MGalleryItem.php?id=1152

Press DOWN ARROW until you get to the line that starts with:

linux /boot

and press the END key to position the cursor at the end of the that line… it usually ends with “quiet splash”.

Now you can enter additional kernel boot options… so add the nomodeset option as in the above screenshot … so it now reads:

[b]quiet splash nomodeset[/b]
(doesn't matter if it moves down a line, as long as there is a space between splash and nomdeset)

Now hit Ctrl+X to boot.

and let me know what happens.

BTW, if this works, it will only work for a single boot and will need re-applying at the next boot … but if it solves the issue, we’ll make it permanent :slight_smile:

Thank you for that, — I need to reinstall Ubuntu 12.4 LTS 64 bit, so please give me a little time.

Thanks again, I’ll make a start now and let you know how I get on.

Does 12.04 work from the LiveCD/LiveUSB … if not there’s instructions for setting the nomodeset option from the LiveCD/LiveUSB here:

See the second pic.

That way you can test it without installing :slight_smile:

Hi,
Ubuntu 12.4 has been installed and updated, your piece of code has worked and as you said, worked only for that session.

I am so thankful for your help, how do we make it permanent?

Tony.

OK, first let’s backup /etc/default/grub … so open a terminal (Ctrl+Alt+T) and run:

sudo cp -v /etc/default/grub /etc/default/grub.backup

Now open /etc/default/grub for editing:

sudo gedit /etc/default/grub

Find the line that reads:-

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash”

and change it so it reads:-

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash nomodeset”

SAVE the file, and exit gedit.

Now back in the terminal, run:

sudo update-grub

Wait for that command to complete, and leave you back at a $ prompt.

That’s it … you’re done … just reboot to test :slight_smile:


If that works, and you consider the issue solved, can you please edit the first posting in this topic (by clicking the Modify link) and make the Subject: line read:-

Laptop screen goes black after installing 12.04 (SOLVED)

Thanks.

Thanks so much for all your help, this is my first restart and all is working fine.

Thank you again.

Tony.

You’re welcome :slight_smile: … If you now consider this issue solved, can you mark the topic as (SOLVED) please.

It may help future searchers find the solution quicker.

TIA.

Hi! I am having the same issue. My bigger problem is that I used the “Install within windows” option for Mint. So, I am using the windows boot manager and there is no way I can see to edit anything to fix the problem.

Is the only option to actually install Mint alongside windows?

Thanks for the info :slight_smile:

Hi Xa3phod, and welcome to the forum :slight_smile:

I know little of WUBI installs, but what happens if you get to this screen

http://linuxforums.org.uk/MGalleryItem.php?id=1555

select Ubuntu … and hit Enter.

Then immediately hit and hold the “Shift” key ? … do you get presented with the GRUB menu ?

.