Legacy printers listed in a fresh Ubuntu install on Windows machine. [RESOLVED]

This Topic is a renamed one because, as usual, we drifted off-topic.
The original Topic was about discovering the location of archive files, and the first couple of posts dealt with this satisfactorily - they are shown immediately below. Read on for the main discussion…

Where is the Archive in Ubuntu?

I downloaded the Ubuntu 16.04 ISO file for a new desktop that I am preparing for a friend. The download was fine except that it did not go to Downloads as expected (that’s where Firefox is set send downloaded files) but to an Archive. I know this because hovering the mouse over its entry in Places tell me the path-name. But I can’t find an archive directory anywhere.

I want to use Unetbootin to create a live USB but can’t do so without specifying the path.

Your assistance would be appreciated.

Run:

sudo updatedb

then

locate -i *.iso

that should list all files on the system (and their locations) with “.iso” as their extention.

That worked perfectly - and a useful command for later, too. Thank you Mark.
I discovered also that I ought to have ticked the “Save” button when downloading, as doing so would have sent it to the Downloads folder. So, sorry to have troubled you - although I have learnt something very useful.

The next, related problem is:
I now need to re-install Ubuntu to remove all non-functioning references to old printers, but I know from experience that the clever installer will keep everything except anything new. How can I delete the whole disc before installing anew, to prevent this happening? Or is there a magic command to use during installation?

Alternatively: is there a way of removing these obstinate printers from the printers list, thus obviating the need for a full re-install? I can’t delete them using CUPS, either.

[Edit] tried sudo usermod -aG lpadmin to no avail.
[Edit] tried lpadmin -x KODAK-5300-AiO

The installer SHOULD offer you “erase Ubuntu and use entire disk” … but if you want to be sure, fire up the LiveUSB and use GParted to delete all the partitions first.

But YES, printers can be removed … in a web browser, go to:
http://localhost:631
and then go to
Administration > Manage Printers

If at any time you’re prompted for a username an password … enter your Ubuntu ones.

Now click the blue writing for your printer, and on the next screen click

Administration > Delete Printer


If that still doesn’t get rid of em, post the output from:

sudo lpstat -s

and

sudo cat /etc/cups/printers.conf

Sorry, I didn’t scroll down to the rest of your reply: I did indeed click on the blue printer entries in CUPS but it responded: “Address wasn’t understood”. Same for all the other printers. The reason being that the address contains the name of my own laptop on which I installed Ubuntu from the original live USB. For example:

lorene@ox12:~$ lpstat -s
system default destination: KODAK-5300-AiO-2
device for Epson-Stylus-Photo-PX720WD: ipps://T500.local:631/printers/Epson-Stylus-Photo-PX720WD
device for HP7610: ipps://T500.local:631/printers/HP7610
device for KODAK-5300-AiO: ipps://T500.local:631/printers/KODAK-5300-AiO
device for KODAK-5300-AiO-2: usb://Eastman%20Kodak%20Company/KODAK%205300%20AiO?serial=B7BU0132&interface=1

where T500 is the name of my laptop but ox12 is the name of the desktop I am struggling with.

Just tried to boot from the USB but it asks for username and password in a terminal, and of course the desktop values won’t work.
Can I delete the partitions while actually running the desktop ? I know that sounds silly, but clutching at straws.

Whilst booted to Ubuntu (not the liveusb) try running:

sudo lpadmin -x KODAK-5300-AiO

and

sudo lpadmin -x Epson-Stylus-Photo-PX720WD

and

sudo lpadmin -x HP7610

and

sudo lpadmin -x KODAK-5300-AiO-2

then post the output from

sudo lpstat -s

again.

and the output from:

sudo ls /etc/cups/ppd

and

sudo cat /etc/cups/printers.conf

Otherwise, the Ubuntu live username and password should be
username = ubuntu
password =

I have already tried the sudo lpadmin -x KODAK-5300-AiO but it had no effect earlier. I have just now repeated all your commands but the output from the last two commands is:
lorene@ox12:~$ sudo stat -s
stat: invalid option – ‘s’
Try ‘stat --help’ for more information.
lorene@ox12:~$ ls /etc/cups/ppd
lorene@ox12:~$

I shall use your live USB password method and report back.

you missed out “lp” in “lpstat”.
(always best to copy/paste commands)

Also post the other output I asked for.

I mean you can reinstall if you want, but that’s a bit drastic.

Sorry; not doing so well tonight!

[i]lorene@ox12:~$ sudo lpstat -s
[sudo] password for lorene:
no system default destination
device for epson-stylus-photo-px720wd: ipps://T500.local:631/printers/Epson-Stylus-Photo-PX720WD
device for hp7610: ipps://T500.local:631/printers/HP7610
device for kodak-5300-aio: ipps://T500.local:631/printers/KODAK-5300-AiO
lorene@ox12:~$ sudo ls /etc/cups/ppd
lorene@ox12:~$ sudo cat /etc/cups/printers.conf

Printer configuration file for CUPS v2.1.3

Written by cupsd

DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING

UUID urn:uuid:6e86a212-7594-35c6-5a08-442335d6f772 Info Epson Stylus Photo PX720WD @ T500 Location T500.local DeviceURI ipps://T500local:631/printers/Epson-Stylus-Photo-PX720WD State Idle StateTime 1486154343 ConfigTime 1486154343 Type 6 Accepting Yes Shared No JobSheets none none QuotaPeriod 0 PageLimit 0 KLimit 0 OpPolicy default ErrorPolicy retry-job Option cups-browsed true UUID urn:uuid:8c9111a6-3eb0-30d1-7baf-d25447e134d7 Info HP Officejet 7610 series @ T500 Location T500.local DeviceURI ipps://T500.local:631/printers/HP7610 State Idle StateTime 1486154360 ConfigTime 1486154360 Type 6 Accepting Yes Shared No JobSheets none none QuotaPeriod 0 PageLimit 0 KLimit 0 OpPolicy default ErrorPolicy retry-job Option cups-browsed true UUID urn:uuid:f5ee2c3f-c0f6-36b1-5eed-1f4cd1269173 Info Eastman Kodak Company KODAK 5300 AiO @ T500 Location T500.local DeviceURI ipps://T500.local:631/printers/KODAK-5300-AiO State Idle StateTime 1486154319 ConfigTime 1486154319 Type 6 Accepting Yes Shared No JobSheets none none QuotaPeriod 0 PageLimit 0 KLimit 0 OpPolicy default ErrorPolicy retry-job Option cups-browsed true lorene@ox12:~$ [/i] I have highlighted the references to a completely different computer (my laptop).

Could I simply delete the list of printers from the conf file?
Answer: Nope. The printers still appear in the printer system settings list.

Okay, try this:

sudo systemctl stop cups.service

then

sudo cp -v /etc/cups/printers.conf /etc/cups/printers.conf.broken

then open printers.conf for editing

sudo gedit /etc/cups/printers.conf

and make it read just:-

# Printer configuration file for CUPS v2.1.3
# Written by cupsd
# DO NOT EDIT THIS FILE WHEN CUPSD IS RUNNING

SAVE the file and exit gedit

now restart the cupsd daemon

sudo systemctl start cups.service

Have the printers gone ?

Perfect!!
I had tried deleting the list myself, without success. The key was stopping CUP.
You have saved the day once more, Mark!

It looks like when updating Ubuntu to a new version by using a Live USB, the process copies lots of info from the existing system to the USB files for inclusion in the upgraded system - and that the copied info remains on the USB device. So when I used it for a fresh install on a new system, my printers were “installed” on the new computer but with the wrong computer name.

I was just about to try changing the computer name in the conf file when your post appeared.

My sincere thanks, as usual, Mark.

Not sure your hypothesis is correct, but who cares what happened if it’s fixed now eh :wink:

Well,…sort of. I install a Kodak printer via a USB connection (and its conf file is correct) but when I try to print or clean the heads via the Printers dialogue, it begins then I receive a message “Processing - Unplugged or turned off”, although it works on other PCs - I shall try installing a network printer tomorrow.

Curiouser and curiouser. Although I can delete printers from the Printers list, when I Add Printer and it searches for what’s around it still comes up with a list of previously installed printers despite them not being switched on. So there is another file somewhere that has the info.

Anyway, this was too painful so I used a GParted Live USB (and a donation) to remove the main partitions from both the SSD, and also the HDD that had remnants of Windows on it (so looked like a dual boot), then did a fresh install which is lightening fast with an SSD.

So problem solved - sort of - but I would really like to know what’s going on.

Many thanks for your assistance, Mark.