LibreOffice not starting [possibly SOLVED]

Lenovo Thinkpad T500 laptop with Ubuntu 16.04 64 bit.

I’ve been playing about with scripts and crontab to start LibreOffice in order to display a message then close it after a while. This worked fine all day but now LibreOffice won’t work at all, even from the applications menu. I have tried updating and re-installing LO and the menu items are displayed, but none of the LO facilities will start. The appropriate tab in the task bar appears for a few seconds then disappears.

Assistance would be very much appreciated.


[UPDATE] I have:
  • removed LibreOffice via the terminal (but is still listed in the Software Centre as installed and shown in the Applications menu)
  • un-installed all the LO packages from the Software centre
  • re-installed LO via the terminal (still marked as unistalled in the Software Centre)
  • re-installed the Writer package in the Software Centre

But still none of the LO software will start.


[UPDATE 2] Partial success. My machine has two software sources:

[ol]- SystemTools/Administration/Ubuntu Software Centre

  • System Tools/Software[/ol]

I’ve been using the first one but after finding the second one I was able to install LibreOffice 6 and remove the original links from the Applications menu.
So I now have a working Office suite although this doesn’t explain how I screwed up the original installation by just playing with cron.

So: fixed for now, though I doubt that this post has helped anyone else and I am still keen to hear of any opinions/ideas.

It’d be impossible to comment on this without knowing what you were getting cron to run

Sorry Mark - you are right.

I’ve marked this post as “possibly solved” as I have removed the old version of LibreOffice and installed Version 6, which is awful!
The crontab problem is described in a post in the Programming section: https://linuxforums.org.uk/index.php?topic=13352.msg108908#msg108908 and I have since chosen not to invoke LibreOffice.
Although I could do the job another way, I would really like to understand how to use crontab as it looks very useful.

Your advice there would be welcome.
Thank you

Why not try installing gnome-schedule, which is really just a GUI front end for cron

You can install gnome-schedule in Ubuntu 16.04 or Peppermint 7 or 8 by running the following commands in sequence:

sudo apt-get install gdebi

then

mkdir ~/gnome-schedule

then

cd ~/gnome-schedule

then

wget http://launchpadlibrarian.net/109052632/python-support_1.0.15_all.deb

then

wget http://launchpadlibrarian.net/60698472/gnome-schedule_2.1.1-4_all.deb

then

sudo gdebi ~/gnome-schedule/python-support_1.0.15_all.deb

(answering “y” when prompted)

then

sudo gdebi ~/gnome-schedule/gnome-schedule_2.1.1-4_all.deb

(answering “y” when prompted)

You’ll then find it in the menu at:-

Menu > System Tools > Scheduled tasks


If you now want to clean up thhe installation directory, feel free to delete the folder called “gnome-schedule” in your home folder.


To UNINSTALL

sudo apt-get remove --purge python-support gnome-schedule

Ah! - that looks good. I shall do so and get back later…

That installed fine, thank you, and looks to be very convenient to use.

Running an executable file isn’t so straightforward, though. I had one running whilst trying to make this post but this page kept disappearing a few seconds after each time the cron job executed - it looked like a time-out. Deleting the cron job fixed the problem. Goodness knows what was going on.

Anyway; the job I was trying to do is working perfectly now and I am very grateful for your patience - and expertise!
Thank you, Mark.

Keith

No problem Keith, happy it was of some use :slight_smile: