Linux Black Screen of Death?

Lenovo T500 laptop with 512GB SSD and “Classic View” (Metacity)

Upon booting up my T500 today a “No entry” sign appeared in the top panel along with the usual symbols. Clicking on this symbol informed me that I have unmet dependencies (mentioning Wine) and that I should use Synaptic to fix broken packages. Synaptic reported no broken packages.
As I am not that confident with Synaptic PM I opted to simply uninstall Wine using the Ubuntu Software Manager. It appeared to hang for 10mins so I foolishly exited the Software Manager and the PC froze.

Rebooting appeared to start Ubuntu but then the screen went blank/black. After a few seconds a line of text flashed briefly returning to a black screen and this process repeated with one new line being added each time. After 1/2hr this all stopped revealing the text which appeared to be almost identical, repeated blocks of which the last one is (omitting line numbers):
ata1.00: exception Emask 0x0 SErr 0x0 action 0x0
ata1.00: BMDMA stat 0x25
ata1.00: failed command: READ DMA EXT
ata1.00: cmd 25:00:08:e0:3b:56/00:00:12:00:00/e0 tag 0 dma 4096 in
res 51/40:08:df:3b:56/40:00:12:00:00/e2 Emask 0x9 (media error)
ata1.00: status: { DRDY ERR }
ata1.00: error: { UNC }
blk_update_request: I/O error, dev sda, sector 307641312

Is this an SSD failure?

I can run Ubuntu from a live USB and access the files using a terminal, so I guess I can back up all recent files (old ones are already backed-up!) and if the SSD is still OK then I can re-install Ubuntu.

Advice would be very gratefully received!


(Writing this on a spare PC)

Is AHCI enabled in the BIOS ?

From a LiveUSB, what’s the output from:

sudo fdisk -l

Hi Mark.

I am at present backing up all the files just in case and it’s taking for ever, for some reason, but I feel it’s best to let it do it’s thing before I do your tests.
Shall report back asap.
In the meantime; can you tell me what AHCI is, please?

Thanks.
Keith

Good plan :slight_smile:

AHCI is an operating mode setting for the HDD/SSD in the BIOS

(your system is likely set to AHCI anyway … I’m just checking)

The back up is not going well.

The BIOS is set to “Compatibility mode” - should I set it to AHCI mode?

The output from fdisk -l is:
Disk /dev/ram0: 64 MiB, 67108864 bytes, 131072 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes

Then the same repeated for RAM 1 to 15. Then:

[i]Disk /dev/loop0: 1.4 GiB, 1459982336 bytes, 2851528 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk /dev/sda: 477 GiB, 512110190592 bytes, 1000215216 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x000f3af0

Device Boot Start End Sectors Size Id Type
/dev/sda1 * 2048 996167679 996165632 475G 83 Linux
/dev/sda2 996169726 1000214527 4044802 2G 5 Extended
/dev/sda5 996169728 1000214527 4044800 2G 82 Linux swap / Solaris

Disk /dev/sdb: 28.9 GiB, 30998003712 bytes, 60542976 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6b6d9f39

Device Boot Start End Sectors Size Id Type
/dev/sdb1 * 8064 60542975 60534912 28.9G c W95 FAT32 (LBA)[/i]

An SSD should always be set to AHCI, so yeah give it a shot … you can always reset it.

Setting to AHCI has made a slight impression on the behaviour: still a black screen with occasional flash of a new line of text but stopping at line 3 as follows:

[ 6.188633] cdc_wdm 2-4:1.5: wdm_int_callback - 0 bytes
[ 6.189509] cdc_wdm 2-4:1.6: wdm_int_callback - 0 bytes
[ 10.383738] cdc_acm 2-4:1.1: failed to set dtr/rts

Backing up the data using the live USB is not progressing well so I shall buy a “carrier” for the SSD and plug it into my spare desktop to see if that gives better access.

In the meantime, any advice for more tests would be welcome.

is there a modem you can disable in the BIOS ?

cdc_wdm
and
cdc_acm

are drivers for USB Modems.

No, Mark; I’ve been through all the BIOS items and found nothing remotely like modem.
As it’s a laptop, I would have been surprised to find one, but I’m not very aux fait with these things.

Okay we can attempt to fix this, but it may be easier (certainly quicker) to just reinstall … let me know what you want to do ?

Hi Mark.
As the back-up via the live USB wasn’t going well I bought a very nice SSD carrier from eBuyer which has just arrived and I have succeeded in copying all my files to my desktop.
So the best thing to do now is to just re-install Ubuntu on the laptop, as you suggest, then copy the files back to it.
I’m guessing that the usual installation method from the live USB will do the trick and it will erase everything first. OK?

Keith

UPDATE

Back up and running now.
The only problems were with Firefox and Thunderbird. Placing the .thunderbird and .mozilla directories in the home folder didn’t work - Ubuntu telling me that those applications were already running. But I got round it eventually by just copying Bookmarks into a new FF and Local Folders & address books into a new TB.

One moral of this story is to ensure that one always keeps a reasonably up-to-date backup of all ones files. My backup was a couple of months old but I was able to extract all my files from the SSD using an external SSD carrier.

Many thanks for your advice and moral support, Mark - much appreciated.
Keith

Another way would have been to either:-

a) make sure they weren’t running
or
b) copied just the Tbird and FF profile directories … then modified the profiles.ini file to point at those profiles as opposed to the default ones.

Glad to hear you’re back up and running Keith :slight_smile:

Thanks, Mark.

I think the problem with FF & TB was that the system crashed while they were running so there must be some sort of “flag” amongst their files that tells Ubuntu they are running, and those flags would remain set - so just placing the .mozilla & .thunderbird directories in the home folder wouldn’t work. Or something like that.

In fact backing up just the TB Local Folders & Address books and FF Bookmarks is a lot faster anyway than backing up the whole lot, so I shall do that as part of my routine backup. (I use IMAP so all my emails are safe).

My thanks once more for your patience.
Keith

You’re absolutely correct… when FF and/or TB is running you will find a file called “lock” in their respective profile directories.

So that’s what it’s for! Thank you for the explanation, Mark.