Linux Discrimination

I put this in general discussion because I don’t think there’s a solution but this really pissed me off

Due to staffing issues at her work my missus has been doing work at home in the evenings, I set up a remote desktop connection to her work PC with Reminna which works perfectly but last night she had to log into a secure website (Scottish Qualifications Agency) but when she tried to log in she got this message

Secure Connection Failed

An error occurred during a connection to www.sqaconnect.org.uk. SSL received a record with an incorrect Message Authentication Code. (Error code: ssl_error_bad_mac_read)

The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem.</blockquote>

So I tried to figure what was wrong I came across this on their FAQ which is what I expected

http://www.sqa.org.uk/sqa/files_ccc/SQA_Connect_System_Requirements.pdf

so I have a couple of questions

(1) Is there any way to circumvent this ?

(2) Is there any technical they should block access from Linux PC’s ?

I asked her to contact the SQA and ask them why they discriminate against Linux users but needless to say she wont and I can’t do it for her

Graeme

Try disabling IPv6 in firefox

In the address bar, type
about:config
and press Enter.

When you see a “This might void your warranty!” warning page, click the “I’ll be careful, I promise!” button to continue to the about:config page.

In the Search field, type network.dns.disableIPv6

In the list of preferences, double-click network.dns.disableIPv6 to set its value to true

exit about:config

close and reopen Firefox

now try the website again


I’m not sure this is discrimination against Linux as much as their website still using old outdated standards such as TLS 1.0, so if the above doesn’t work we may need to add an exception:
https://support.mozilla.org/en-US/questions/1056108

I tried what you suggested and it didn’t work although I didn’t get as far as adding an exception but what I did do was try it in Chromium and it opened the log in page straight away so you’re right it possibly isn’t deliberate Linux discrimination but it’s still discrimination in so far as not listing Linux in their FAQ system requirements

many thanks for your help

Graeme

Cool, glad you found a workaround