Linux has taken over my system (SOLVED - thank you)

Having wrestled with Linux Mint 13, and 3 different ‘Virtual’ programs, without success I have decided to try something else.

Trouble is I can’t stop Linux saying “I’m in charge”. Although I changed my hard drive priority to my WinXP drive I still get the Grub menu on boot up. Granted this does allow me to boot to Windows but that isn’t quite what I want. If I disconnect the drive I used for Linux I get an error message and the system will not boot.

It seems to me that Linux has either: -

a) Got at my BIOS to override the priority settings I have chosen or

b) Planted a file on my C: (Windows) dev/sda1 drive directing the the boot to G: (Linux) dev/sdb1.

I suspect that b) is the more likely, but try as I might I can’t find anything on my C: drive that could do this. Where might it be hiding?

In the unlikely event that Linux has ‘got at’ the BIOS where would I find the miscreant?

Tony N

It’s in the master boot record (MBR) whch isn’t visible from within the OS :wink:

With only the WinXP HDD attached …

  1. Boot up with your Windows XP CD.

  2. Select the option Recovery Console.

  3. At the prompt, type “fixmbr” (without the quotes of course) ← rewrites the MBR

  4. At the prompt, type “fixboot” (without the quotes of course) ← fixes the boot files

  5. Restart your computer.

You can probably skip step 4

See here for how to access the “Recovery Console” from an XP CD:

If for some reason that doesn’t work … change step 3 to:-

  1. At the prompt, type “fdisk /mbr” (without the quotes of course) ← also rewrites the MBR

and skip step 4

OK It seems you have a got the wrong end of the stick on few items.
If you have no install disks then to reset the master boot record you could do this:

Download Partition Wizard Bootable CD and burn it to disk.
Re plug your disks so that you have your disk with XP on it as a first device, reset your bios to boot from CDrom first then HDD1 (XP disk)
then run Partition Wizard
If it detects the windows partition (should be marked as primary or active) and click ‘Rebuild MBR’ and click apply.

Thanks guys,

as I do have an XP64 Disk I followed Mark’s instructions, which did the business.

My problem with ‘Virtual’ XPs was that they all generate their own C: drive, from which it is impossible to access other drives on my system, which meant that not only could I not read from or write to my data drive, I couldn’t load the license file for my CAD program. That, and the fact that I’m having a problem getting Linux to ‘see’ the parallel port, where my dongle resides, means I think I’m going to have to settle for a dual boot option for now.

Thanks again for your help.

Tony N

Glad it worked for you, one question though:
I am curious as to what CAD program you are using as I have not seen dongle based licensing management for donkeys years.

Lantek still uses a dongle and I think solid works does too.

It’s actually Zuken Cadstar, I’ve been using it since the days when it was Racal Redac Cadstar (round about 1985) and still have the original MSDOS dongle! They issued a new one when 'Works for Windows was the ‘in’ thing.

I’m now trying to get to grips with “Crossover” but still haven’t managed to get Linux to ‘see’ the parallel port though, or get my license file, (that tells the program which features I have paid to use) into the correct directory.

Tony N