linux install

Hi Mark,
My first foray into the Linux world has let me send you this thank you.
I have managed to lock the OS up and hit the reboot key on the front of the computer which has restarted PeppermintOS. ;D
I may be able to wipe this machine and install Linux only, I will wait until the holidays are over to make sure.
My grandson uses this machine to log into Super Mario, but I think Santa may be bringing him a laptop. ::slight_smile:

take care
Don W

Santa to the rescue :slight_smile:

Yeh, as I said it won’t be as stable from a USB stick as it would from the hard drive due to the lack of a swapfile … technically you could do a “proper” installation to the USB stick (rather than LiveUSB) which would include a swapfile, but probably not worth it unless you intend to run Linux from the USB stick for some extended period … having a swapfile on a USB stick can also shorten the life of the USB stick.

Thanks Mark,
I have just been told that Santa is on his way so I can install Linux on this machine.
This will be a job for after the holidays so you have a nice rest :wink:

take care
Don W

Okey dokey … catch you on the other side of the holidays :slight_smile: … and have fun.

I have peppermint 2 running on a 10 year old IBM laptop with no problems so enjoy the fast start-up and shut down.

Thanks for the encouragement chaps.
I booted with the USB Pendrive this morning and chose Install alongside XP.
I presume I can remove the Pendrive now that PeppermintOS is installed.
I have an Epson Stylus SX130 printer/ scanner and I have a Linux driver for it in my Windross files, I haven’t found out how to copy from “there” to “here”.
I will install the needed bits and pieces later when I have stopped playing around, using stage 5 in the tutorial Mark directed me to.
I was very surprised that I managed an Internet connection so easily, I literally did nothing, it was just there to use, hence this post.
Why it was surprising was I have never managed to get my email connection on this machine and Internet Explorer never seemed to work properly.
I may set up a GMail account.
Thanks again everybody for all your help and encouragement, I will be back when I encounter problems.
take care
Don W
PS I use an IBM keyboard that is at least 15 years old and built like a tank :slight_smile:

Glad to hear it’s going well for you :slight_smile:

Yes, if you’ve installed Peppermint to the hard drive you can remove the LiveUSB stick and boot to the hard drive.

Installing Epson Stylus SX130 printer/ scanner if you go to install printers "menu/system tools/printing you may find that a driver for the printer is already available.

Epson printers are will supported in Linux.

Thanks Tramlink,
Did as you suggested, and printed out a test page,
Everything appears to be working ok.
As this is a printer/scanner I will leave the scanning until tomorrow.

take care
Don W

OK, to install the drivers for the scanner (for an Epson SX130 in PeppermintOS Two, which is based on Ubuntu 11.04 32bit) …

First install the xsane scanning application:

sudo apt-get install xsane

Now you need to install the iScan driver packages … you can either search for them on the Avasys website here:
http://www.avasys.jp/lx-bin2/linux_e/spc/DL1.do
or download the correct ones directly from my dropbox (I can’t post direct links to the drivers from the Avasys website … it doesn’t allow direct linking):

http://dl.dropbox.com/u/11876059/Epson-SX130/iscan-data_1.13.0-1_all.deb
then
http://dl.dropbox.com/u/11876059/Epson-SX130/iscan_2.28.1-3.ltdl7_i386.deb

you can install them by double-clicking the .deb packages … but they must be installed in the order above.

Once installed, start up Xsane, and see if it finds your scanner.

I take it the printer/scanner is connected by USB cable ?


If you already have the printer working I doubt if you need to install the printer driver from Avasys … but I’ll link to it anyway just in case:
http://dl.dropbox.com/u/11876059/Epson-SX130/epson-inkjet-printer-201101w_1.0.0-1lsb3.2_i386.deb

Hi Mark,
I have copied your instructions but have hit a problem.
In terminal, I type
Code:
Do I then press Enter or do I enter
sudo etc and then press enter.?
Sorry for being such a pain.

Don W
EDIT Whatever I do it says Code: Command not found

Duh :-[ :-[ Problem solved
Will get back when I have tried the rest.
thanks
Don W

You’re not being a pain at all … Is the scanner working now ?

[EDIT]

I also meant to ask, how are you finding PeppermintOS ? … has it solved the speed issue you were having with Ubuntu ?

Hi Mark,
I am having some problems
I installed the xsane scanning application as advised.

I had some drivers in ‘Downloads’
/home/don/Downloads/epson-inkjet-printer-201101w_1.0.0-1lsb3.2_i386.deb
/home/don/Downloads/iscan_2.28.1-3_i386.deb
The printer driver I installed last night was the one I got from Avasys and it installed the printer ok.
I printed out the Test page and it was very impressive, however I have printed the latest instructions from you and I am a bit mixed up.

1 I opened ‘Downloads’ , opened the first file (inkjet printer) and clicked on GDebi Package Installer.
It said package already installed ;D I was very happy.
2 However on trying the same with the other package (iscan) I get the error message
"Error: Dependency is not satisfiable: iscan-data

When I try to get the packages from your dropbox I haven’t a clue
So at the moment I am happy the printer prints, but I have no scanning option, and I haven’t tried to send a page from the printer/scanner to my documents as a PDF.
Hope you can help.
take care
Don W

Read the above instructions again … you need to download 2 files, and install them in the order I listed them

BTW, DO NOT use the file you already have (iscan_2.28.1-3_i386.deb) … it is the wrong one … use the ones from the links below.

iscan-data_1.13.0-1_all.deb
THEN
iscan_2.28.1-3.ltdl7_i386.deb

they MUST be installed in that order … here’s the links again:

http://dl.dropbox.com/u/11876059/Epson-SX130/iscan-data_1.13.0-1_all.deb
and
http://dl.dropbox.com/u/11876059/Epson-SX130/iscan_2.28.1-3.ltdl7_i386.deb

If you’re using Firefox, click the above links (one at a time) and select “Save As” … they should then be saved to your Download directory.

Go to your Download directory, and double click the first file and install it … then do the same with the second file.


If it would make things easier, you can do it all from the command line instead … if you wish.

mkdir ~/iscan-temp

then

cd ~/iscan-temp

then

wget http://dl.dropbox.com/u/11876059/Epson-SX130/iscan-data_1.13.0-1_all.deb

then

sudo dpkg -i iscan-data_1.13.0-1_all.deb

then

wget http://dl.dropbox.com/u/11876059/Epson-SX130/iscan_2.28.1-3.ltdl7_i386.deb

then

sudo dpkg -i iscan_2.28.1-3.ltdl7_i386.deb

Now open Xsane and see if the scanner works … if it does, you can delete the temporary directory with

rm -r ~/iscan-temp

Hi Mark,
I used the CLI and typed in the instructions.
The first package installed ok
The second package installed ok
But when I run Xsane I get an error message
Failed to open device 'epkowa:usb:003:002:
Access to resource has been denied
I will get back to this in the morning.

take care
Don W
I enjoyed using the Terminal again. Only 2 mistakes

Can you post the output from these 5 commands

sane-config --version

then

sane-find-scanner

then

scanimage -V

then

scanimage -L

and

groups

Hi Mark,
I hope this helps

When I preview I see nothing, but the files are not installed.
If I type in certain instructions (given) then all should be ok ?

thanks
Don W

OK, run this command:

sudo apt-get install install sane libsane-dev sane-utils

then post the output from those commands again.

Hi Chaps, I had the same dependencies problem when I installed my Epson SX425W. There was a link from the Avasys website to the correct dependencies.

This issue is because peppermint is using a newer version of the program and the driver needs an older version.