Linux Live Boot

Hi everyone I am trying to live boot Linux Mint, Ubuntu or Kali but I cant get neither to work properly. My pc wont live boot any linux distro. I tried on my laptop and it works just fine on my laptop. I can live boot and set up LTS.I thought it was a hardware problem so I contacted my motherboard maker and they did some testing to ensure me that it was not the motherboard.
The error I am getting “Inframs unpacking failed: Decoding Failed” (error hosted at ImgBB — ImgBB) IDK why the screen goes like that (keep in mind the same ISO and USB works on my laptop)
My set up is ;
Aorus elite x570
r5 3600x
corshair 16gb ram
2060 Super

The ultimate aim is to have a dualboot set up with linux(preferably kali) and windows. I have windows running without an issue rn.

Hello Killer(!) - and welcome to the Forum.

As I know nothing about Windows, it might help others to comment if you can tell us if you have Windows on your laptop, too.
Your desktop set up looks astonishingly good to me.


Hello Keith,
Yes my laptop is able to run both Windows and Kali on it. I also tried with Linux mint and it is capable of doing so too.


This sounds like it might be a compression issue … something changed in recent releases which apparently causes problems on some systems. You can test for this by trying an older version. Can you give it a go with the Ubuntu 18.04 live CD, this should be pre- the compression issue. If you get the issue post-install, (i.e. if you install 18, then upgrade to 20) apparently you can fix with (after booting in recovery mode);

sudo sed -i 's/COMPRESS=lz4/COMPRESS=gzip/g' /etc/initramfs-tools/initramfs.conf
sudo update-initramfs -u


I have heard about this issue too but I was not sure if this would solve the issue for Kali or Mint too. I will give this a go. Just to be sure I am meant to live boot 18.04 run the command you have specified and upgrade to 20
I have 2 questions how do I upgrade to 20 and could I upgrade to Kali from 18.04 ubuntu.

When you boot a Linux installer, you should get the opportunity to edit the boot command. Try adding this to the end of the line and see if it helps:


I just got no IRQ handler when I tried to boot 18.4.5 ubuntu. Albeit I tired running live it did not work.

I have 2 questions how do I upgrade to 20 and could I upgrade to Kali from 18.04 ubuntu.

No. my suggestion was to boot / install an “old” version of your distro of choice … then upgrade to the latest version … then IF you have a problem, try the command.
I don’t know if/when the issue cut in for Kali/Mint, but it would seem Ubuntu 18.04 pre-dates the issue.

I’m not sure precisely what the issue is, however I’ve seen the word “bug” mentioned a couple of times in the same context …