linux mint 17 cinnamon - auto wi-fi after resume [UPDATE]

Hi all,
on the previous version LM 16 cinnamon, I had black out problems when I opened the laptop lid from suspend,

I’ve installed the latest release LTS 17 and all these problems have gone and it runs really well, except for one small problem.

When I resume by lifting the lid I get a box asking for authentication to log on to wi-fi, if i click on connect the box keeps reappearing,and it does not connect, if I click on cancel I can then click on the network manager icon on the panel bar, click on my wi-fi address and it connects.

I’ve tried to post a screen shot but the file is too large.

any help welcomed.

Keith

What’s the box expecting ? … your Mint password or your wireless key ?

If it’s your Mint password…

Enter NetworkManager and select to edit your wireless connection … make sure “All users may connect to this network” is ticked.

Are you using auto login ?

wireless key
screenshot should be attatched

i’ll try the screenshot again.

another try

BTW thanks for replying
a bit more info
when I’ve cancelled the box and click on network manager, I only have to tap on my address, and it connects , i do not have to input my key .

clear the boxes

automatically connect
and
All users may connect to this network

and on the Wireless Security tab … remove the password

SAVE the settings.

go back into NetworkManager

re-tick those 2 boxes

and on the Wireless Security tab … enter your wireless key

SAVE the settings

try resuming

Sounds like it might be a bug somewhere in Cinnamon’s settings, but a bug report affecting Mint 16 - Bug #1318893 “Mint 16 64bit wireless wont start after resume fro...” : Bugs : Linux Mint - suggests that it might be a more global issue…

I’d be tempted to wait until final release to see if that issue is ironed out (I haven’t jumped yet, I’ve never really trusted RCs)

@ Mark

tried but with no success

@ Chemicalfan

I think your right, in mint 16 there were issues from resume, but I’m not qualified (plain stupid) to understand.
But if there was a bug, surely i would have thought it would have been sorted b4 the release of 17.

I can live with it for a while and then try peppermint 5 when it comes out to see how that works on this laptop.

thanks

Keith

just in case anyone’s interested
because of something chemicalfan said in an earlier post, I decided to ditch cinnamon and install linux mint 17 mate.
that was over a week ago and I’m pleased to say I’ve had no problems at all.
So its strange one version has problems which the other doesn’t.

Keith

Weird, must be a bug in Cinnamon’s power management then. Power management bugs are a nightmare to investigate, as they can be very hardware specific, but I’m aware of an old Cinnamon bug which originated from a bad port of Gnome’s power management. I thought that had been resolved, but like I said, power management bugs are a right pain to fix sometimes.