Linux NAS Solutions

Hi Guys

I’ve finally managed to bork my Freenas server, it really wasn’t difficult all I tried to do was install a sata drive Freenas wouldn’t recognise the drive I then removed the drive put everything back the way it was and now it won’t boot, I took a backup of the config but that’s useless to me if I can’t get into the system, it’s probably quite fixable by reinstalling Freenas but to be honest I’m not really happy with Freenas, I can’t get my head around the plugin/jail system and I don’t think I ever will

So I’m at a crossroads and thinking of scrapping Freenas in favour of Openmediavault for several reasons but mainly because it’s Linux based (Debian), if not OMV then some kinda Linux solution, so my first question is can I install OMV to usb key or usb hard drive, that’s kinda important because I need to keep all the IDE channels open for storage

If I’m good to install OMV the main problem will be moving all my files over because as it is all the drives are formatted to ufs so OMV won’t read them, there are 5 drives which have all been backed up to a 1tb external usb drive, so the only way I see it would be to install PC-BSD on my PC mount the ext hard drive copy the files off the drive and pass them up to the OMV NAS, unless anyone has a better idea

Any help or advice would be much appreciated

Graeme

What makes you think Linux can’t mount ufs partitions ?

What makes you think Linux can't mount ufs partitions ?

Yeah you’re right but I’m sure I read somewhere that linux can only read ufs partitions not write but I maybe wrong

In Peppermint 4

modinfo ufs

seems to suggest there is a kernel module present … dunno if it’s read/write though

mark@AA1-Blue ~ $ modinfo ufs filename: /lib/modules/3.8.0-35-generic/kernel/fs/ufs/ufs.ko license: GPL srcversion: 89DDD063B186411DD1F6735 depends: intree: Y vermagic: 3.8.0-35-generic SMP mod_unload modversions 686

So only one way to find out…

OK

I’ve went ahead and installed OMV to the NAS, I installed the OS to and external 40gb USB HDD but I cant get it to boot from that drive unless I access the boot menu (F12) and select USB Flash Drive, I’ve tried various things in the bios settings but no joy so far but it must be possible, I have one 500gb drive connected via a SATA controller the drive is recognised but I’m getting an error when I try to mount it so I’ve still got a bit of configuring to do before I get to reformatting the drives and moving the data back over.

as it stands all the drives that have my data on them are disconnected so the data should still be good

I’m having a few problems with OMV, but the immediate one is that I can’t create a file system

I have i 500gb sata drive installed OMV recognises the drive under “Physical Disks” It’s also listed under “Filesystems” as NTFS but if I click on “Create” no drives are listed in the drop down menu as per screenshot

Any help would be much appreciated

Graeme

My guess is you’d have to delete the NTFS partition first (as it’s taking up the whole drive), then cr4eate a new one

Out of interest, Distrowatch have been running a series on distros for home servers - last week and the week before (not sure about this week, haven’t read it yet!). Might be worth reading if you’re not settled on OMV

Hi Chemicalfan

Thanks for that, I have kinda settled on OMV for now, it seems to tick all the boxes, it’s very similar to Freenas without the geeky stuff , but I still have a bit of configuring to do before I’m up and running again, the biggest problem I see at the moment is the switch over from UFS to EXT4, that’s scaring me a bit :slight_smile:

Graeme

If you can’t read UFS in Linux, maybe you can do it in WinLOL
http://ufs2tools.sourceforge.net/

You’ll still need to do some juggling with a spare drive though.

I have a spare 500gb HDD which is the drive I tried to install when I screwed the Freenas system up, I now have that drive installed into OMV and shared although I haven’t yet been able to access it on my PC, so as it stands the original UFS drives containing all my file are so far untouched, I also have a copy of all the files from all the drives backed up to an external USB drive also formatted to UFS.

So once I’ve mounted the 500gb share in my PC I’m gonna have to find a way of mounting the external USB drive so I can copy the files over one drive at a time and clearing & reformatting each drive as I go, there are several ways I can this but I think the easiest way for me would be to install PC-BSD to my PC then mount the USB drive and access the files that way.

I have 2 HDD’s installed on my PC 1 has a Windows 7 and a Peppermint 4 partition, the other drive which is only 40gb has a Peppermint 3 partition so there may be room on that drive to install PC-BSD, alternatively I have a spare 60gb USB HDD but I’m not sure if it’s possible to install PC-BSD on that or if PC-BSD can be run as a live session, but it would be handy to have that drive spare for moving data.

So I’m just taking this one step at a time and open to suggestions

Graeme

According to this:
http://www.livebsd.com/

There are a few BSD “LIVE” options, including PC-BSD

You could either boot it from a LiveCD or install it on the 60gb USB HDD (as long asx your system can boot from USB HDD’s

Then at the very least transfer stuff from a UFS partition to an XFS … Linux can read/write to XFS (after installing xfsprogs if not already installed).

Here’s how I’m thinking of doing this.

I’m currently installing PC-BSD to an old 8.4gb HDD on my PC, once installed I can mount the EXT HDD then copy across the files to the spare 60gb usb HDD, as the contents of some of the folders are larger than 60gb I’ll have to do it in approx 60gb increments, then connect the usb hdd to the OMV server and copy the contents locally to the 500gb drive

is that feasible or is there a better way ?

Graeme

Sounds like a plan

Once you have one of the drives contents copied, use that in place of the of the 60GB so you can copy more in one go

Bet ya wish ya’d chosen XFS in the first place eh :wink:

Bet ya wish ya'd chosen XFS in the first place eh

Is xfs readable in both BSD & Linux ?

Graeme

Well, I’m not sure now ??? … I could have sworn I saw it mentioned in FreeNAS documentation, but according to Wikipedia XFS is only experimental in FreeBSD

Definitely supported in Linux as long as you have xfsprogs installed.

[EDIT]

Embarrassingly, according to this:

FreeNAS only supports UFS and ZFS :o

Yeah I’ve finally managed to install PC-BSD and xfs definitely wasn’t an option.

Anyway I’ve made some progress, PC-BSD is installed and I’ve mounted the 1tb ext hdd and all the files are there, but the 60gb hdd wont mount on any PC so it’s probably knackered, but my daughter has a 250gb ext hdd so I’ll borrow that tomorrow and start copying the files over

the ext hard drive my daughter has is formatted to NTFS, will PC-BSD mount that and if not what file system should I format it to that can be read by PC-BSD & Linux ?

Graeme

I’m going to guess YES

as according to this:

FreeNAS supports NTFS and FAT

UFS2, NTFS and FAT file system support

[EDIT]

See here:
http://forums.pcbsd.org/showthread.php?t=16817

it seems that external ntfs drives are automounted in /media :slight_smile:

Another way I thought of doing this would be to resize the partition on the 1tb drive containing the files leaving enough space to create a new ext4 partition large enough to copy the files over to so I would have 2 sets of identical files on 2 separate partitions on the same drive then when all the files are copies over to OMV I would then just have to delete the ufs partition and extend the ext4 partition to the full size of the drive, that way I wouldn’t have to sync all the files back over to the 1tb drive when everything’s transferred (hope I’ve explained that ok)

The problem with that plan is that I see no way of resizing the partition on the 1tb drive in gparted, the option to resize is greyed out

Could that work ?

Graeme

Not unless gparted in PC-BSD will allow you to resize the UFS partition.