LinuxMint failed boot up!!! HELP

Can anyone help?

I tried to boot my dual pc (Vista- works/Mint- not). All I get is:

No init found. Try passing init= bootarg

Busyboxv1.13.3 (Ubuntu 1:1.13.3-1Ubuntu11)
Built-in shell (ash)
Enter help[for a list of built-in commands
(initrams)

I’m absolutely at a loss, as it worked fine previously.

:frowning: :frowning: :frowning:
Thanks in advance
Umberto

Sounds like the file system has become corrupted somehow (PC turned off from the switch, rather than being closed down properly ?)… try booting from a LiveCD, then open a terminal and enter:

sudo fdisk -l

In the output, look for the Linux partition (Device) marked with * in the boot column… it should have a name like /dev/sda1 or /dev/sda2 etc.

Reboot from the LiveCD again… just to make sure no partitions are mounted.

Open a terminal and enter:

sudo fsck [b]/dev/sdaX[/b]

Obvoiusly you need to change the /dev/sdaX to whatever got listed as the boot partition in the first command.

BE AWARE - If you get a WARNING that the partition is mounted, DO NOT run fsck… exit, reboot to the LiveCD and try again.

Many thanks…Again, Mark.

As far as I know my PC is always shut down correctly. Never by the switch. I wondered if updates to Mint, which had just be downloaded, my have been to blame?

  1. Unfortunately, I’m not in the possesion of a Live CD! (I think I used a memory stick to install, will that do?)
  2. Most (well, nearly all, of what you’ve suggested has gone right over my head! Sorry.

I take it there is nothing I can enter at the command promt? Although recovery mode fails to boot also.

Umberto

Yes a LiveUSB (memory stick) will do fine… just boot to it (all the way to the desktop)

And No, there is no command that will work if the file system is corrupt… it needs to be fixed from a LiveCD/LiveUSB

There is a chance the updates caused the problem though.

the above instructions will become fairly self-explanatory once you start to go through them :wink:

Thanks again, Mark

I’ll give it a try shortly. I think I need to alter the boot sequence i currently have.

I’ll let you know how things go.

Cheers
Rob

Hello

Sorry for the delay in updating! I still haven’t gotten round to booting from the memory stick to cure my Mint issue. With me being slightly (well, considerably) in over my head with this, I was wandering if I could start again. How do I uninstall or delete Mint in its entirity? I will then attempt to start again by re-installing Mint, if I can remember how i did it the first time!!!

Many thanks
Rob

Mint 9 (Isadora) ← Download Link

Check here for installation instructions… they are for Ubuntu 10.04, but as Mint 9 is based on Ubuntu 10.04 it will be very similar if not exactly the same.

http://linux.co.uk/pages/installation/

When you get to step 6 (picture 4), select the same partition you selected the first time (the Linux partition )and when asked, let it format the partition.
(be careful not to select your Windows partition)


Mint 10 (Julia) ← Download Link

(Mint 10 is available as a release candidate at the moment, or the final release version should be available in a week or two)

The installation procedure for Ubuntu 10.10 should be the same as Mint 10 and can be found here:

http://www.ubuntu.com/desktop/get-ubuntu/download

Click the “Show Me How” button at option 4 “Install It!”