live USB or dual boot ?

Hi again,
I’ve just been trying to find how to install a dual boot (pep7 & Win10) on this (Toshiba) laptop, but have found references to using just a live USB instead. There is mention of running from a USB as being much slower than direct from an on-board hard drive. As I’m trying to improve speed (over win10) is the USB option a non starter? Anything else I should be aware of ? (I’ve tried searching the site but obviously the terms I’m searching aren’t the right ones.) Thanks.

Yes, the USB will be slower than installing to the Hard Drive.

There are three types of install to a USB stick.
Normal. This is like using a LiveCD. When you switch off any changes you have made will be lost.
Persistent. This is where you create a separate partition. You can save SOME stuff. It will remain on the partition when you switch off.
Full install. You make a full install to the USB stick. Every change you make will be saved. (Needless to say, you will need a larger USB stick for this.)

Thanks.
I think I’ll try a full install on USB & see if I’m happy with the speed. I try & search how to do this first.
Would an external hard drive be faster than a USB?

Only if it’s USB 3.0, and in a USB 3.0 port.

The Toshiba has a 3.0 port but neither available USB wants to say what it is in its properties. I’ve found Mark’s ‘how to make a persistent USB drive’ in the hints and tips section - working in Ubuntu type disto’s. Still working on that as there are differences to what’s on the screen from what should be. Also the USB i want to use won’t mount on my other (peppermint) lap top. (It works ok in Win 10.) I get the following Mounting Error message;

Error mounting /dev/sdb1 at /media/jahn/76E8-CACF: Command-line `mount -t “exfat” -o “uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,iocharset=utf8,namecase=0,errors=remount-ro,umask=0077” “/dev/sdb1” “/media/jahn/76E8-CACF”’ exited with non-zero exit status 32: mount: unknown filesystem type ‘exfat’

My other USB looks to work ok on both & even gives an option to create a bootable USB on peppermint laptop, but ideally i was wanting to use this one for something else. Help on getting the non compliant USB working would be appreciated. It’s 128 GB, chinesey from fleabay, so maybe that’s it.

mount: unknown filesystem type 'exfat'
The exfat filesystem is not installed in Ubuntu/Peppermint by default. The exFAT is a proprietary and patented by Microsoft. Try to install it:
sudo apt-get install exfat-fuse exfat-utils

Ran your code. USB looks be working now, properties show 137 GB avaiable but not if it’s USB 3.0. Thanks.

Just tried to use the instructions in this post ( https://linuxforums.org.uk/index.php?topic=11106.msg87254#msg87254 - How to create a persistent LiveUSB stick in Ubuntu based distros. ) I used the code to install usb-creator-gtk, but using the menu to find and run “Startup Disk Creator” doesn’t give me the same screen as pictured in that post. There is no “Erase Disk” button, neither is there any option regarding reserved extra space set aside for saving changes. There are just the opening sentance, the two panes and ‘close’ / ‘make start up disc’. As i used select to copy the code to install usb-creator-gtk how come USB creator is different? ???

Which OS/distro/architecture are you running under when you try create the LiveUSB ?

As you’re trying to install usb-creator-gtk I’m going to assume it’s an Ubuntu based distro right ? … which version/architecture ?

eg. Ubuntu 14.04 64bit

Peppermint 7 64bit. installed in the last month.

Don’t use usb-creator-gtk then … instead use the “USB Stick Formatter” to format the USB stick, and “USB Image Writer” to write an ISO to a USB stick.

Both tools are in the Peppermint 7 menu.

Or do you need persistence ?

If so, which OS are you trying to put on the LiveUSB ?

I’m trying to create a persistent USB of peppermint 7, though I had also considered Ubuntu.

Firstly, open a terminal and run these commands in sequence

sudo add-apt-repository ppa:gezakovacs/ppa

then

sudo apt-get update

then

sudo apt-get install unetbootin

Now fire up Unetbootin from the menu…

Now be aware Unetbootin doesn’t currently have a working profile for Peppermint 7 but the Lubuntu 16.04 profile works perfectly with Peppermint 7, so set the Unetbootin Distribution profile to:-
Distribution: Lubuntu ~ Version: 16.04_Live
then point it at the Peppermint 7 ISO image.

https://i.imgur.com/UOs39HF.png

Set the persistence file size (3072MB in the example picture above … remembering there is a 4GB limit)

Then after clicking the “OK” button give it some time … during the file copy stage it will “appear” to hang around the 70% mark, this is normal, during the persistence file creation stage it will appear to hang at 100% again this is normal, just wait and it will finish :wink:

.

Thanks - got as far as pressing ‘ok’ & got a ‘/dev/sbd1’ not mounted error. I’m trying to do this on my Dell (Peppermint os) which i think only has USB 2.0 . My other laptop has a USB 3.0 but is Win 10 os. Is this the problem? I tried both sticks & got the same error (& yes i followed the instruction to remove & re-insert it). I had to reformat one (to fat32) as it wasn’t being recognised at all. Would i just be better off going dual boot? If you remeber this was my original dilema (win 10/ peppermint or Ubuntu).

No, USB 2/3 is unlikely to be the problem…

Insert the USB stick

Then open the file manager, and in the left hand pane click the USB stick to mount it

NOW open Unetbootin and try again.


Do you want instructions for creating a Peppermint LiveUSB with persistence in Windows ?
(actually you should be able to use the Windows version of Unetbootin and the same instructions above)

But if that doesn’t work, there are other tools that can create it.


As for your “dual boot” question - I can’t answer that for you my friend, that’s your decision :wink:

.

Mark,
I use Unetbootin a lot and wouldn’t be without it, but I don’t know what “persistence file size” is. Would you explain for me? Just curious.

Thanks,
Keith

Okay you can have 2 types of LiveUSB

  1. A LiveUSB where everything is forgotten when you reboot … think of it like an unwritable CDROM … so if you create a text file on the desktop, or enter your wireless key, or browse the web, when you next reboot too the LiveUSB the text file will NOT be on the desktop, you will need to re-enter your wireless key, and the browser will have no memory of where you’ve been or any addons you installed.

This is great for security, and okay for a simple installation media, but pretty useless if you want to save files or install apps and not have to redo them next boot.

  1. A LiveUSB “with persistence” … this type of LiveUSB remembers your changes, so the file would still be on the desktop, your wireless key wouldn’t need re-entering, the browser would remember your history/etc. and any installed apps will still be installed.

Now bear in mind that all these “changes” are saved to something called a “persistence file” that is layered on top of the normal (unwritable) Live image amd you get what a “persistence file” is.

Also bear in mind that the file system used for LiveUSB’s is FAT32 so there’s a limit to the size of a persistence file … simply because FAT32 doesn’t allow files larger than 4GB

So if you want your LiveUSB to remember changes, include a persistence file of “up to” 4GB.

Hmmm - this is getting frustating. :cry: Followed your instructions & it seems i created the desired live USB. When Unetbootin finished it gave the instruction to select boot from USB stick when rebooting. Switched off (Dell/pep os) put stick in, switched on & got ‘bios’ like menu that didn’t have this option but did have a count down to auto boot (or some such) - nothing like a bit of pressure when you don’t know what’s going on - so i let it auto. Got a (different) peppermint start screen with a loading bar which stopped at the very last increment & stayed stopped. Got fed up waiting pressed esc & got a lot of code the last bits of whiched showed ‘failed’ on a lot of start commands eg. start file manager. Switched off at the good old standby on/off button.
So here i am again. looks like I may not be getting a choice over dualboot or liveUSB. :frowning:
just thought - is this USB 2/3.0 Issue ? Hesitant about going to my Win 10 laptop with this in case i stuff up somewhere - given problems i seem to be getting.

Did i say i was getting frustrated - should have kept quite, my Dell (pep o/s) committed suicide yesterday evening in a suspicously similar way to it’s forerunner, so I now need to know how make this USB from windows - i think. Help…

See your other topic :slight_smile: