locked out - password not authenticated

I have decided to put these remarks at the head of this post in order to clarify matters. I suspect that my system has been corrupted and no matter the guidance provided nothing worked.

I am confident that in normal circumstances the advice provided by Mark would resolve the problem.

I have just installed Lucid on my partners laptop but did not expect to have to resort to the forum as quick as this. Everything went as expected and on re-booting the system I entered the required password and entered Lucid thinking about doing the required updates.

I noticed that the battery was low so I shut down and connected the power only to find that when I attempted to login again I was totally shut out of Lucid.

I don’t want to remove Lucid so what6 are my options?

OK, the procedure to change a lost password requires that you boot into “single user mode” which is not easy “by design”, but here goes…

Turn ON your PC… as soon as your BIOS POST screen disappears, and you see:

http://linuxforums.org.uk/MGalleryItem.php?id=1122

Press the SHIFT key and you will be presented with the GRUB menu.
(if you get to the screen with the 5 or 6 dots changing colour, you’ve gone too far and will need to try again… timing is everything here, and you hit the Shift key as soon as the BIOS screen disappears)

Select the ‘Default’ Ubuntu kernel (usually the top one), and rather than pressing enter, press E to edit.

You will be presented with a screen like this:

http://linuxforums.org.uk/MGalleryItem.php?id=1152

Press the DOWN ARROW key until you get to the line that starts with:

linux /boot

and press the END key to position the cursor at the end of the that line… it usually ends with “quiet splash”.

Now you can enter additional kernel boot options… the nomodeset option has been added in the above screenshot… but you need to add single init=/bin/bash in its place, so make the end of that line read:

[b]quiet splash single init=/bin/bash[/b]
(doesn't matter if it moves down a line, as long as there is a space between splash and single)

Now hit Ctrl+X to boot.

When you end up at a root prompt, remount the file system read-write with:

mount -o remount,rw /

You can now change the password for your user account with:

passwd

EXAMPLE - On my system I would enter:

passwd mark

to change the password for mark’s account.

You will be asked to enter the password twice for verification, and remember unlike windows you will NOT see **** being entered, in fact you won’t see anything being entered at all as you type in the password, but it IS being entered.

Once done, Ctrl+ Alt+Delete to restart the PC.

Someone has absconded with my lucky white heather. No matter how hard I try I am unable to access the first screen that you give as an example.

I keep getting the dual boot option of Ubuntu & Windows 7. When I start up the system the first thing displayed is the Intel logo and from there it immediately passes on to the dual boot option. One strange thing that I do note is that the circle with the pictograph shows on the bottom bar on the system when ever it asks for a password.

Just when I thought progress was being made in converting my partner over to Ubuntu the door gets shut in my face.

Where do I go from here?

Erm… that IS the GRUB menu :slight_smile:

You would need to highlight the top Ubuntu kernel line at that screen, and select “E” to edit.

BUT, if this is a WUBI installation, I have no idea whether “single user mode” will work or how it will behave, so you may be best uninstalling Ubuntu from the Windows control panel add/remove programs, and reinstalling…

Many thanks for the info. Still having problems as having added the single init=/bin/bash and used Ctrl+X found that at the prompt I was unable to enter any text. Second time round it displayed "target file system does not have bin/bash. Tried again only to have new message :

“bash: cannot set terminal process group (-1): Inappropriate ioctl for device
Bash: no job control in this shell
root@(none):/#”

I can confirm that Lucid was installed as an ext4 partition which I have confirmed by checking with GParted.

I suspect that I will have to remove Lucid and would ask the best method of doing so. Daft question time is it possible to overwrite the ext4 partition rather than remove it and start again?

Again my thanks for your kind reply

I’m going to guess the battery died completely and the system was turned off without a proper shutdown ?

It looks like the file system might be messed up… if it’s a “proper” Linux installation, (ie. not WUBI) try running a fie system check:

  1. Boot to a LiveCD

  2. Open a terminal and enter

sudo fdisk -l

Now determine from the output which is the main Linux partition… something like /dev/sda1

  1. Still in the terminal enter:
fsck /dev/sda1

Obviously edit the /dev/sda1 part to whatever YOUR Linux partition is.

BE AWARE - Don’t mess around in the LiveCD interface before doing the above, or you may mount the hard drive… running fsck on a mounted drive can cause MORE corruption of the filesystem… so do nothing more than boot to the LiveCD desktop, then open a terminal, and enter those commands.

If you’re not sure which partition to run fsck on, send the output from the sudo fdisk -l command, and I’ll tell you what the second command should be.

As far as I know the battery is OK although when I was attempting follow some of your instructions the warning light showed. Stopped everything at that point & charged battery. Might be messed up as you say.

Using a LiveCD and following your instructions the following displayed.

" To run a command as administrator (user “root”), use “sudo ”.
See “man sudo_root” for details.

ubuntu@ubuntu:~$ sudo fdisk -1
fdisk: invalid option – ‘1’

Usage:
fdisk [options] change partition table
fdisk [options] -l list partition table(s)
fdisk -s give partition size(s) in blocks

Options:
-b sector size (512, 1024, 2048 or 4096)
-c switch off DOS-compatible mode
-h print help
-u give sizes in sectors instead of cylinders
-v print version
-C specify the number of cylinders
-H specify the number of heads
-S specify the number of sectors per track

ubuntu@ubuntu:~$

ubuntu@ubuntu:~$ fsck /dev/sda5
fsck from util-linux-ng 2.17.2
e2fsck 1.41.11 (14-Mar-2010)
fsck.ext2: Permission denied while trying to open /dev/sda5
You must have r/w access to the filesystem or be root "

I confirmed the sda5 via GParted. It displayed as ext4 and was of the size I expected from previous checks.

I have come to the conclusion that this laptop is beyond the pale. It will have to go !!! I have reached the end of my tether with this system.

As I can still access XP at the moment I will just work with it while I look at a replacement.

Again my thanks for your assistance.

sudo fdisk -l

That’s a lower case L not a 1 :slight_smile:

and try

sudo fsck /dev/sda5

prefixing a command with sudo gives you root permission.


The fonts can be a little confusing, as a lower case L looks like
l
when displayed as normal text, but

l

when surrounded by "

" tags

That is an ell of a reply. I am thinking of starting a campaign to ban the ell. I have seen this problem raised so many times I should have seen the error of my ways.

You have caught me rushing out to catch a ferry so I will report back later.

Ban the ell - do you think it will catch on??

In this case… “For fsck sake, I’m gonna #!/bin/bash the ell outa my PC”… may be slightly better. :slight_smile:

Mark

Here we go again. Followed your correction and this time it confirmed sda5 and sudo fsck worked.

Went back to your earlier instruction and added “single init=/bin/bash” and Ctrl+X only to once again have the message : “bash: cannot set terminal process group (-1): Inappropriate ioctl for device
Bash: no job control in this shell
root@(none):/#”

at this point nothing I do will let me enter text. In addition it just sits there CTRL ALT DEL will not get me out of things at all. All that I can do is to power off. I don’t know if this is causing more problems than good.

Please clarify for me as I am viewing your instructions on my system and typing the instruction into the other one. In the single init=/bin/bash are there any spaces between=and the end. I have assumed that there are none. When you say Ctrl+X I assumed that it was the Ctrl & X keys to be pressed together. Is this right? I am asking this as I replicated the message that I posted earlier and seek reassurance that I am not totally round the bend.

As to your last post I can only hope that things can get better. Took I look at it and howled !!

Again my thanks for your assistance.

PS If you were not an administrator I would report you for the quality of that pun

Hmm… I just tried the same thing on Lucid, and got the same result… seems it’s done slightly differently in 10.04 (Lucid)

In lucid, just make the end of the linux line read:

[b]quiet splash single[/b]

and hit Ctrl+X to boot (yes both at the same time… put your finger on Ctrl, then whils holding it, hit the X key as well)

You will eventually end up at a blue screen with a grey box with some options… use the down arrow key to scroll right to the bottom “Drop to root shell prompt” option, and hit the Enter key.

You should end up at a promt like this

root@computer-name:~#

now enter:

mount -o remount,rw /

(for clarity… there are NO zero’s in that command)

then

passwd <username>

(eg. passwd mark)

then enter your new password, and hit enter

then when prompted enter it again for verification, and hit enter.

now enter

reboot

and hit enter… to… erm… reboot :slight_smile:

Oh Mark it seems like I keep taking one step back every time I attempt to sort the password out.

Despite following your latest advice to the word the expletive deleted system just keeps running and running but does not deliver anything. Eventually after 3-4 minutes I am once again forced to power off.

It would appear that no matter what you attempt the system rejects it. I think that for our sanity we abandon this. No doubt anyone following this will be able to re-set the password if they hit the identical problem but for reasons totally beyond me this system is not co-operating.

I am going to admit defeat and get a new laptop and start everything fresh. I had been thinking of doing so for my own pleasure so it will not be too much of a pain.

My sincere thanks for all your kind assistance.

Why not just resinstall Ubuntu ?

I had a lot of trouble in the past when I removed a beta from the system and ended up being locked out as the MBR had been changed. I had to resort to external help and really don’t want to go through that again. Even with a complete of backup of documents and pictures safely away from the system I am loath to go down that road.

I really suspect that somehow or other that I have a well messed up laptop and a new one will be the best option.

Okey Dokey… your call :slight_smile:

You’re right… removing Ubuntu WOULD leave the (Windows) partition unbootable, but once you reinstall Ubuntu, GRUB should re-detect it and add it to the boot menu.

Unless of course there is something more serious amiss, such as bad sectors on the hard drive.

GRUB (on a single drive) is pretty easy to fix… as is the XP bootloader…Vista/Win7 a little more involved, though still quite easy.
(though obviously you need the CD’s)
and then there’s always SuperGrub2… which will come to the rescue if/when needed.

BTW, I didn’t mean your battery had died as in… it’s now useless.
I meant died as in ran out of charge, whilst the system was running, so shutting the system down incorrectly.

If nothing else I have learned that by re-installing Ubuntu back on to the system will let me have the dual boot login again. There is something well and truly out of sync on this laptop.

This time when I installed Lucid I accepted the automatic login and initially things worked OK. Rebooted and it looked good. Did the update and then wishing to have the min max and close buttons on the right applied the change. On rebooting this time I was asked for a password for KEYRING DEFAULT to unlock. Applied the password only to have it rejected. In addition this time the wireless network called for the WPA password and this although it was accepted again the keyring default was called for and rejected.

Once again I had to power off to get out of Lucid.

I am convinced that the system is in a complete SNAFU state and don’t wish to risk anything. Once the holiday is over I am hunting for a new laptop. Meanwhile I am turning to drink.

I really feel that this laptop is a lost cause and don’t want to keep pestering you for assistance.

As always my sincere thanks for all your assistance. It is the hardware that has beaten us both.

You’ve selected auto login haven’t you :wink:

It is the wireless connection that is asking for the keyring password… open Network Manager, and delete any wireless connections… manually enter a new wireless connection, and when asked for a keyring password, leave it blank… it will complain about “Unsafe storage” but accept it anyway.

You won’t be asked for a keyring password for the wireless connection again.

Now I am well confused. On my system while at home I have a full auto login for my password and having previously provided my password which is different to the login find that I have immediate access to a wireless connection.

On this system when I established the login I similarly was asked to enter my password for the wireless connection followed up by the WPA & WPA2 password (twice). This was accepted and worked OK. It was only after changes to Lucid requiring that the system be rebooted that the problem arose.

I am a bit unsure as VirginMedia require that I provide them with a password for my wireless connection.
I was under the impression that both were required.

I will give your suggestion a try and see what works and advise back.

You have 3 passwords for a wireless connection

  1. your login password… to get onto the computer.

  2. your keyring password… to allow you to use wireless.

  3. your WPA or WPA2 or WEP key… which is required by your router.

If you had set up your system with auto login OFF, the keyring would have been the same as your login… so the act of logging on would have opened the keyring, and you would never have been asked for the keyring password.

but since you set auto login, opening wireless or creating a wireless connection requires a password.

when creating a new wireless connection you will be asked to provide a NEW keyring password… most people will set this as the same as their login… but this will require you to enter it after every boot.

if you want auto login, AND not be asked for a keyring password, you have to set the keyring password as when you first first set up the wireless connection.

the act of deleting the wireless connection and creating a new one, should prompt you for a new keyring password… this time leave it blank.

or disable auto login… and set the wireless keyring password as the same as your login password.