Lubuntu installation

Dear Forum,
I have read here several plaintiff cries from new Linux users and am heartend by the assistance being offered. And yes, you’ve guessed already: I am a new user with a problem.
Some backgound: I have been writing scientific s/w for some years before retirement and am reasonably familiar with XP Home (even modifying the registry!) but have no knowledge of the mechanics of operating systems, and Linux does seem to need some expertise.
I acquired a distro disc with a Linux magazine and attempted to install Lubuntu 11.04. It ran fine directly from the disc but the installation failed miserably.
The first error message: …comp.bus not detected. Module not inserted.
Then lots more unintelligible ones, but the installation continued until it crashed near the end. Each installation attempt provides some different error messages including a suggestion that my DVD or HD drives are faulty. Not true as I can run Lubuntu from the DVD and can re-install XP SP1. None of the other distros on the disc (Xubuntu 11.04, TinyCore Linux 3.6) will install either.
I would be grateful for advice: should I purchase a Ubuntu disc from a reputable supplier (e.g. CodeSages), try another distro type, or do I have a problem with my system that prevents Linux installation?
My PC is very old: AMD Athlon 1.1GHz with 1G RAM and new 160GB IDE H/D.
Your assistance would be appreciated.

Looking for a solution now … Did it mention SiS630 just prior to “comp.bus not detected” ?

I’m sorry, Mark - the error message was displayed for such a short time that I registered only the last bit.

I don’t think you need to buy a disk, after a quick search for “comp.bus not detected Module not inserted” it seems to be related to the SiS630 motherboard chipset.

Do you know the make/model of your motherboard ?

Just found the owner’s manual for the motherboard.
It is a “BN730E Ultra Motherboard” made by Lex(?).
The manual lists the chipset as “SiS 730S”.
I hope this helps.

OK, I think the best way to go about this is to start from scratch, checking things as we go along.

Download the lubuntu-11.04-desktop-i386.iso disk image from here:
http://lubuntu.lafibre.info/11.04/lubuntu-11.04-desktop-i386.iso

Before burning it to a CD/DVD, check the files MD5 hash/checksum to make sure it isn’t corrupt -
Free MD5 checker for Windows here:
http://www.md5summer.org/

the checksum for lubuntu-11.04-desktop-i386.iso should be:
76e5865ce8d0d08fa9f833d781016fe3

If the checksum is correct… burn it to CD or DVD… Instructions and link to free Windows burning software here:
http://linuxforums.org.uk/general-help-advice/error-message-pxe-e16-media-test-failure/msg25182/#msg25182

Once the CD/DVD is burned… boot to it, and run “Check media for defects”… instructions here:
http://linuxforums.org.uk/general-help-advice/advice-on-setting-up/msg40492/#msg40492

and let us know if there are any errors… if there ARE errors, they may help… if there AREN’T errors, at least we’ve ruled out the installation media.

Meanwhile, I’ll keep looking for any issues connected to the SiS630/730 chipsets, and see if I can find any workarounds.

QUESTION:- You aren’t using RAID are you ?

Ah! A small problem with downloading large files: my broadband is actually narrow band and very unreliable at that as I live miles from the local exchange. After 10pm is the best connection time, but even so, downloading all your recommended files could take a few evenings so please bear with me if my response is slow.
As for RAID arrays: no, I have just the one hard-drive.

Is there any option to check the disk on the coverdisk you have ?

As for RAID arrays: no, I have just the one hard-drive

I didn’t mean are you using an array, but you can still be using software RAID in the BIOS on a single drive… DELL PC’s in particular set this by default, and sometimes require the "“Alternate install CD”.

Is there ANY mention of RAID or SoftwareRAID in you mobo manual ?

Have you tried disableing ACPI in the BIOS, or from the Lubuntu kernel boot parameter… don’t know how you’d do this from your coverdisk, but on a normal disk:
http://linuxforums.org.uk/general-help-advice/no-version-of-linux-will-install-on-my-computer/msg39022/#msg39022
and select the acpi=off option… then boot.

Though I’m semi-convinced this is down to the I/O controller… I’ll keep digging and see what I can find :slight_smile:

I can’t find any reference to RAID in the manual.
Downloading the 680MB file is proving difficult, but I’ll get a colleague in a town served by cable to provide it on a disc - by Wednesday.
ACPI changed OK to “disabled” in the BIOS.
I should mention that I am installing Lubuntu on a spare PC which will need the internet connection for my next installation attempt - so no responses for a while!

Many thanks for your guidance so far.

I wouldn’t leave ACPI permanently disabled in the BIOS… it was just an option for you to try too see if it helped with the install, and if it worked may give us a clue to the issue.

I’ll wait your return then… whenever you’re ready :wink:

Mark,
With ACPI disabled and booting from the DVD gave the error:

Busybox V1.17.1 (Ubuntu 1:1.17.1-10Ubuntu1) built-in shell (ash)
Enter “help” for commands
(initramfs) mount: mounting /dev/loop0 on //filesystem.squashfs failed: input/output error
Can not mount /dev/loop0 (/cdrom//boot/i386.1.Ubuntu/filesystem.squashfs) on //filesystem.squashfs

So I have re-enabled it. But I think I have wrecked the PC as I can no longer connect to the internet for the installation to procede. Ah, me!
My mate has created a DVD with the ISO file - to be delivered Tuesday.

Disabling ACPI, then re-enabling it should make no difference to the hardware, and should have no effect on how the LiveCD works… it sounds more like the CD/DVD drive is having problems reading the CD/DVD… this time just failing at a different place.

It’s not an Eco-disk by any chance is it ?

Mark,
I can’t tell the disc make, but retrying the installation last night repeated a warning that occurred once before:
“I/O error, possibly faulty hard disk or CD/DVD drive” or words to that effect, and recommended cleaning the reading mechanism of the DVD drive.
I shall do that, possibly tomorrowor or Wednesday, and will report back.
My grateful thanks once more for your assistance.

Keith

Have you got a spare DVD drive you can attach to the PC and attempt a test installation ? … if not it may be best to wait till you get that “proper” Ubuntu disk that your friend is burning for you.

The reason I asked if it was an EcoDisc was they are thinner than normal disks, and some (generally older) drives have problems with them… LinuxFormat were using EcoDisc’s for a while (for their coverdisks) and received that many complaints I think they recently switched back to normal disks.

No spares, I’m afraid. - I’m a basic home user.
Your explanation of thin disks sounds like a good one. The drive is of 2000 vintage so could be a problem.
I’m away all day tomorrow and possibly Wednesday but shall report back asap.

Keith

Back home after a few days away.
Whilst away I left the PC with my local PC repair shop to try. They failed, too, but installed Ubuntu (not Lubuntu) apparently succesfully until I booted it up, when the screen image became unstable. So I opted for XP Pro to be installed but took the Ubuntu disc with me.
Back home I tried installing Ubuntu on my own PC with the same result - very unstable with missing icons.
By now I had received the 700MB ISO file and downloaded MD5 to check it. But there is a file association choice - I opted to keep the current one at which I was asked to select the root folder. At this point I have given up as my knowledge is too meagre to understand what is going on.

Next step was to “check the media for defects” as you suggested, and followed your forum post #msg40492. The small icon that was supposed to appear before I should start pressing the space bar did not appear so I rebooted and pressed it anyway - still no joy.
Now I was in hacking mode and selected “Repair broken packages”. 208MB later(!) I rebooted in Recovery Mode(?) which told me it couldn’t use the display and did I want to manually reconfigure: but there was no response to the OK button & I had to reboot.
I soon found myself in command mode reminding me of my Unix days but the only commands I could remember were “ls” & “cd”.

For people following this thread I think the message is: When installing modern s/w, first make sure that your h/w is modern, too!
Rather than waste your generous time any more, I shall have to start from basics and get a book on the subject - can anyone recommend one?
My sincere thanks to Mark for your time and advice - sorry I couldn’t take advantage of it. :-[

Regards,
Keith

very unstable with missing icons

If we’re talking about Ubuntu 11.04…

Sounds like the system is trying to boot into the Unity desktop, with a graphics card that either doesn’t fully support 3D, or is using the wrong drivers.

Try booting into the “Classic” desktop… when you get to the login screen, highlight your username and enter your password, but before hitting enter, look on the panel at the bottom of the screen… click on the “Session” selector, and select “Ubuntu Classic Desktop”… now hit enter to login.

http://linuxforums.org.uk/MGalleryItem.php?id=1441

This should load the GNOME 2 dekktop rather than UNITY, if that works let me know and I’ll tell you how to make GNOME 2 the default desktop.

If it doesn’t… try selecting “Ubuntu Classic Desktop (no effects)”, and let me know if that works

Mark - You’re a genius! The “No Effects” option works perfectly. :slight_smile:
Very many thanks for your help.

Best wishes,
Keith

Best thing to do now would be to see which graphics card you have (so we can check for drivers)… can you open a terminal (Applications > Accessories > Terminal) and enter:

sudo lshw -C display

hit enter and your password when asked.

Be aware, when you enter your password, nothing will display to screen… this is normal, just enter it then hit enter.

Also remember, Linux commands ARE case sensitive… so that’s a capital C

Post back the output from that command… you can copypaste using the mouse.


If there are no better drivers for your graphics card, I’ll tell you how to make the “no effects” desktop the default… so you don’t have to select it every boot.

When rebooting, it selected “No effects” automatically, so no real problem, I guess. Here is the card info anyway:

keith@keith-desktop:~$ Code: [Select]
Code:: command not found
keith@keith-desktop:~$ sudo lshw -C display
[sudo] password for keith:
*-display
description: VGA compatible controller
product: 82865G Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 02
width: 32 bits
clock: 33MHz
capabilities: pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:16 memory:f0000000-f7ffffff memory:ff280000-ff2fffff ioport:ec00(size=8)
keith@keith-desktop:~$