MAJOR problems

My computer suddenly stopped responding when I was clicking on items, so I decided to restart it, and… it wouldn’t boot up! I got my installation USB device I used to put Linux mint onto the computer, and run the boot repair, however it didn’t work and the report from the boot repair mentioned ‘bad superblocks’. So, I tried to reinstall, thinking it would just wipe everything and give us a clean slate again, and it kept getting stuck at the point where it asks you to connect to the internet to get the multimedia codecs, despite being connected to the internet.

I’m using the live USB device right now to make this post. I don’t know if I did something wrong, can’t see how, I only downloaded some stuff from the repositories and browsed youtube some.

I think my hard drive might have actually failed at this point, I could be wrong but it sort of reads that way, maybe erasing windows was the last strain it could take. My 2TB device is going to be on the way within a couple of weeks, so worst case scenario I must wait for it and install onto that. Just as I thought things were looking up, I’d got everyones accounts sorted, downloaded all the software I needed and was just about to work out how steam proton worked… I am disappointed and frustrated right now.

I know it isn’t an issue with the USB device, or else it couldn’t have installed mint in the first place.

Does this sound like catastrophic hard drive failure to you? I suspected it was on it’s way out. Even when it had windows, the number of boot failures and other issues seemed awful even by windows poor standards.

I was just looking at the logs, and most of the errors begin with atal or atal.00

Furthermore it says disk manager failed to start. Does this then mean for sure my hard drive has failed. I’ll take a look in bios and see if that recognises it. If it does I will attempt a format, it can’t break it any more than it is already broken.

It may just be a corrupted file system. See the last two answers to this thread: lenovo - How to Fix Error ata1.00: failed to enable AA (0x1 = error_mask - Ask Ubuntu If that gets it going you’ll be OK until your new drive arrives, otherwise at least you’ve got the live usb.

You can check the condition of a drive with SMART:

Are corrupted filesystems a common occurence? I had assumed that they’d be quite rare considering how stable Linux is said to be. I would have thought a simple reinstall would have solved the problem…

I will give the systemmd-fsck method a go first. Just to make sure I understand properly, I have to press shift (or escape if this doesn’t work) just as the bios is loading, press e to edit boot options, find the line beginning with ‘linux’ and add fsck.mode=force to the end of it, press F10, and then let the program run to repair all disks (in this instance, my hard drive). This method seems to be similar to chkdsk in windows, although I only ever needed to use that ONCE.

Oh, and I probably can’t use SMART because it is supposed to be installed after the main OS is up and running, if I understood that correctly. Whether I get this going again or not, I’ll definitely be most careful about how much software I install on any one day in future, just in case I overwhelmed it or made a mistake. I only encountered a problem though after I installed proton on steam, and installed wine. I might stay away from windows compatibility programs until I’ve gained my footing in Linux. I obviously have a lot to learn here, and I was not expecting to be learning how to fix something so very soon. That said, in another way it is a good thing because it means I will know how to do it in the future if I encounter the same problem again and the solution works.

How does the file system become corrupted in the first place though. I can’t prevent this from happening again unless I understand the cause, and I’d very much like to avoid similar problems in the future.

Another thing worth mentioning is that before the crash, I was looking for the RPG Maker EXE, which was supposed to be in the steam folder, and according to steam it was installed, and yet I could not find it anywhere on the hard drive. I wanted to try and run it through wine because proton had not worked, steam said the program was running, although it was clearly not. This is what makes me suspect either the windows program caused it, or that the hard drive didn’t store the program even though steam thought that it did, because hard drive death was imminent. Either way when this is up and running again (either by repair or replacement) I am taking no chances. If I have to learn another game making software (including how to code), so be it, I don’t want to go through this again.

Thanks for your response by the way, I appreciate it :slight_smile:

Corrupted filesystems can happen, but not often, provided the correct steps are followed. Did you download your .iso via wi-fi or wired? Wired is better. Did you do the MD5 checksum to ensure the numbers matched? You don’t say how you installed Linux either…?

Using Wine, especially for a beginner, can be fraught with problems. Perhaps take time to get used to your new operating system before trying the more advanced stuff?

Hi Helen, how old is your hard disk? Corruption is often associated with some kind of hardware misbehaviour, if you can get your machine to boot from a ‘live’ CD you can check it out with a program called ‘badblocks’. If you run it against your hard disk (you could add -n for non-destructive to add a write-test), this should attempt to read/write every block on your device looking for problems. (check out the ‘man’ page) It takes a while, but it should rule in-out a hardware issue … and if the issue is just a few bad sectors, hopefully it should encourage the drive to re-map them.

Well guys, the problem was so bad with my computer that I am 100% sure it was general hardware failure. In the end, I couldn’t even access bios. No problem with any operating system could have caused that, a corrupted filesystem could have lead to problems with booting and accessing the hard drive, yes, but could not have caused complete failure. So, what I am trying to say is that I certainly do NOT blame Linux for the difficulties I experienced, I blame worn out hardware and possibly my own ignorance.

I’ve had to get a new computer, fortunately it is higher specs than the last one, 8GB RAM, an SSD (which I have researched, and I know now I should never use a disk defragmenter on it because it shortens it’s lifespan and doesn’t yield any extra performance, it is NOT like a HDD and has no moving parts), and a quad core processor. It comes with Windows 10, and is running it without strain to the system despite the usual bloat from Microsoft, actually it seems a bit less bloated than 8.1, and it didn’t come with any anti-spyware other than windows defender. Microsoft edge isn’t too bad either, a massive improvement on Internet explorer. They probably realized that IE was rubbish, was infested with however many bars of stuff nobody wanted, and nobody was using it. I’ve also changed some settings to stop windows from spying, so like, they can get crash reports and info about my hardware, none of which is personal, and a few basics that I had to give them such as my e-mail address to log into my microsoft account, but they already had that information. Thankfully all my important stuff was saved on onedrive, so I did not lose any of that! If I tried to put another OS onto it, it would void my warranty. So, I CANNOT put Linux onto this machine until the warranty runs out. Do I like Windows 10? Yes, but I am aware that it has some flaws and I won’t use it forever. I don’t know if this computer is windows 11 ready or not, if not I will have to change to Linux in 2025 when windows 10 reaches end of life, which will be after my warranty runs out anyway, it lasts for two years.

This said, nothing will stop me from creating a virtual machine in which to learn Linux, it’s obvious that being such a newbie, I had not much clue about what I was doing, and not much idea how to resolve Linux problems (unlike in Windows where there is very little I cannot do by myself). I may, in time, get a secondary machine on which to run Linux, then any serious problems in the virtual machine are confined to that machine and will not affect my Windows. Using a virtual machine while I am learning is going to give me a pretty hefty safety net, so any mistakes won’t result in anything more than having to delete and then re-create the VM. I loved Mint Cinnamon, but it is clear to me that while obtaining software is much easier in Linux, resolving problems is much more difficult (or at least I perceived it to be so because I didn’t know what I was doing).

As for my old computer. I have absolutely no idea how old it was (or the hard drive inside), it was secondhand when I got it. The previous owner had obviously reset windows before selling it on, but how old it was I have no idea. For all I know it could have been a good few years. This makes me glad my new machine is brand new, it should last. Actually I got a very good deal on it, it should have been more than I actually paid. I may see if it is possible to get a new bios chip for it and a new hard drive, see if I can resurrect it for Linux. If it is not possible I may be able to acquire another secondhand computer later down the line. I know Linux is best run on hardware a couple of years old so that the devs have the chance to develop any needed drivers in instances where the manufacturer doesn’t (like, graphics cards).

Oh, and yes I checked the checksum before burning the image, it checked out. I installed using a bootable USB that I made with unetbootin, changed the bios to boot from USB, and followed the installation instructions. All in all the process was quicker than I expected, easier and straightforward.

In any case, thanks for trying to help me diagnose my issues, hopefully my experience in a VM will be much smoother!


I’m pleased that you have resolved your immediate problems - even if it is at the cost of a new machine.
Pleased also that you intend to keep on with Linux with a view to using it in the future. Familiarity is the key to any OS and I am sure that ultimately you will fall for Linux. We hope to see you back here.

As an aside, you may not know that from Windows 10 the Terms & Conditions give the Microsoft the right to monitor users’ keystrokes. For purely technical reasons, of course!


I’d imagine that the monitored keystrokes would be to find the most familiar search terms, therefore giving them info on what people are searching for the most, and therefore which products to advertise and make the most money from. Nothing really shocking there. I see it as a type of market research they’re doing (much like a supermarket wants to know how many of each brand of bread they sell each day so they know what to get in stock), but I do think that they ought to be more upfront about such practices really.

You’re also right about the familiarity aspect too, which is part of the reasons I wish to protect windows until such a time I am actually competent with Linux. I know windows well enough to diagnose and usually resolve problems with little to no help from anyone else (I’ve been doing so since 98SE), but Linux is sufficiently different that I am literally beginning from scratch when it comes to learning about how to actually resolve issues.

One thing has rubbed off on me though depite using Linux for a single day… the concept of repositories. Yesterday I found myself browsing the apps in the Microsoft store, something I have never actually done before, I’d always used the internet to find programs. There is much more free stuff in there than I thought, including over ten possibilities for a video editor. I think I am going to be making use of that feature when possible, perhaps those apps might be better because they’re not only windows compatible, but microsoft approved. Hard to believe that any OS could make me change a lifelong way of doing things in one day, but Linux Mint managed that.

Edit: I just checked if my computer could support windows 11, apparently it meets all of the requirements except one: my processor isn’t on the approved list, despite having four cores (two are the minimum allowed), and being over the 1GHz asked for. Wow, an intel Celeron isn’t on the list, that strikes out a lot of computers then. It’s shocking considering that this machine is brand new. I mean, if it was a couple of years old fair enough, but this processor is still widely used in manufacturing of computers. Sure, it isn’t anything special, and it’s certainly not gaming grade hardware, but it should be good enough really.