Major video lag whilst online?

Ok lots of solutions here, I’ll try them one at a time, but first I have noticed something. I’m just about to uninstall the nVidia accelerated graphics driver (version current). As I was going to press “Remove” I noticed it said… “This driver is activated, but not currently in use.” To double check it wasn’t just because there wasn’t a eligible application running, I closed the “addition drivers” windows and started up LFS in wine, which uses 3D accelerated graphics… I open the additional drivers window again by typing in “addi” in the application lens and selecting. Click on the driver I’m using and it still says it isn’t in use. Maybe this is the problem?

"This driver is activated, but not currently in use."

How did you install the drivers in the first place ?

Try this:

The same fix is mentioned (along with some others) here, but also includes starting in safe graphics mode if necessary:

See my posting here:

about how I installed the drivers.

I’ll give these fixes a try.

Ok I’ve read some of the solutions on reddit, on of them was to check if the drivers has installed properly by using the grep command

cat /var/log/Xorg.0.log | grep nvidia

to which the output should look something similar too:

(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers/
(II) Module nvidia: vendor="NVIDIA Corporation"

What I got was:

[    14.667] (II) LoadModule: "nvidia"
[    14.667] (II) Loading /usr/lib/xorg/extra-modules/
[    14.668] (II) Module nvidia: vendor="NVIDIA Corporation"
[    14.669] (II) Loading /usr/lib/xorg/extra-modules/

So the driver did correctly install. It seems the “driver activated, but not currently in use” is a common bug with nvidia cards and Natty.

Have you tried turning off hardware acceleration in the flashplayer itself ?

I’ll go try that just now.

Disabling hardware acceleration has just made the problem worse. :frowning: I guess I’ll have to try these other drivers I downloaded?

Have you tried the drivers from the nVidia site yet, and the other option I mentioned ?


sudo apt-get install libvdpau1 vdpau-va-driver

Next option would probably be to usinstall ALL traces of flash from within Synaptic, so the only version on your system is the one we put in ~/.mozilla/plugins and see if that works with Firefox.

Next option would be to try another version at that location… maybe the 11 beta, which I’ve still got a copy of if you want

Or ditch 11.04 altogether and try a fresh install of 11.10 which is out now :wink:

I’m going to install the drivers we download just now… wish me luck. >.<

Good Luck :wink:

Right, currently booted up on a LiveCD (for safety sake)… How do I “re-adjust” your terminal command instructions to fit?

You don’t want to install them from a LiveCD ???

Now you tell me… :o Boot up in Low Graphics mode then? Ok doke.

Personally I’d boot normally, remove the drivers that are in Additional drivers, then install/configure the new ones by following the instructions here:

Once you’ve ditched the original drivers, it may also be a good idea to rename your /ect/X11/xorg.conf
and allow the new drivers to create a new one.

Can’t help much more than that ATM … I haven’t got an nVidia card.

Nothing to stop you testing the procedure in a VM first though :wink:

Wish I had read this before I had steamed ahead. A little heads up for anyone doing this. You’ll have to put up into failsafe low graphics mode, because the drivers that come with Ubuntu just freeze up when trying to start with nVidia cards. (I read this in one of the links. Same happened to me and a lot of other people.)

Mark - I can’t seem to get grub to show the menu for Low graphics mode. I’ve tried “Esc” “F12”, “Ctrl+Alt+Esc”, “Ctrl+Alt+F12”, “Alt+Shift+Esc”, “Alt+Shift+F12” & “Alt-F12”… none seem to do anything. I keep pressing them after the BIOS screen repeatly… but it just boots like normal. Any suggestions? I can’t boot up to install the drivers unless I’m in low graphics mode :frowning: On the liveCD atm.

Just turn on the PC, then press and hold Shift till the GRUB menu is displayed.

IT’s always the simple things…

Mark, I can’t install the drivers. Even in failsafe mode.

  ERROR: You appear to be running an X server; please exit X before            
         installing.  For further details, please see the section INSTALLING   
         THE NVIDIA DRIVER in the README available on the Linux driver         
         download page at [url=][/url].

So I must have to install these from a liveCD? It’s the only other way I think it could work. Anyway gonna install the current version back, so I can run normally until we come up with a fix.

Installing from the LiveCD WILL NOT WORK (unless you chroot), as you’ll just be installing the drivers to memory.

You are going to need to boot to a console (CLI), log on, then run:

sudo service gdm stop

To stop X

Then run the commands to install/configure the driver.

then restart X

sudo service gdm start

If you are able to boot to low graphics mode… do it, then hit Ctrl+Alt+F3 to drop to a console

run these commands:

sudo service gdm stop
cd ~/Downloads
sudo ./
sudo nvidia-xconfig
sudo service gdm start

(obviously you’ll have to adjust the .run file name and path if necessary)

FYI, You can get out of the console (as long as X is running) with Ctrl+Alt+F7

Or you could do as it suggests :wink: